HDU1002 A + B Problem II 大数问题

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 409136    Accepted Submission(s): 79277

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

思路:

采用字符数组储存两个加数,模拟小学的加法竖式计算

注意点:

1.俩个加数长度不等的时候,长度短的加数前面加0,0的个数为二者长度相减的绝对值

2.输出格式问题,只有输出最后一组数据的结果的时候,一个回车,其余都是两个回车

代码如下:

#include<bits/stdc++.h>
int main()
{
    int n;
    scanf("%d",&n);
    int y=1;
    while(y<=n)
    {
        char a[1005]= {‘0‘},b[1005]= {‘0‘},C[1005],A[1005],B[1005];
        getchar();
        scanf("%s %s",a,b);
        int l1=strlen(a);
        int l2=strlen(b);
        if(l1>l2)
        {
            int k=l1-l2;
            char d[k];
            for(int i=0; i<k; i++)
                d[i]=‘0‘;
            d[k]=‘\0‘;
            B[0]=‘\0‘;
            strcat(B,d);
            strcat(B,b);
            A[0]=‘\0‘;
            strcat(A,a);
        }
        else if(l1<l2)
        {
            int k=l2-l1;
            char d[k];
            for(int i=0; i<k; i++)
                d[i]=‘0‘;
            d[k]=‘\0‘;
            A[0]=‘\0‘;
            strcat(A,d);
            strcat(A,a);
            B[0]=‘\0‘;
            strcat(B,b);
        }
        else if(l2==l1)
        {
            A[0]=‘\0‘;
            B[0]=‘\0‘;
            strcat(A,a);
            strcat(B,b);
        }
        l1=strlen(A);
        l2=strlen(B);
        int k=0,cc=0;
        for(int i=l1-1,j=l2-1; i>=0&&j>=0; i--,j--)
        {
            int t=A[i]-‘0‘+B[j]-‘0‘+cc;
            if(t>=10)
            {
                cc=1;
                t=t-10;
            }
            else
            {
                cc=0;
            }
            C[k]=t+‘0‘;
            k++;
        }
        if(cc==1)
        {
            C[k]=‘1‘;
            C[k+1]=‘\0‘;
        }
        else
        {
            C[k]=‘\0‘;
        }
        int l3=strlen(C);
        printf("Case %d:\n",y);
        printf("%s + %s = ",a,b);
        for(int i=l3-1; i>=0; i--)
        {
            printf("%c",C[i]);
        }
        printf("\n");
        if(y!=n)
            printf("\n");
        y++;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/yinbiao/p/8728486.html

时间: 2024-11-05 11:47:14

HDU1002 A + B Problem II 大数问题的相关文章

hdu1002 A + B Problem II(大数题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002 A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 230247    Accepted Submission(s): 44185 Problem Description I have a very sim

HDU1002 -A + B Problem II(大数a+b)

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 315214    Accepted Submission(s): 61139 Problem Description I have a very simple problem for you. Given two integers A and B, you

A + B Problem II(大数加法)

一直格式错误,不想改了,没A 1 #include <iostream> 2 #include <stdio.h> 3 #include <string.h> 4 #include <stdlib.h> 5 using namespace std; 6 7 int main() 8 { 9 int T,K=0; 10 scanf("%d",&T); 11 char a[1002],b[1002]; 12 int ta[1002],

(hdu step 2.3.1)A + B Problem II(大数加法)

题目: A + B Problem II Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2372 Accepted Submission(s): 917   Problem Description I have a very simple problem for you. Given two integers A and B, your j

HDU-1002 A + B Problem II

Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, eac

[HDU1002] A + B Problem II

Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines fol

HDU 1023 Train Problem II 大数打表Catalan数

一个出栈有多少种顺序的问题.一般都知道是Catalan数了. 问题是这个Catalan数非常大,故此须要使用高精度计算. 并且打表会速度快非常多.打表公式要熟记: Catalan数公式 Cn=C(2n,n) / (n+1); 递推公式 C(n ) = C(n-1)*(4*n-2) / (n+1) 高精度乘以一个整数和高精度除以一个整数的知识.这样还是使用整数数组比較好计算,假设使用string那么就不太好计算了,由于整数也可能是多位的. const int MAX_N = 101; short

杭电 1002 A + B Problem II(大数处理)

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 209179    Accepted Submission(s): 40226 Problem Description I have a very simple problem for you. Given two integers A and B, yo

HPU 1002 A + B Problem II【大数】

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 261413    Accepted Submission(s): 50581 Problem Description I have a very simple problem for you. Given two integers A and B, yo