POJ3207 Ikki's Story IV - Panda's Trick 【2-sat】

题目

liympanda, one of Ikki’s friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy games and wants to play another game with Ikki.

liympanda has a magic circle and he puts it on a plane, there are n points on its boundary in circular border: 0, 1, 2, …, n ? 1. Evil panda claims that he is connecting m pairs of points. To connect two points, liympanda either places the link entirely inside the circle or entirely outside the circle. Now liympanda tells Ikki no two links touch inside/outside the circle, except on the boundary. He wants Ikki to figure out whether this is possible…

Despaired at the minesweeping game just played, Ikki is totally at a loss, so he decides to write a program to help him.

输入格式

The input contains exactly one test case.

In the test case there will be a line consisting of of two integers: n and m (n ≤ 1,000, m ≤ 500). The following m lines each contain two integers ai and bi, which denote the endpoints of the ith wire. Every point will have at most one link.

输出格式

Output a line, either “panda is telling the truth...” or “the evil panda is lying again”.

输入样例

4 2

0 1

3 2

输出样例

panda is telling the truth...

题解

2-sat裸题

如果两条连线的区间有相交,那么就不能同时在圆的一侧

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define LL long long int
#define REP(i,n) for (int i = 1; i <= (n); i++)
#define Redge(u) for (int k = h[u],to; k; k = ed[k].nxt)
#define BUG(s,n) for (int i = 1; i <= (n); i++) cout<<s[i]<<‘ ‘; puts("");
using namespace std;
const int maxn = 1005,maxm = 1000005,INF = 1000000000;
inline int read(){
    int out = 0,flag = 1; char c = getchar();
    while (c < 48 || c > 57) {if (c == ‘-‘) flag = -1; c = getchar();}
    while (c >= 48 && c <= 57) {out = (out << 3) + (out << 1) + c - ‘0‘; c = getchar();}
    return out * flag;
}
int n,m,h[maxn],ne = 0;
struct EDGE{int to,nxt;}ed[maxm];
inline void build(int u,int v){
    ed[ne] = (EDGE){v,h[u]}; h[u] = ne++;
}
struct node{int l,r;}e[maxn];
inline bool operator <(const node& a,const node& b){
    return a.l == b.l ? a.r < b.r : a.l < b.l;
}
int dfn[maxn],low[maxn],Scc[maxn],scci = 0,cnt = 0,st[maxn],top = 0;
void dfs(int u){
    dfn[u] = low[u] = ++cnt;
    st[++top] = u;
    Redge(u)
        if (!dfn[to = ed[k].to])
            dfs(to),low[u] = min(low[u],low[to]);
        else if (!Scc[to]) low[u] = min(low[u],dfn[to]);
    if (dfn[u] == low[u]){
        scci++;
        do{Scc[st[top]] = scci;}while (st[top--] != u);
    }
}
int main(){
    while (~scanf("%d%d",&n,&m)){
        REP(i,m){
            e[i].l = read(),e[i].r = read();
            if (e[i].l > e[i].r) swap(e[i].l,e[i].r);
        }
        sort(e + 1,e + 1 + m);
        for (int i = 1; i <= m; i++)
            for (int j = i + 1; j <= m; j++)
                if (e[j].l <= e[i].r && e[j].r >= e[i].r){
                    build(2 * i,2 * j - 1),build(2 * j,2 * i - 1);
                    build(2 * i - 1,2 * j),build(2 * j - 1,2 * i);
                }
                else break;
        for (int i = 1; i <= (m << 1); i++) if (!dfn[i]) dfs(i);
        bool flag = true;
        for (int i = 1; i <= m; i++) if (Scc[2 * i] == Scc[2 * i - 1]){
            flag = false; break;
        }
        if (flag) puts("panda is telling the truth...");
        else puts("the evil panda is lying again");
    }
    return 0;
}

POJ3207 Ikki's Story IV - Panda's Trick 【2-sat】

原文地址:https://www.cnblogs.com/Mychael/p/8283237.html

时间: 2024-07-30 10:06:51

POJ3207 Ikki's Story IV - Panda's Trick 【2-sat】的相关文章

poj3207 Ikki&#39;s Story IV - Panda&#39;s Trick

Description liympanda, one of Ikki’s friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy games and wants to play another game with Ikki. liympanda has a magic circle and he put

POJ3207 Ikki&#39;s Story IV – Panda&#39;s Trick

Time Limit: 1000MS   Memory Limit: 131072K Total Submissions: 9426   Accepted: 3465 Description liympanda, one of Ikki’s friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy gam

POJ 3207 Ikki&#39;s Story IV - Panda&#39;s Trick(2 - sat啊)

题目链接:http://poj.org/problem?id=3207 Description liympanda, one of Ikki's friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy games and wants to play another game with Ikki. liy

poj 3207 Ikki&#39;s Story IV - Panda&#39;s Trick【2-set】

题目:poj 3207 Ikki's Story IV - Panda's Trick 题意:给出一个有(0-n-1)组成的圆,然后连接上面的一些点,可以选择从圆内部连接或者内部连接,然后问你所有的都不想交可不可行 分析:对于每条Link,要么在圆外,要么在圆内,且不可同时满足, 只能两者取一,判断这M条Link是否合法,也就是M条Link不冲突, 这就是典型的2-sat问题了. 将每条Link i 看做一个点,如果Link在圆内, 则选做i ,如果在圆外, 则选做i'.对于两条线(i,j) ,

POJ Ikki&#39;s Story IV - Panda&#39;s Trick [2-SAT]

题意: 圆上n个点,m对点之间连边,连在园内或园外,所有边不相交是否可行 发现两对点连线都在内相交则都在外也相交,那么只有一个在内一个在外啦,转化为$2-SAT$问题 #include <iostream> #include <cstdio> #include <cstring> #include <algorithm> #include <cmath> using namespace std; const int N=1005,M=5e5; t

HDU 3207 Ikki&#39;s Story IV - Panda&#39;s Trick(图论-2SAT,图论-tarjan)

Ikki's Story IV - Panda's Trick Time Limit: 1000MS   Memory Limit: 131072K Total Submissions: 7821   Accepted: 2892 Description liympanda, one of Ikki's friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many tim

POJ 3207 Ikki&#39;s Story IV - Panda&#39;s Trick

简单的看了2-sat……似乎还是挺神奇的东西……等大致刷完几道题再来写总结吧! 而这道题……算是2-sat的超级入门题了吧 不过题目大意也是醉了:圆上顺序排列n个点,现要在一些点间连边,规定边只能在圆内或圆外,求有没有可能不相交 .一开始想的是嗷嗷嗷,圆上两个点的连线怎么可能有什么在圆外在圆内之分,不都是弦么?后来才知道……原来两个点的连线不是直线可以使曲线…… 判定是否相交很简单吧……看成是一条直线上四个点,那么如果e1.a<e2.a<e1.b<e2.b就相交啦…… 都说是热身题没多难

POJ 3207 Ikki&#39;s Story IV - Panda&#39;s Trick (2-SAT)

题目地址:POJ 3207 找好矛盾关系,矛盾关系是(2,5)和(3,6)这两个只能一个在外边,一个在里边,利用这个矛盾关系来建图. 可以用在外边和里边来当1和0,最后判断每对是否出现矛盾. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #inc

【POJ】3207 Ikki&#39;s Story IV - Panda&#39;s Trick

http://poj.org/problem?id=3207 题意:一个圆上顺时针依次排列着标号为1-n的点,这些点之间共有m条边相连,每两个点只能在圆内或者圆外连边.问是否存在这些边不相交的方案.(n<=1000, m<=500) #include <cstdio> #include <cstring> #include <algorithm> #include <cmath> #include <iostream> using n