Spring-1-I 233 Matrix(HDU 5015)解题报告及测试数据

233 Matrix

Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?

Input

There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).

Output

For each case, output a n,m mod 10000007.

Sample Input

1 1

1

2 2

0 0

3 7

23 47 16

Sample Output

234

2799

72937

Hint

题解:

  1. 数字范围很大,必须用long long 整型,不然会WA。
  2. 构造矩阵时需要注意233的增长2333=233*10+3。一般情况下,递推的矩阵都可以用使用矩阵快速幂来解决。
  3. 求快速幂的时候,需要注意当前幂指数为奇数的时候的处理。

以下是代码:


1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

56

57

58

59

60

61

62

63

64

65

66

67

68

69

70

71

72

73

74

#include <iostream>

#include <cstdio>

#include <string>

#include <cstring>

#include <algorithm>

#include <cctype>

#include <sstream>

#include <queue>

#include <stack>

#include <stack>

#include <map>

using namespace std;

#define F(i,s,e) for(int i = s;i<e;i++)

#define FA(i,s,e) for(int i=s;i>e;i--)

#define ss(x) scanf("%d",&x)

#define s64(x) scanf("%I64d",&x)

#define write() freopen("1.in","r",stdin)

#define W(x) while(x)

typedef long long LL;

int aa[15];

int N;

const int Mod = 10000007;

struct Matrix{

    LL m[15][15];

    Matrix(){

        memset(m,0,sizeof(m));

    }

};

void init(Matrix&a,int n){//构造初始矩阵

    N = n+2;

    F(i,0,N)F(j,0,N)a.m[i][j]=0;

    F(i,0,n)FA(j,n-1,i-1)a.m[i][j]=1;

    F(i,0,n)a.m[n][i]=1;

    a.m[n][n]=10;

    a.m[n+1][n]=3;

    a.m[n+1][n+1]=1;

}

Matrix mul(Matrix a,Matrix b){//矩阵乘法

    Matrix c;

    F(i,0,N)

    F(j,0,N)

    F(k,0,N)

    c.m[i][j]=(c.m[i][j]+a.m[i][k]*b.m[k][j]) % Mod;

    return c;

}

Matrix power_m(Matrix a,int m){//矩阵快速幂

    Matrix b;

    F(i,0,N)b.m[i][i]=1;

    W(m){

        if(m%2)b = mul(a,b);//如果是奇数,则先乘出

        a = mul(a,a);

        m = m/2;

    }

    return b;

}

int main(){

    //write();

    int n,m;

    LL ans;

    Matrix a,b;

    W(ss(n)!=EOF){

        ss(m);

        F(i,0,n)ss(aa[i]);

        aa[n]=233;aa[n+1]=1;

        ans =0;

        init(a,n);

        b = power_m(a,m);  

        F(i,0,N)ans=(ans+aa[i]*b.m[i][n-1])%Mod;//计算右下角的值

        printf("%I64d\n",ans);

    }  

}

时间: 2024-10-20 14:15:21

Spring-1-I 233 Matrix(HDU 5015)解题报告及测试数据的相关文章

2014 ACM/ICPC Asia Regional Xi&#39;an Online 233 Matrix,hdu 5015

比赛的时候若是这题过了就进前50 刚开始的时候大家的思路都以为是找规律的题目,于是再推公式,此外还发现类似于杨辉三角.于是又去套杨辉三角的通项去求. 于是TLE了无数次.(每次取范围的最大值也要3s多). 对于明显的矩阵样子,其实可以转化为矩阵的运算,每一行的转移.就是对一个转移矩阵的幂运算.然后再用快速矩阵幂即可. A: 10 0 0 1 10 1 0 1 10 1 1 1 0  0  0 1 B: 23 0 0 3 C=A^M  *B,ans=C[N] 教训:对于时间限制,即便是最大数据也要

hdu 2112 HDU Today 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2112 题目意思:又是求最短路的,不过结合埋字符串来考查. 受之前1004 Let the Balloon Rise 学到用map 的解法做之后,有点蠢蠢欲动,当时见到要用字典树做有点吓坏了(之前看过下,非一般难理解,所以暂时放下了).于是,死就死吧,硬住头皮用map做,反反复复修改终于过了. 首先是memory limit exceeded,因为无读清题目意思,直接开10000 * 10000的数组

Winter-2-STL-E Andy&#39;s First Dictionary 解题报告及测试数据

use stringstream Time Limit:3000MS     Memory Limit:0KB Description Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thin

BestCoder17 1002.Select(hdu 5101) 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5101 题目意思:给出 n 个 classes 和 Dudu 的 IQ(为k),每个classes 都有相应的人,每个人又有相应的IQ.现在要求从这些classes挑选两个人,满足IQ之和 > k,不过要满足这两个人不能来自同一个class的. 解题思路不难想出,直接所有人两两之和 > k - 同一个class 两两之和 > k  就是答案了. 不过很容易超时!!!! 用二分就可以过了.二分有

BestCoder18 1002.Math Problem(hdu 5105) 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5105 题目意思:给出一个6个实数:a, b, c, d, l, r.通过在[l, r]中取数 x,使得这个函数 f(x)= |a∗x3+b∗x2+c∗x+d| 最大. 我一开始做的时候,很天真的认为数据量这么小,一个一个试,暴力搜就肯定能得到答案啦.但是一个很严重的问题是,x 没有说是实数还是整数,所以枚举根本不可行. 于是就联想到应该使用高中求一元三次方程的方法来做.我当时是直接从 f(l), f

BestCoder16 1002.Revenge of LIS II(hdu 5087) 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5087 题目意思:找出第二个最长递增子序列,输出长度.就是说,假如序列为 1 1 2,第二长递增子序列是1 2(下标为2 3),而第一长递增子序列也是(下标为 1 3). 我一开始天真的以为,还是利用求最长递增子序列的算法啦,第二长不就是对dp 数组sort完后(从小到大)的dp[cnt-1] 啦,接着就呵呵啦----= = 题解说,要加多一个 dp 数组,以便对当前下标值为 i 的数 a[i] 为结

BestCoder12 1002.Help him(hdu 5059) 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5059 题目意思:就是输入一行不多于 100 的字符串(除了'\n' 和 '\r' 的任意字符),问是否是合法的整数,如果是的话问是否在[a, b] 范围内,是则输出 YES,否则输出 NO 合法的整数:(1)非负整数:只有数字,没有前导0 (2)负数:负号后面只能跟着数字,负号前没有任何字符 首先这条题感觉不是出得太好,不过都是硬着头皮学人家做啦.反正一些很变态的数据可能还是过不了,但却AC的. 模

BestCoder10 1001 Revenge of GCD(hdu 5019) 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5019 题目意思:给出 X 和 Y,求出 第 K 个 X 和 Y 的最大公约数. 例如8 16,它们的公约数依次为1 2 4 8,那么第 3 个 GCD(X, Y) = 2,也就是从后往前数第3个公共因子. TLE思路:求出 X 的所有因子(从小到大开始存储),再从后往前枚举这些因子,检查是否也为 Y 的因子,统计到第 K 个数就是答案了......以为可以顺利通过,原来数据量还是非常大滴!!! 正确

BestCoder10 1001 Revenge of Fibonacci(hdu 5018) 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5018 题目意思:给出在 new Fibonacci 中最先的两个数 A 和 B(也就是f[1] = A, f[2] = B),通过这条式子f[n] = f[n-1] + f[n-2],问 C 是否在这条 new Fibonacci sequence 内.(1 <= A, B, C <= 1 000 000 000) 首先,要想到 C 有可能是 A 或者 B,这种情况也是属于在这个序列范围内的. 还