UVA - 12096 The SetStack Computer(编码,STL)

12096 The SetStack Computer

Background from Wikipedia: “Set theory is a branch of mathematics created principally by the German mathe-matician Georg Cantor at the end of the 19th century.Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics,in
the sense of a theory invoked to justify assumptions made in mathematics concerning the existence of mathe-matical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a foundational role to play as specifying
a theoretical ideal of mathematical rigor in proofs.” Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets in-stead of numbers. The initial SetStack Alpha is under
construction, and they need you to simulate it in order to verify the operation of the prototype. The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The
cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT,and ADD.

? PUSH will push the empty set {} on the stack.

? DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).

? UNION will pop the stack twice and then push the union of the two sets on the stack.

? INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.

? ADD will pop the stack twice, add the first set to the second one, and then push the resulting set

on the stack.

For illustration purposes, assume that the topmost element of the stack is

A = {{},{{}}}

and that the next one is

B = {{},{{{}}}}

For these sets, we have |A| = 2 and |B| = 2. Then:

? UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.

? INTERSECT would result in the set {{}}. The output is 1.

? ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.

Input

An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of eachtest case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack
computer can execute all the commands in the sequence without ever popping an empty stack.

Output

For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be
a line with ‘***’ (three asterisks).

Sample Input

2

9

PUSH

DUP

ADD

PUSH

ADD

DUP

ADD

DUP

UNION

5

PUSH

PUSH

ADD

PUSH

INTERSECT

Sample Output

0

0

1

0

1

1

2

2

2

***

0

0

1

0

0

***

题目大意:集合的运算

有5种操作:

PUSH: 空集“{}”入栈。

DUP:把当前栈顶元素复制一份后再入栈。

UNION:出栈两个集合,然后把二者的并集入栈。

INTERSECT:出栈两个集合,然后把二者的交集入栈

ADD:出栈两个集合,然后把先出栈的加入到后出栈的集合中,把结果入栈。

每次操作后输出栈顶集合的大小。

是集合的集合,为了表示不同的集合,可用一个整型ID表示,比如说用1表示{},集合{{}}就表示成{1},再用2作为其ID。于是题目就成了编码问题,对每个新生成的集合,我们判断该集合是否出现过,若未出现过,就给他分配一个新的ID,出现过的用已有的ID表示。所有集合用map表示集合与ID的对应关系,用一个队列存集合,以便根据ID去集合。

#include<iostream>
#include<set>
#include<vector>
#include<stack>
#include<map>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;

#define ALL(x) x.begin(),x.end()         //表示所有的内容
#define INS(x) inserter(x,x.begin())     //插入迭代器

typedef set<int> Set;
map<Set, int>IDcache;    //把集合映射成ID
vector<Set>Setcache;     //根据ID取集合

//查找给定集合x的ID。如果找不到,分配一个新的ID
int ID(Set x)
{
	if (IDcache.count(x))return IDcache[x];
	Setcache.push_back(x);  //添加新集合
	return IDcache[x] = Setcache.size() - 1;
}

int main()
{
	int casen;
	cin >> casen;
	while (casen--)
	{
		IDcache.clear();
		Setcache.clear();
		stack<int>s;   //集合栈
		int n;
		cin >> n;
		for (int i = 0; i < n; i++)
		{
			string op;
			cin >> op;
			if (op[0] == 'P') s.push(ID(Set()));
			else if (op[0] == 'D') s.push(s.top());
			else
			{
				Set x1 = Setcache[s.top()]; s.pop();
				Set x2 = Setcache[s.top()]; s.pop();
				Set x;
				if (op[0] == 'U') set_union(ALL(x1), ALL(x2), INS(x));
				if (op[0] == 'I') set_intersection(ALL(x1), ALL(x2), INS(x));
				if (op[0] == 'A') { x = x2; x.insert(ID(x1)); }
				s.push(ID(x));
			}
			cout << Setcache[s.top()].size() << endl;
		}
		cout << "***" << endl;
	}
}
时间: 2024-07-31 22:17:56

UVA - 12096 The SetStack Computer(编码,STL)的相关文章

uva 12096 - The SetStack Computer(STL 的运用)

这道题目貌似就是在不停地用STL中的内容,对STL熟练运用的大神估计坐起来会比较easy.. 不过对于我这种看着代码还是需要上网查函数运用的菜鸟来说,若让我自己做这道题,肯定不会使用STL.. 就当对STL的学习了. #include<cstdio> #include<iostream> #include<cstring> #include<string> #include<set> #include<stack> #include&

uva 12096 The SetStack Computer(STL set)

题意: 有5种操作: PUSH:加入"{}"空集合入栈. DUP:栈顶元素再入栈. UNION:出栈两个集合,取并集入栈. INTERSECT:出栈两个集合,取交集入栈. ADD:出栈两个集合,将先出栈的加入到后出栈的集合中. 输入不超过2000, 保证操作顺利进行. 分析: 用set<int>(本身又可以映射成一个int)去模拟集合,所以可以将不同的集合映射成int型. 用一个Map<set<int>,int> 去映射成不同的int. 以后需要se

uva 12096 - The SetStack Computer(STL)

UVA 12096 - The SetStack Computer 题目链接 题意:几个操作,push是在栈顶加入一个空集,dup是复制栈顶集合,在放入栈顶,union是把头两个取并集放回,int是头两个取交集放回,add是取头两个,把第一个当成一个集合加入第二个,每次操作输出栈顶集合的里面的个数 思路:用set,stack模拟,然后利用map去hash一个集合,模拟即可 代码: #include <cstdio> #include <cstring> #include <s

UVAOJ 12096 The SetStack Computer(STL的运用)

12096 The SetStack Computer Background from Wikipedia: Set theory is a branch ofmathematics created principally by the German mathe-matician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play therole of

UVa 12096 The SetStack Computer

Description Background from Wikipedia: "Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational

UVa - 12096 The SetStack Computer(STL容器综合,强推!)

题目链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=42064 #include <iostream> #include <algorithm> #include <string> #include <map> #include <set> #include <vector> #include <stack> #define ALL(x) x.b

12096 - The SetStack Computer UVA

Background from Wikipedia: \Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in m

12096 - The SetStack Computer

The SetStack Computer PS:因为该题排版较麻烦,这里给出OJ网址:UVa12096 - The SetStack Computer 有一个专门为了集合运算而设计的"集合栈"计算机.该机器有一个初始为空的栈,并且支持以下操作. PUSH:空集"{}"入栈. DUP:把当前栈顶元素复制一份后再入栈. UNION:出栈两个集合,然后把二者的并集入栈. INTERSECT:出栈两个集合,然后把二者的交集入栈. ADD:出栈两个集合,然后把先出栈的集合加

UVa - 12096 集合栈计算机(STL)

[题意] 有一个专门为了集合运算而设计的“集合栈”计算机.该机器有一个初始为空的栈,并且支持以下操作:PUSH:空集“{}”入栈DUP:把当前栈顶元素复制一份后再入栈UNION:出栈两个集合,然后把两者的并集入栈,并输出并集的sizeINTERSECT:出栈两个集合,然后把二者的交集入栈,并输出交集的sizeADD:出栈两个集合,然后把先出栈的集合加入到后出栈的集合中,把结果入栈,并输出结果的size       每次操作后,输出栈顶集合的大小(即元素个数).例如栈顶元素是A={ {}, {{}