杭电1013-Digitai Root(这是一道考研编程题-天大2015)

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53625    Accepted Submission(s): 16747

Problem Description

The
digital root of a positive integer is found by summing the digits of
the integer. If the resulting value is a single digit then that digit is
the digital root. If the resulting value contains two or more digits,
those digits are summed and the process is repeated. This is continued
as long as necessary to obtain a single digit.

For example,
consider the positive integer 24. Adding the 2 and the 4 yields a value
of 6. Since 6 is a single digit, 6 is the digital root of 24. Now
consider the positive integer 39. Adding the 3 and the 9 yields 12.
Since 12 is not a single digit, the process must be repeated. Adding the
1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The
input file will contain a list of positive integers, one per line. The
end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24

39

0

Sample Output

6

3

分析:

1  10  19(10)  28(10)  ....

2  11  20        29(11)

3  12  21        30

4  13  22       .....

5  14  23

6  15  24

7  16  25

8  17  26

9  18  27

#include<stdio.h>
#include<string.h>
int main(){
    long int sum,len,i;
    char num[10000];
    while(scanf("%s",num) && num[0]!=‘0‘){
        
        len=strlen(num);
        sum=0;
        for(i=0;i<len;i++)
            sum+=num[i]-‘0‘;
        sum=sum%9;
        if(sum>0)
            printf("%d\n",sum%9);
        else
            printf("9\n");
    }
    return 0;
}

时间: 2024-11-02 17:45:31

杭电1013-Digitai Root(这是一道考研编程题-天大2015)的相关文章

HDU 4902 Nice boat 2014杭电多校训练赛第四场F题(线段树区间更新)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4902 解题报告:输入一个序列,然后有q次操作,操作有两种,第一种是把区间 (l,r) 变成x,第二种是把区间 (l,r) 中大于x的数跟 x 做gcd操作. 线段树区间更新的题目,每个节点保存一个最大和最小值,当该节点的最大值和最小值相等的时候表示这个区间所有的数字都是相同的,可以直接对这个区间进行1或2操作, 进行1操作时,当还没有到达要操作的区间但已经出现了节点的最大值跟最小值相等的情况时,说明

杭电1379(DNA Sorting)java面向对象编程

点击打开链杭电1379 Problem Description One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater t

赛码网的一道百度编程题

最近偶尔接触到这个赛码网,看了百度的一道编程题,于是尝试了一下,发现虽然天天写代码实现这个居然花了我好长时间,仍然没有通过全部案例.目前给的通过率是83% 题目如下: 小B最近对电子表格产生了浓厚的兴趣,她觉得电子表格很神奇,功能远比她想象的强大.她正在研究的是单元格的坐标编号,她发现表格单元一般是按列编号的,第1列编号为A,第2列为B,以此类推,第26列为Z.之后是两位字符编号的,第27列编号为AA,第28列为AB,第52列编号为AZ.之后则是三位.四位.五位--字母编号的,规则类似. 表格单

Digital Roots(杭电1013)(字符串处理)(大数)

Digital Roots Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 50923    Accepted Submission(s): 15890 Problem Description The digital root of a positive integer is found by summing the digits of

杭电 1013 Digital Roots

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1013 反思:思路很简单,但是注意各位数加起来等于10的情况以及输入0的时候结束程序该怎么去表达 #include<stdio.h> #include<string.h> char a[1000000]; int main() { int i; int sum=0; while(gets(a)&&a[0]!='0') { sum=0; for(i=0;a[i]!='\0'

杭电oj1860:统计字符(字符串hash / 水题)

统计字符 题目链接 Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Problem Description 统计一个给定字符串中指定的字符出现的次数 Input 测试输入包含若干测试用例,每个测试用例包含2行,第1行为一个长度不超过5的字符串,第2行为一个长度不超过80的字符串.注意这里的字符串包含空格,即空格也可能是要求被统计的字符之一.当读到'#'时输入结束,相应的结果不要输出.

每天一道算法编程题(1)——网易笔试&quot;工程师工作安排“问题

首先理解题目意思:每个人只能做工作序号表里的一件工作且两个人不能同时做一件工作.AC思路:采用暴力枚举每种可能的分配方案,子问题的解决逐步向上解决了母问题,最终原问题得解. 标程作者:NotDeep(牛客网)链接:https://www.nowcoder.com/discuss/22696?type=6&order=0&pos=5&page=2 1 #include <bits/stdc++.h> 2 3 using namespace std; 4 5 vector&

一道OJ编程题总结

用暴力递归的话,以图中的测试用例为例,先让A号选择0号活,在让2-n 号员工选择1-5号活          有res1种 让A号选择1号活,在让2-n 号员工选择0, 2-5号活       有res2种 让A号选择2号活,在让2-n 号员工选择0-1,3-5号活     有res3种 ... 让A号选择5号活,在让2-n 号员工选择0-4号活            有res5种 res = res1 + res2 + ... + res5 因为前1名员工选择了0活,为了让0不出现在候选列表中

和Fibonacci数列有关的一道入门级编程题

vz9lo7及庇懦佣擞尉<http://weibo.com/20180411pp/230927983159307539320832?=Ro> z5b5tn菊始统沃湍踪<http://weibo.com/20180411p/230927983203570092351488?=5> p4vsuv庇儇们寻乩林<http://weibo.com/uFzp/230927983006954752315392> uyon6b盟菜郴星雷盟<http://weibo.com/p/2