POJ 1573:Robot Motion

Robot Motion

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10267   Accepted: 5001

Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in
which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions
contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions
on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

一道模拟题

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M =1000+5;
int vist[M][M];
char path[M][M];
int step;
int a, b, c;

void dfs(int x, int y)
{
    if(x>0&&x<=a&&y>0&&y<=b)   //判断边界,也就是看他是否出界
    {
        if(!vist[x][y])
        {
            step++;
            vist[x][y]=step;
        }
        else
        {
            printf("%d step(s) before a loop of %d step(s)\n",vist[x][y]-1,step-vist[x][y]+1);
            return ;
        }
    }
    else
    {
        printf("%d step(s) to exit\n",step);
        return ;
    }

    if(path[x][y]=='S')
        dfs(x+1, y);

    if(path[x][y]=='N')
        dfs(x-1, y);

    if(path[x][y]=='W')
        dfs(x, y-1);

    if(path[x][y]=='E')
        dfs(x, y+1);
}

int main()
{
    while(scanf("%d%d%d", &a, &b, &c) &&a &&b &&c)
    {
        step=0;
        memset(vist, 0, sizeof(vist));
        for(int i=1; i<=a; i++)
            for(int j=1; j<=b; j++)
                cin>>path[i][j];
        dfs(1, c);
    }

    return 0;
}

POJ 1573:Robot Motion

时间: 2024-07-28 22:26:14

POJ 1573:Robot Motion的相关文章

poj1573 Robot Motion

题目链接: http://poj.org/problem?id=1573 题目: Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10202   Accepted: 4971 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direct

POJ 1573 Robot Motion(模拟)

题目代号:POJ 1573 题目链接:http://poj.org/problem?id=1573 Language: Default Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 14195   Accepted: 6827 Description A robot has been programmed to follow the instructions in its path. Instr

POJ 1573 Robot Motion【是搜索,就不要纠结是DFS还是BFS】

Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12845   Accepted: 6234 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in

Poj OpenJudge 百练 1573 Robot Motion

1.Link: http://poj.org/problem?id=1573 http://bailian.openjudge.cn/practice/1573/ 2.Content: Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10856   Accepted: 5260 Description A robot has been programmed to follow the instru

POJ 1573 Robot Motion 搜索

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6297    Accepted Submission(s): 2952 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

POJ 1573 &amp; POJ 2632(两道有趣的Robot)

题目链接:POJ 1573 Robot Motion & POJ 2632 Crashing Robots [题意]题意就不说了,有兴趣从链接点进去看吧,就是机器人各种打扫房间,行驶指令. [思路]2632是一道纯模拟题,只要把题意读懂,就可以用代码模拟过程,只是写起来有点蛋疼,代码力还是欠缺啊.而1573感觉挺新奇的,我用的DFS来模拟,好久没有写DFS,一开始又把dir数组写错了,结果总是得出0. 下面贴代码,先是2632的AC代码: 1 /* 2 ** POJ 2632 Crashing

1573 Robot Motion

Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10219   Accepted: 4977 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in

poj1573&amp;&amp;hdu1035 Robot Motion(模拟题)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接: HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1035 POJ:   http://poj.org/problem?id=1573 Description A robot has been programmed to follow the instructions in its path. Instructions for

V-rep学习笔记:Reflexxes Motion Library 2

VREP中的simRMLMoveToPosition函数可以将静态物体按照设定的运动规律移动到指定的目标位置/姿态.If your object is dynamically enabled, it will not work (since in that case the position of the object is dictated by the physics engine). In that case, make sure to uncheck the Body is dynami