Description
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
一开始我是算两点之间的最短路,这样的话每个点就要用两次dijkstra,喜闻乐见的TLE了。翻了翻题解才知道,迪其实是算单源起点到所有点的最短路,而所有牛去目标点算是多个起点到一个终点,所以这里要用到族长的反向之力,把邻接矩阵的两个下标互换就行,这样最多也就用了两次dijlstra。
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1010
#define mod 1000000007
using namespace std;
int map[1005][1005],cost[1005][1005],vis[1005],dis[1005],undis[1005];
int n,m,x;
int dijkstra()
{
int i,j,min,v;
memset(vis,0,sizeof(vis));
for(i=1; i<=n; ++i)
{
dis[i]=map[x][i];
undis[i]=map[i][x];
}
vis[x]=1;
for(i=1; i<=n; ++i)
{
min=INF;
for(j=1; j<=n; ++j)
{
if(!vis[j]&&dis[j]<min)
{
min=dis[j];
v=j;
}
}
vis[v]=1;
for(j=1; j<=n; ++j)
{
if(!vis[j]&&map[v][j]<INF)
{
if(dis[j]>dis[v]+map[v][j])
{
dis[j]=dis[v]+map[v][j];
}
}
}
}
memset(vis,0,sizeof(vis));
vis[x]=1;
for(i=1; i<=n; ++i)
{
min=INF;
for(j=1; j<=n; ++j)
{
if(!vis[j]&&undis[j]<min)
{
min=undis[j];
v=j;
}
}
vis[v]=1;
for(j=1; j<=n; ++j)
{
if(!vis[j]&&map[j][v]<INF)
{
if(undis[j]>undis[v]+map[j][v])
{
undis[j]=undis[v]+map[j][v];
}
}
}
}
int ans=-1;
for(int i=1; i<=n; ++i)
{
if(i!=x)
{
int tmp=dis[i]+undis[i];
ans=max(tmp,ans);
}
}
return ans;
}
int main()
{
scanf("%d%d%d",&n,&m,&x);
int a,b,t;
for(int i=1; i<=n; ++i)
for(int j=1; j<=n; ++j)
if(i!=j)
map[i][j]=INF;
else
map[i][j]=0;
while(m--)
{
scanf("%d%d%d",&a,&b,&t);
map[a][b]=t;
}
printf("%d\n",dijkstra());
return 0;
}