NUC_HomeWork1 -- POJ1068

A - Parencodings

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

 S		(((()()())))
 P-sequence	    4 5 6666  W-sequence	    1 1 1456 

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

今天wj说,这道题模拟就好,用不了多长时间,结果我想了一晚上,用递推的方法做的,不知道他是怎么想的,能A出来,很开心

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 50;

void print(int ans[], int n)///打印函数,其实是在中间查错的时候写的,后来就直接用了
{
     printf("%d", ans[1]);
    for(int i = 2; i <= n; ++i)
    {
        printf(" %d", ans[i]);
    }
    puts("");
}

int main()
{
#ifdef  LOCAL                       ///重定向第一发忘记删了,错了T_T
    freopen("in.txt", "r", stdin);
#endif
    int t, n;
    int arr1[maxn], arr2[maxn], ans[maxn];///我的想法是,预处理arr2数组用以放在此坐标左侧有几个半括号
    bool tag[maxn];                        ///预处理ans数组,每次值变化,都会从“1”开始,然后就处理不是“1”的值
    scanf("%d", &t);                       ///用tag数组标记被处理过的值,
    while(t--)
    {
        memset(tag, false, sizeof(tag));
        scanf("%d", &n);
        for(int i = 1; i <= n; ++i)
            scanf("%d", &arr1[i]);

        ans[1] = 1;
        arr2[1] = arr1[1] - 1;
        for(int i = 2; i <= n; ++i)     ///进行一次预处理,将所有为 “1” 的情形记录
        {
            arr2[i] = arr1[i] - arr1[i-1] - 1;
            arr2[i] = (arr2[i] < 0) ? 0 : arr2[i];
            ans[i] = (arr1[i] > arr1[i-1]) ? 1 : 0;
        }

        int i, k;
        int sum = 0;
        for(i = 2; i <= n; ++i)
        {
            if(ans[i] == 0)
            {
                for(k = i-1; k > 0; --k)              ///往前找无非两种情况可以累加
                {                                      ///没有被标记过的且arr2值为0,和没有被标记过的且arr2值不为0
                    if((tag[k] == false) && (arr2[k] == 0))
                    {
                        sum += ans[k];
                        tag[k] = true;                  ///刚开始也DB了, 用于 “==”,查了半天
                    }
                    else if((tag[k] == false) && arr2[k])
                    {
                        arr2[i] = --arr2[k];
                        arr2[k] = 0;
                        sum += ans[k] + 1;              ///找到arr2值不为‘0’,就arr2值转移到 i 身上。到这步就到底了
                        tag[k] = true;
                        //printf("%d\n", arr2[i]);
                        break;
                    }
                }
                ans[i] = sum;
                sum = 0;
            }
        }

       print(ans, n);
    }
    return 0;
}
时间: 2024-10-24 12:42:36

NUC_HomeWork1 -- POJ1068的相关文章

poj1068题解报告与感想

poj1068描述了这样一个问题:给出一种括号序列的表示形式名叫P序列,规则是统计出每个右括号之前的左括号个数作为序列每项的值.然后要求你根据这个求括号列的W序列值,W序列的规则是统计每一个右括号和与其匹配的左括号之间所有匹配后的括号个数. 刚看到这个题的时候,想法是十分简单的,就是模拟.我先用给的P序列推出括号序列,然后再去求W序列.后来我在discuss区发现一种十分不错的做法,贴在这里. 假定输入的P序列存在数组p中,则p[i]表示第i个P序列元素. 根据P序列的定义,每个数值表示的是当前

poj1068 模拟

Parencodings Time Limit: 1000 MS Memory Limit: 10000 KB 64-bit integer IO format: %I64d , %I64u Java class name: Main [Submit] [Status] [Discuss] Description Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two differen

poj1068解题报告(模拟类)

POJ 1068,题目链接http://poj.org/problem?id=1068 题意: 对于给出给出的原括号串S,对应两种数字密码串P.W: S         (((()()()))) P-sequence      4 5 6666   (Pi表示第i个右括号前面有多少个左括号) W-sequence     1 1 1456    (Wi表示第i个右括号对应它前面的第几个左括号) 要求给出P串,求W. 思路: 1. 模拟类题型.将输入的P串先装换为S串,再由S串得到W串. 2. 左

[POJ1068]Parencodings

试题描述 Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). q By an in

poj1068

#include<iostream> #include<cstring> int num[25],result[25]; char s[150]; int main() { using namespace std; int n,m; cin >> n; while(n--){ cin >> m; for(int i=0;i<m;++i) cin >> num[i]; int ans=0; int t=0; for(int i=0;i<

快速切题 poj1068

Parencodings Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19716   Accepted: 11910 Description Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: q By an integer sequence P = p1 p2...pn

NUC_HomeWork1 -- POJ2067(最短路)

C - Fire Station Description A city is served by a number of fire stations. Some residents have complained that the distance from their houses to the nearest station is too far, so a new station is to be built. You are to choose the location of the f

NUC_HomeWork1 -- POJ1088(DP)

D - 滑雪 Description Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激.可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你.Michael想知道载一个区域中最长底滑坡.区域由一个二维数组给出.数组的每个数字代表点的高度.下面是一个例子 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9 一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小

POJ-1068题

下面的代码是北京大学Online Judge网站上1068题(网址:http://poj.org/problem?id=1068)的所写的代码. 该题的难点在于实现括号匹配,我在代码中采取用-1和1分别代表左右括号,使得括号匹配时各位数相加为0,不匹配时则不为0的方法来判断是否完成括号匹配,代码列表如下: 性能:Memory:704K,Time:0MS #include "iostream" using namespace std; int main() { const int LEF