ACM学习历程—HDU 2795 Billboard(线段树)

Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard,
she would always choose the topmost possible position for the
announcement. Among all possible topmost positions she would always
choose the leftmost one.

If there is no valid location for a new announcement, it
is not put on the billboard (that‘s why some programming contests have
no participants from this university).

Given the sizes of the billboard and the announcements,
your task is to find the numbers of rows in which the announcements are
placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer
numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) -
the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file)
output one number - the number of the row in which this announcement is
placed. Rows are numbered from 1 to h, starting with the top row. If an
announcement can‘t be put on the billboard, output "-1" for this
announcement.

Sample Input

3

5

5

2

4

3

3

Sample Output

1

2

1

3

-1

这个题乍一看10^9次方确实很吓人,但是n最多只有200,000,这样的话,即使每个广告牌占一行,也就前200,000行会被占用, 后面全部打酱油的。

再者,广告牌需要插在能放下它的最前面一行,自然插完这个广告牌,这行的容量就减少了。

最后,看这需要O(nlogn)才能过的,logn查询,总感觉像线段树。

然后稍微一想,就是一个线段树对区间最大值的维护。

起始每个点的值都是w,也就是每段区间的值都是w。
然后根据线段树查询,从左儿子到右儿子查询。
直到查到点对应的区间时,就修改该区间的val值,并返回lt或者rt值。
然而,这题数据规模有点BT,必须任意时候不满足就return -1,不能查到底部才返回。

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <set>
#include <map>
#include <queue>
#include <string>
#include <algorithm>
#define LL long long

using namespace std;

int h, w, n;

//线段树
//区间某点增值,求区间最大值
const int maxn = 200005;
struct node
{
    int lt, rt;
    int val;
}tree[4*maxn];

//向上更新
void pushUp(int id)
{
    tree[id].val = max(tree[id<<1].val, tree[id<<1|1].val);
}

//建立线段树
void build(int lt, int rt, int id)
{
    tree[id].lt = lt;
    tree[id].rt = rt;
    tree[id].val = 0;//每段的初值,根据题目要求
    if (lt == rt)
    {
        tree[id].val = w;
        return;
    }
    int mid = (lt + rt) >> 1;
    build(lt, mid, id<<1);
    build(mid + 1, rt, id<<1|1);
    pushUp(id);
}

//查询某段区间内的符合p的
int query(int lt, int rt, int id, int p)
{
    if (tree[id].val < p)
        return -1;
    if (tree[id].lt == tree[id].rt)
    {
        tree[id].val -= p;
        return tree[id].lt;
    }
    int tmp;
    tmp = query(lt, rt, id<<1, p);
    if (tmp != -1)
    {
        pushUp(id);
        return tmp;
    }
    tmp = query(lt, rt, id<<1|1, p);
    pushUp(id);
    return tmp;
}

void work()
{
    int k, ans;
    int len = min(h, n);
    build(1, len, 1);
    for (int i = 0; i < n; ++i)
    {
        scanf("%d", &k);
        ans = query(1, len, 1, k);
        printf("%d\n", ans);
    }
}

int main()
{
    //freopen("test.in", "r", stdin);
    while (scanf("%d%d%d", &h, &w, &n) != EOF)
    {
        work();
    }
    return 0;
}
时间: 2024-08-30 00:18:13

ACM学习历程—HDU 2795 Billboard(线段树)的相关文章

ACM学习历程—HDU 5289 Assignment(线段树)

Problem Description Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a gr

HDU 2795 Billboard(线段树啊 )

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2795 Problem Description At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements

HDU 2795 Billboard (线段树 单点更新 区间求最大值)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=2795 题意:有一块h*w 的广告版,有n块1*w[i]的广告,就着放广告尽量在顶上,尽量先放左边的原则,问在第几行能把广告放下,如果放不下,就打印-1: 思路:我们可以根据每一行建树,每一个子叶表示每一行的容量,而节点存放子节点的最大值,然后从最顶到底,快速查找能存放下广告的一行. 总之还是简单的线段树问题,难点在于抽象模型. #include <iostream> #include <cs

HDU 2795 Billboard(线段树,单点更新)

D - Billboard Crawling in process... Crawling failed Time Limit:8000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 2795 Appoint description: bupt_admin_13 (2015-07-28) System Crawler (2015-08-18) Description

HDU 2795 Billboard (线段树+贪心)

手动博客搬家:本文发表于20170822 21:30:17, 原地址https://blog.csdn.net/suncongbo/article/details/77488127 URL: http://acm.hdu.edu.cn/showproblem.php?pid=2795题目大意:有一个h*w的木板 (h, w<=1e9), 现在有n (n<=2e5)张1*xi的海报要贴在木板上,按1~n的顺序每次贴海报时会选择最上的一排的最左边贴 (海报不能互相覆盖), 求每张海报会被贴在哪一行

HDU 2795 &lt;Billboard&gt; &lt;线段树单点更新&gt;

Description At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in th

[HDU] 2795 Billboard [线段树区间求最值]

Billboard Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 11861    Accepted Submission(s): 5223 Problem Description At the entrance to the university, there is a huge rectangular billboard of s

HDU 2795 Billboard (线段树单点更新 &amp;&amp; 求区间最值位置)

题意 : 有一块 h * w 的公告板,现在往上面贴 n 张长恒为 1 宽为 wi 的公告,每次贴的地方都是尽量靠左靠上,问你每一张公告将被贴在1~h的哪一行?按照输入顺序给出. 分析 : 这道题说明了每一次贴都尽量选择靠上靠左的位置,那既然这样,我们以1~h建立线段树,给每一个叶子节点赋值初值 w 表示当前行最大能够容纳宽度为 w 的公告纸,那么对于某一输入 wi 只要在线段树的尽量靠左的区间找出能够容纳这张公告的位置(即叶子节点)然后减去 wi 即可,需要对query()函数进行一点改造,将

hdu 2795 Billboard 线段树+二分

Billboard Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Problem Description At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is