HDU 5303 Delicious Apples(贪心 + 背包 2015多校啊)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5303

Problem Description

There are n apple
trees planted along a cyclic road, which is L metres
long. Your storehouse is built at position 0 on
that cyclic road.

The ith
tree is planted at position xi,
clockwise from position 0.
There are ai delicious
apple(s) on the ith
tree.

You only have a basket which can contain at most K apple(s).
You are to start from your storehouse, pick all the apples and carry them back to your storehouse using your basket. What is your minimum distance travelled?

1≤n,k≤105,ai≥1,a1+a2+...+an≤105

1≤L≤109

0≤x[i]≤L

There are less than 20 huge testcases, and less than 500 small testcases.

Input

First line: t,
the number of testcases.

Then t testcases
follow. In each testcase:

First line contains three integers, L,n,K.

Next n lines,
each line contains xi,ai.

Output

Output total distance in a line for each testcase.

Sample Input

2
10 3 2
2 2
8 2
5 1
10 4 1
2 2
8 2
5 1
0 10000

Sample Output

18
26

Source

2015 Multi-University Training Contest 2

题意:

一个长为 L 的环行路线,有 n 颗苹果树,每颗苹果树上有 a[i] 个苹果,一个人在0点(仓库的位置),他有一个篮子,篮子每次最多只能装 k 个苹果,求要装完所有的苹果并且回到仓库的最小路程;给出的苹果树坐标是按顺时针的!

官方题解:

PS:

贪心,把环从中间分为两段,分左右两条线;

利用 a[i] 数组记录每个苹果所在的苹果树的位置,之后再将苹果按照所在的位置进行排序一下,

所以我们就知道了每次摘 k 个苹果的路程是最远的那个苹果所在的位置。

再用 sum[i] 表示摘第 i 个苹果时的最小代价和,

根据背包的思想得到:

if ( i <= k )

sum[i] = d[i]

else

sum[i] = d[i] + sum[i-k]

注意:

还有一种情况是在最后当剩下的苹果少于等于 k 个时,或许一次性绕环一圈拿完最后的k个所需的路程更少;

枚举剩下的最后k个!

代码如下:

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
#define LL __int64
const int maxn = 100047;
vector <int> v1, v2;
LL a[maxn];
LL sum1[maxn], sum2[maxn];

int main()
{
    int t;
    int n, k, l;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&l,&n,&k);
        int pos, num;
        int h = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d",&pos,&num);
            for(int j = 0; j < num; j++)
            {
                a[++h] = pos;
            }
        }
        k = min(h,k);
        v1.clear();
        v2.clear();
        for(int i = 1; i <= h; i++)
        {
            if(a[i]*2 < l)
            {
                v1.push_back(a[i]);
            }
            else
            {
                v2.push_back(l - a[i]);
            }
        }
        memset(sum1,0,sizeof(sum1));
        memset(sum2,0,sizeof(sum2));
        sort(v1.begin(), v1.end());
        sort(v2.begin(), v2.end());
        int len1 = v1.size(), len2 = v2.size();
        for(int i = 0; i < len1; i++)
        {
            int id = i+1;
            if(id <= k)
            {
                sum1[id] = v1[i];
            }
            else
            {
                sum1[id] = v1[i]+sum1[id-k];
            }
        }
        for(int i = 0; i < len2; i++)
        {
            int id = i+1;
            if(id <= k)
            {
                sum2[id] = v2[i];
            }
            else
            {
                sum2[id] = v2[i]+sum2[id-k];
            }
        }

        LL ans = 2*(sum1[len1]+sum2[len2]);//来回
        int t1, t2;
        for(int i = 0; i <= k && i <= len1; i++)
        {
            t1 = len1 - i;
            t2 = len2-(k-i);
            if(t2 < 0)
            {
                t2 = 0;
            }
            ans = min(ans,2*(sum1[t1]+sum2[t2])+l);//最后不足k个绕行一圈全部摘走
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-12-29 04:26:49

HDU 5303 Delicious Apples(贪心 + 背包 2015多校啊)的相关文章

HDU 5303 Delicious Apples (贪心 枚举 好题)

Delicious Apples Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others) Total Submission(s): 199    Accepted Submission(s): 54 Problem Description There are n apple trees planted along a cyclic road, which is L metres l

HDU 5303 Delicious Apples (2015多校第二场 贪心 + 枚举)

Delicious Apples Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others) Total Submission(s): 321    Accepted Submission(s): 95 Problem Description There are  apple trees planted along a cyclic road, which is  metres lon

2015 Multi-University Training Contest 2 hdu 5303 Delicious Apples

Delicious Apples Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)Total Submission(s): 1057    Accepted Submission(s): 354 Problem Description There are n apple trees planted along a cyclic road, which is L metres

hdu 5303 Delicious Apples

这道题贪心 背包 如果在走半圆之内能够装满,那么一定优于绕一圈回到起点.所以我们从中点将这个分开,那么对于每个区间因为苹果数很少,所以可以利用pos[x]数组记录每个苹果所在的苹果树位置,然后将苹果按照所在的位置排序,那么也就是我们知道每次拿k个苹果的代价是苹果所在的最远的位置. 最主要的是为什么这样选择是最优的结果 比如说在一条直线上 pos num 1 4 2 2 3 3 4 4 篮子大小为6 那么我们可以选择先把位置4和位置2的带回家 花费 8 第二次 我们把位置3带回家 花费 6 第三次

多校第二场 1004 hdu 5303 Delicious Apples(背包+贪心)

题目链接: 点击打开链接 题目大意: 在一个周长为L的环上.给出n棵苹果树.苹果树的位置是xi,苹果树是ai,苹果商店在0位置,人的篮子最大容量为k,问最少做多远的距离可以把苹果都运到店里 题目分析: 首先我们能够(ˇ?ˇ) 想-,假设在走半圆之内能够装满,那么一定优于绕一圈回到起点.所以我们从中点将这个圈劈开.那么对于每一个区间由于苹果数非常少,所以能够利用belong[x]数组记录每一个苹果所在的苹果树位置,然后将苹果依照所在的位置排序,那么也就是我们知道每次拿k个苹果的代价是苹果所在的最远

hdu 5303 Delicious Apples(背包)

题意:一个环长度为L,上面有n棵树,篮子一次可装K个苹果: 给出每棵树的位置和树上的苹果数,求将所有苹果运回原点的最少的总距离: 思路:将环分为两半考虑,且若有绕环一圈的情况也只能有一次: 以单个苹果为对象进行处理: 考虑不绕圈的情况:每个半圈优先取最远的苹果:sum[i]表示取第i个苹果是的花费(距离): 考虑绕圈的情况:枚举两个半圈共剩下k个苹果的情况,最后绕一圈: 不绕圈和绕圈中的最小值即为所求值: #include<cstdio> #include<cstring> #in

[多校2015.02.1004 dp] hdu 5303 Delicious Apples

题意: 在一个长度为L的环上有N棵苹果树.你的篮子容量是K个苹果. 每棵苹果树上都有a[i]个苹果. 问你从0点出发最少要走多少距离能拿完所有的苹果. 思路: 我们考虑dp,dp[0][i]代表顺时针取i个苹果的最短距离. dp[1][i]代表逆时针取i个苹果的最短距离. 那么设苹果的总是为sum 那么ans=dp[0][i]+dp[sum-i]  (0<=i<=sum) 代码: #include"stdio.h" #include"algorithm"

HDU 5303 Delicious Apples 美味苹果 (环型序列,逻辑)

题意:给一个长为L的环,起点在12点钟位置,其他位置上有一些苹果,每次带着一个能装k个苹果的篮子从起点出发去摘苹果,要将全部苹果运到起点需要走多少米? 思路:一开始还以为是网络流,建模不了.就感觉是贪心,可是又是个环,有点难搞,直接放弃(生平最讨厌环了,各种情况都要考虑到,就是说你:时钟题!!!). 无论哪处地方,只要苹果数超过k个,那么必须一次专程来运走!所以一开始可以先将他们mod k,去掉的部分先计算出来. 那么剩下的局面再来用贪心来做.苹果树上的苹果拆成单个来看待,最多也才10w个,那么

hdu 5303 Delicious Apples(dp)

题意:一个长为L的圈种上n颗树,每棵树的坐标为xi,结了ai个苹果,用大小为k的篮子把所有苹果装回来,问最少走多少路 解:被神奇的dp教做人了(其实我比较水,本来以为左边贪心一下,右边贪心一下在最后转一圈就搞定的水题=-=) #include <stdio.h> #include <string.h> #include <algorithm> #define ll __int64 #define MIN(a,b) ((a)<(b)?(a):(b)) const i