ZOJ1003: Crashing Balloon

Time Limit: 2 Seconds Memory Limit: 65536 KB

On every June 1st, the Children‘s Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let‘s go!" the two players, who each starts with a score of  "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash.  After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numbers on the balloons he\she‘s crashed.  The unofficial winner is the player who announced the highest score.
Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved.  The player who claims the lower score is entitled to challenge his\her opponent‘s score.  The player with the lower score is presumed to have told the truth, because if he\she were to lie about his\her score, he\she would surely come up with a bigger better lie.  The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player.  So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49.  Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculations that refereeing requires.  Hence the need for you, sober programmer, to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome.

Sample Input

343 49
3599 610
62 36

Sample Output

49
610
62

这道题的难点在于两位选手都可能有多个不同的分解方案,只要其中任何一种分解方案不冲突即是被挑战者赢。参考代码如下:

#include<stdio.h>

bool aTrue, bTrue;
int judge(int m, int n, int p)
{
    if(aTrue) return 0;
    if(m == 1 && n == 1)
    {
        aTrue = true; return 0;
    }
    if(n == 1) bTrue = true;
    while(p > 1)
    {
        if(m%p == 0) judge(m/p, n, p-1);
        if(n%p == 0) judge(m, n/p, p-1);
        p--;
    }
    return 0;
}

int main()
{
    int a, b;
    while(scanf("%d%d", &a, &b)!=EOF)
    {
        if(a < b)
            {int temp = a; a = b; b = temp;}
        aTrue = false; bTrue = false;
        judge(a, b, 100);
        if(!aTrue && bTrue)
            printf("%d\n",b);
        else
            printf("%d\n",a);
    }
    return 0;
}

别人的思路,代码如下:

#include <stdio.h>
int flag1, flag2;	//分别表示n, m是否已被成功分解
void dfs(int n, int m, int fac = 100){
	if(flag1)	//如果n, m均可分解且因子不同
		return;
	if(n == 1 && m == 1){	//n, m均分解完
		flag1 = 1;
		flag2 = 1;
		return;
	}
	if(m == 1){ //m分解完
		flag2 = 1;
	}
	if (fac < 2)
		return;
	if(n % fac == 0)	//精华之处,对同一个因子不同时分解n, m,难点解决
		dfs(n / fac, m, fac - 1);
	if(m % fac == 0)
		dfs(n, m / fac, fac - 1);
	dfs(n, m, fac - 1);
}

int main(){
	int n, m;
	while(~scanf("%d%d", &n, &m)){
		if(m > n){ //交换m, n
			n = m ^ n;
			m = m ^ n;
			n = m ^ n;
		}
		flag1 = 0;
		flag2 = 0;
		dfs(n, m);
		if(flag1 || !flag2)	//如果n成功分解货m无法成功分解
			printf("%d\n", n);
		else
			printf("%d\n", m);
	}
	return 0;
}

关于程序算法艺术与实践更多讨论与交流,敬请关注本博客和新浪微博songzi_tea.

时间: 2024-08-08 01:11:10

ZOJ1003: Crashing Balloon的相关文章

【ZOJ1003】Crashing Balloon(DFS)

Crashing Balloon Time Limit: 2 Seconds      Memory Limit: 65536 KB On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the num

ZOJ1003 Crashing Balloon

Crashing Balloon Time Limit: 2 Seconds      Memory Limit: 65536 KB On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the num

TOJ-1307 Crashing Balloon

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV. The rule is very simple. On the ground there are 100 labeled balloons, with the numbers 1 to 100. After the referee shouts "Let's go!" the two

POJ 2632:Crashing Robots

Crashing Robots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8424   Accepted: 3648 Description In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destination

zoj 1003 Crashing Balloon

#include<stdio.h> #include<algorithm> using namespace std; int fa,fb; void dfs(int a,int b,int k) { if(b==1) { fb=1; if(a==1) fa=1; } if(k==1||(fa&&fb)) return ; if(a%k==0) dfs(a/k,b,k-1); if(b%k==0) dfs(a,b/k,k-1); dfs(a,b,k-1); } int

ZJU-1003 Crashing Balloon dfs,

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3 题意(难以描述):A,B两个人从1~100选数乘起来比谁的大(不能选重复的或者对方选的).数小的人如果发现数大的人在撒谎,则他可以获胜.(当然都没撒谎大数赢,都撒谎了也是大数赢233)而他判断大数撒谎的方法就是找到自己选的一个数,是构成大数所必须的./*给你两个数,由1~100选取不重复的数乘起来得到的.如果小的那个数包含了某个大数必须包含的因子,则*/ 题解:从1到100

1003 Crashing Balloon

考察DFS的应用,判断两个数的因子. 1 #include <stdio.h> 2 3 int f1,f2; 4 5 void DFS(int m,int n,int k){ 6 if(n==1){ 7 f2=1; 8 if(m==1) 9 f1=1; 10 } 11 if(f1&&f2||k==1) 12 return; 13 if(m%k==0) 14 DFS(m/k,n,k-1); 15 if(n%k==0) 16 DFS(m,n/k,k-1); 17 DFS(m,n,k

转载:hdu 题目分类 (侵删)

转载:from http://blog.csdn.net/qq_28236309/article/details/47818349 基础题:1000.1001.1004.1005.1008.1012.1013.1014.1017.1019.1021.1028.1029. 1032.1037.1040.1048.1056.1058.1061.1070.1076.1089.1090.1091.1092.1093. 1094.1095.1096.1097.1098.1106.1108.1157.116

KVM虚拟化:使用qemu-kvm创建和管理虚拟机

CentOS 6加载了KVM模块后,我们是无法进行虚拟机的管理的,如果需要管理KVM虚拟机,还需要管理工具才可以.先看一下KVM的管理工具栈. yum grouplist |grep -i "virtualization" Virtualization: qemu-kvm Virtualization Client: python-virtinst, virt-manager, virt-viewer Virtualization Platform: libvirt, libvirt-