SGU[116] Index of super-prime

Description

描述

Let P1, P2, … ,PN, … be a sequence of prime numbers. Super-prime number is such a prime number that its current number in prime numbers sequence is a prime number too. For example, 3 is a super-prime number, but 7 is not. Index of super-prime for number is 0 iff it is impossible to present it as a sum of few (maybe one) super-prime numbers, and if such presentation exists, index is equal to minimal number of items in such presentation. Your task is to find index of super-prime for given numbers and find optimal presentation as a sum of super-primes.

令P1, P2, ..., PN为一列素数。超级素数是满足当前素数在原有的素数序列中的下标也是素数。例如,3是超级素数,而7不是。某个数字的超级素数索引是0,当且仅当它不能够表示成一系列(也可以是一个)超级素数的和,如果存在这样的表示,这个数字的超级素数索引等于该表示法所使用到的超级素数的个数和的最小值。你的任务是对于给定的数字,找到这样的一个超级素数所以以及最优的表示方法。

Input

输入

There is a positive integer number in input. Number is not more than 10000.

输入包含一个正数,数字不会大于10000。

Output

输出

Write index I for given number as the first number in line. Write I super-primes numbers that are items in optimal presentation for given number. Write these I numbers in order of non-increasing.

第一个数字输出给定数字的超级素数索引。接下来输出超级素数的表示方法,将这I个数字以非递减顺序输出。

Sample Input

样例输入

6

Sample Output

样例输出

2

3 3

Analysis

分析

首先,我们可以根据筛法求出10000以内的素数,接下来我们继续利用筛法,求出这些素数中,下标为素数的超级素数,这样我们就得到了题目中所需要的超级素数。

对于寻找一个最优的组合,我们可以使用0-1背包来解决这个问题,同时记录路径,最后输出最优解即可。

Solution

解决方案

#include <iostream>
#include <memory.h>
#include <vector>
#include <algorithm>

using namespace std;

const int MAX = 10240;

vector<int> P, SP;

int pP[MAX], pSP[MAX], nCnt;
int f[MAX], pPath[MAX];

int main()
{
	int N;
	P.push_back(0); SP.push_back(0);
	memset(pP, 0, sizeof(pP));
	memset(pSP, 0, sizeof(pSP));
	for(int i = 2; i < MAX; i++)
	{
		if(pP[i] == 0)
		{
			P.push_back(i);
			for(int j = i + i; j < MAX; j += i)
			{ pP[j] = 1; }
		}
	}
	for(int i = 2; i < P.size(); i++)
	{
		if(pSP[i] == 0)
		{
			SP.push_back(P[i]);
			for(int j = i + i; j < P.size(); j += i)
			{ pSP[j] = 1; }
		}
	}
	while(cin >> N)
	{
		memset(f, 0, sizeof(f));
		memset(pPath, 0, sizeof(pPath));
		f[0] = 0;
		for(int i = 1; i <= N; i++)
		{ f[i] = 214748364; }
		for(int i = 1; i < SP.size(); i++)
		{
			for(int j = SP[i]; j <= N; j++)
			{
				if(f[j - SP[i]] + 1 < f[j])
				{
					f[j] = f[j - SP[i]] + 1;
					pPath[j] = j - SP[i];
				}
			}
		}
		if(f[N] == 214748364) { cout << 0 << endl; }
		else
		{
			cout << f[N] << endl << N - pPath[N];
			for(int i = pPath[N]; i; i = pPath[i])
			{ cout << " " << i - pPath[i]; }
			cout << endl;
		}
	}
	return 0;

  

这道题目主要考察最为基本的动态规划以及记录路径。

时间: 2024-10-22 11:48:56

SGU[116] Index of super-prime的相关文章

SGU 116 Index of super-prime 数论+完全背包+输出方案

题目链接:http://acm.sgu.ru/problem.php?contest=0&problem=116 题意好晦涩 给你一个不超过一万的数 问它最少可以用多少个“超级素数”来表示 使“超级素数”之和等于它 如果无法这样表示 输出0 否则 按非降序形式输出方案 数论部分就模板的问题 没什么说的 完全背包方面也很常规 说说[输出方案] 背包九讲的伪码给的是二维dp[]的方法 实际上稍加改动就可以用在一维数组上 用一个rec[]记录dp[]的当前状态是从哪个状态转移而来(即上一个状态) 通过

SGU 116

简单DP,可以理解为背包问题的变式.(想当初苯渣会错题意,以为只要输出任意一组解啊!结果一趟DFS在第14个点上WA三次啊!TUT) (第14个点上WA的一定是用贪心或一趟DFS做的!) 首先找到10000以内的super_prime,共201个.(不是打表- -) 这部分代码可以在行到行找到. 然后DP:f[i]代表用最少SUPER_PRIME构成i的数目,prev[i]保存序列. f[i]=f[i-super[j]]+1(如果super[j]<=i,1<=j<=201) #inclu

Index of super-prime - SGU 116(素数+背包)

题目大意:素数表2,3,5,7,11.....如果一个素数所在的位置还是素数,那么这个素数就是超级素数,比如3在第2位置,那么3就是超级素数.....现在给你一个数,求出来这个数由最少的超级素数的和组成,输出这个超级素数. 分析:因为给的数字并不大,所以直接用完全背包求出来即可. 代码如下: =======================================================================================================

HDU 1010 Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. Note: the number of first circle should always be 1. Input n (0 < n <

Application Error - The connection to the server was unsuccessful. (file:///android_asset/www/index.html)

问题描述: PhoneGap+Sencha Touch开发的应用,打包后的APP或者调试期间,在启动的时候提示如下信息: Application Error - The connection to the server was unsuccessful. (file:///android_asset/www/index.html) 问题分析: 这个应该是PhoneGap某些版本的BUG,尤其在index.html加载的内容较多时容易出现. 解决方法: 方法1:更新到PhoneGap的最新版本:

模型类中 Parcelable 接口使用

1 package com.exmyth.ui.model; 2 3 import java.util.ArrayList; 4 import java.util.List; 5 6 public class ProductItem{ 7 //-------------------------以下字段在扫描中需要额外用到------------------------- 8 protected String productId = ""; //产品id,扫描标签时候会返回该字段 9 p

java中的hashcode和euqals的区别和联系

一.equals方法的作用 1.默认情况(没有覆盖equals方法)下equals方法都是调用Object类的equals方法,而Object的equals方法主要用于判断对象的内存地址引用是不是同一个地址(是不是同一个对象). 2 .要是类中覆盖了equals方法,那么就要根据具体的代码来确定equals方法的作用了,覆盖后一般都是通过对象的内容是否相等来判断对象是否相等. 没有覆盖equals方法代码如下: [java] view plaincopy //学生类 public class S

handler的基础应用

包含了handler的三种简单应用 1 public class MainActivity extends Activity implements OnClickListener{ 2 3 private static String TAG = "tag"; 4 private static ImageView img; 5 private Handler handler = new Handler(); 6 private static class handler1 extends

【小笨鸟看JDK1.7集合源码之四】Vector源码剖析

Vector 简介 (1)Vector类也是以数组结构为基础,可以直接使用数组索引进行访问,但是它具有可自由增长的特性: (2)实现了RandomAccess支持随机访问,Cloneable可以实现克隆,Serializable能够被序列化: (3)Vector其实与ArrayList功能类似,但是加入了很多同步语句,因此是线程安全的,适用于多线程环境:但是因为加了同步之后效率会相应降低. JDK1.7-LinkedList源码详细分析 1 public class Vector<E> 2 e