POJ2828 Buy Tickets 【线段树】+【单点更新】+【逆序】

Buy Tickets

Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 12296   Accepted: 6071

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped
the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in
the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i ? 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue
    was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

POJ Monthly--2006.05.28, Zhu, Zeyuan

同样的代码,选择不同的编译器运行时间直接是倍数关系。。

Run ID User Problem Result Memory Time Language Code Length Submit Time
13039660 changmu 2828 Accepted 4536K 1375MS C++ 953B 2014-07-08 00:09:31
13039659 changmu 2828 Accepted 4764K 3391MS G++ 953B 2014-07-08 00:08:47

这题折腾了好久,线段树节点保存的是区间空余线段的数量,由于区间是右开的,所以也可以看作是左端点空闲数量,update函数确定插入区间并更新空闲元素数量(即线段树节点的值),最关键的是在读取完节点后需要逆序插入,比如逆序读取pos, val后说明该点需要插入的位置前面有pos个空位,缕清思路后就该coding了~~

#include <stdio.h>
#define maxn 200002
#define lson l, mid, rt << 1
#define rson mid, r, rt << 1 | 1

struct Node{
	int pos, val;
} arr[maxn];
int tree[maxn << 2], ans[maxn];

void build(int l, int r, int rt)
{
	tree[rt] = r - l;
	if(tree[rt] == 1) return;

	int mid = (l + r) >> 1;
	build(lson);
	build(rson);
}

void update(int pos, int val, int l, int r, int rt)
{
	--tree[rt];
	if(r - l == 1){
		ans[l] = val; return;
	}

	int mid = (l + r) >> 1;
	if(tree[rt << 1] > pos) update(pos, val, lson);
	else update(pos - tree[rt << 1], val, rson);
}

int main()
{
	int n, pos, val, i;
	while(scanf("%d", &n) == 1){
		for(i = 0; i < n; ++i)
			scanf("%d%d", &arr[i].pos, &arr[i].val);

		build(0, n, 1); //注意右端点,线段树存储的是线段信息

		for(i = n - 1; i >= 0; --i)
			update(arr[i].pos, arr[i].val, 0, n, 1);

		for(i = 0; i < n; ++i)
			printf("%d%c", ans[i], i != (n - 1) ? ' ' : '\n');

	}
	return 0;
}

POJ2828 Buy Tickets 【线段树】+【单点更新】+【逆序】,布布扣,bubuko.com

时间: 2024-10-12 15:22:53

POJ2828 Buy Tickets 【线段树】+【单点更新】+【逆序】的相关文章

poj-----(2828)Buy Tickets(线段树单点更新)

Buy Tickets Time Limit: 4000MS   Memory Limit: 65536K Total Submissions: 12930   Accepted: 6412 Description Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue… The Lunar New Year wa

POJ训练计划2828_Buy Tickets(线段树/单点更新)

解题报告 题意: 插队完的顺序. 思路: 倒着处理数据,第i个人占据第j=pos[i]+1个的空位. 线段树维护区间空位信息. #include <iostream> #include <cstdio> #include <cstring> using namespace std; struct node { int x,v; } num[201000]; int sum[1000000],ans[201000]; void cbtree(int rt,int l,in

Minimum Inversion Number(线段树单点更新+逆序数)

Minimum Inversion Number(线段树单点更新+逆序数) Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Description The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy

POJ 2828 Buy Tickets(线段树单点)

https://vjudge.net/problem/POJ-2828 题目意思:有n个数,进行n次操作,每次操作有两个数pos, ans.pos的意思是把ans放到第pos 位置的后面,pos后面的数就往后推一位.最后输出每个位置的ans. 思路:根据题 目可知,最后插入的位置的数才是最终不变的数,所以可以从最后的输入作第1个放入,依此类推,倒插入.在插入时也有一定的技术,首先创建一棵空线段树时,每个节点记录当前范围内有多少个空位置.在插入时,要注意,一个数放入之后那么这个位置就不用管了,那么

poj2828 Buy Tickets (线段树 插队问题)

Buy Tickets Time Limit: 4000MS   Memory Limit: 65536K Total Submissions: 22097   Accepted: 10834 Description Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue… The Lunar New Year w

[POJ2828]Buy Tickets(线段树,单点更新,二分,逆序)

题目链接:http://poj.org/problem?id=2828 由于最后一个人的位置一定是不会变的,所以我们倒着做,先插入最后一个人. 我们每次处理的时候,由于已经知道了这个人的位置k,这个位置表明,在他之前一定有k个空位,于是将他插在第k+1个位置上.我们可以在线段树上直接二分,根据这个位置,假如这个位置在左子树上,那么一直向左走,否则要减掉左子树剩下的位置后再向右边走,同时更新沿途非叶节点的空闲位置数量(减一),手工画一下图就知道了. 1 /* 2 ━━━━━┒ギリギリ♂ eye!

POJ 2828 Buy Tickets (线段树 单点更新 变形)

题目链接 题意:有N个人排队,给出各个人想插队的位置和标识,要求输出最后的序列. 分析:因为之前的序列会因为插队而变化,如果直接算时间复杂度很高,所以可以用 线段树逆序插入,把序列都插到最后一层,len记录该区间里还剩余多少位置,插入的时候就插到剩余的第几个位置, 比如1,2已经插入了,如果再想插入第3个位置,则实际上插入的是5. 因为是逆序的,所以在3之前除了现在的1,2 还有之前的1,2. 1 #include <iostream> 2 #include <cstdio> 3

Buy Tickets+POJ+线段树单点更新的灵活运用

Buy Tickets Time Limit: 4000MS   Memory Limit: 65536K Total Submissions: 12927   Accepted: 6410 Description Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue- The Lunar New Year wa

poj2828 线段树单点更新

Buy Tickets Time Limit: 4000 MS Memory Limit: 65536 KB 64-bit integer IO format: %I64d , %I64u Java class name: Main [Submit] [Status] [Discuss] Description Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up e

POJ 2828 Buy Tickets 线段树解法

此题应用线段树的方法非常巧妙.没做过真的难想得出是这么想的. 是一个逆向思维的运用. 其实一看到这道题目我就想到要运用逆向思维的了,但是就是没那么容易想通的. 思路: 1 要从后面往前更新线段树 2 线段树记录的是当前区间还剩下多少个记录空间 3 因为后面的插入会使得前面的插入往后退,那么前面插入的下标如果大于前面可以插入的空间,就需要往后退了. 好难理解的操作.仔细观察一下下面update这个函数吧. 二分地去查找适合的插入位置,把插入操作时间效率提高到 O(lgn),如果使用一般方法插入操作