Hdu 2899 - Strange fuction 二分/三分求函数极值点

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4527    Accepted Submission(s): 3251

Problem Description

Now, here is a fuction:

F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)

Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

这是一个开口向上的函数,我们只要求这个函数的极(最)小值即可,可以三分直接求,当然也可以先把函数求导,然后二分求解,水题...附上两种解法

//三分求极值
#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
const double INF = 0x7fffffff;
const double eps = 1e-10;
int T;
double Y,X;
double Calc(double x) { return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-Y*x; }
void Search() {
    double l,r,mid,Rmid,MVal,RMVal;
    l = 0;r = 100;
    while(r-l>=eps)
    {
        mid = (l+r)/2.0;Rmid = (mid+r)/2.0;
        MVal = Calc(mid);RMVal = Calc(Rmid);
        if(MVal < RMVal)
        {
            r = Rmid;
        }
        else if(MVal > RMVal)
        {
            l = mid;
        }
        else
        {
            r = mid;
            l = Rmid;
        }
    }
    printf("%.4lf\n",Calc(mid));
}
int main() {
    //freopen("input.in","r",stdin);
    for(scanf("%d",&T);T--;)
    {
        scanf("%lf",&Y);
        Search();
    }
    return 0;
}

//二分求极值
#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
const double INF = 0x7fffffff;
const double eps = 1e-10;
int T;
double Y,X;
double Calc(double x) { return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*pow(x,1)-Y; }
double F(double x) { return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-Y*x; }
void Search(){
    double l,r,mid,MVal;
    l = 0;r = 100;
    while(r-l>=eps)
    {
        mid = (l+r)/2.0;
        MVal = Calc(mid);
        if(MVal > 0)
        {
            r = mid;
        }
        else if(MVal < 0)
        {
            l = mid;
        }
        else break;
    }
    printf("%.4lf\n",F(mid));
}
int main() {
   // freopen("input.in","r",stdin);
    for(scanf("%d",&T);T--;)
    {
        scanf("%lf",&Y);
        Search();
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-25 19:56:54

Hdu 2899 - Strange fuction 二分/三分求函数极值点的相关文章

HDU 2899 Strange fuction 二分

1.题意:给一个函数F(X)的表达式,求其最值,自变量定义域为0到100 2.分析:写出题面函数的导函数的表达式,二分求导函数的零点,对应的就是极值点 3.代码: 1 # include <iostream> 2 # include <cstdio> 3 # include <cmath> 4 using namespace std; 5 const double eps=1e-8; 6 double Y; 7 int sgn(double x) 8 { 9 if(fa

hdu 2899 Strange fuction (二分)

题目链接:http://acm.hdu.edu.cn/showproblem.pihp?pid=2899 题目大意:找出满足F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)的x值.注意精确度的问题. 1 #include <iostream> 2 #include <cstdio> 3 #include <cmath> 4 using namespace std; 5 double y; 6 7 doub

ACM : HDU 2899 Strange fuction 解题报告 -二分、三分

Strange fuction Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5933 Accepted Submission(s): 4194 Problem Description Now, here is a fuction: F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) C

HDU 2899 Strange fuction (模拟退火)

题目链接:HDU 2899 Problem Description Now, here is a fuction: F(x) = 6 * x^7+8x^6+7x^3+5x^2-yx (0 <= x <=100) Can you find the minimum value when x is between 0 and 100. Input The first line of the input contains an integer T(1<=T<=100) which mean

HDU 2899 Strange fuction

Strange fuction Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5253    Accepted Submission(s): 3750 Problem Description Now, here is a fuction:  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=

HDU 2899 Strange fuction(牛顿迭代)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 9333    Accepted Submission(s): 6352 Problem Description Now, here is a fuction:  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)Can you find

HDU 2899 Strange fuction (求导解方程+二分查找)

题目链接:click here~~ [题目大意]: Now, here is a fuction:  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)  Can you find the minimum value when x is between 0 and 100.给你一个方程,求其给定范围内的最小值. [解题思路]: 首先,对该式子,求一阶导,得到F'(x) = 42*x^6 + 48*x^5+21*x^2+10*x-y,这里,我们

hdu 2899 Strange fuction——模拟退火

题目:http://acm.hdu.edu.cn/showproblem.php?pid=2899 还可三分.不过只写了模拟退火. #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> #include<ctime> #include<cmath> #include<cstdlib> #define db double using

hdoj 2899 Strange fuction【二分求解方程】

Strange fuction Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4599    Accepted Submission(s): 3304 Problem Description Now, here is a fuction:  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=