POJ 1328 Radar Installation 【贪心 区间选点】

解题思路:给出n个岛屿,n个岛屿的坐标分别为(a1,b1),(a2,b2)-----(an,bn),雷达的覆盖半径为r

求所有的岛屿都被覆盖所需要的最少的雷达数目。

首先将岛屿坐标进行处理,因为雷达的位置在x轴上,所以我们设雷达的坐标为(x,0),对于任意一个岛屿p(a,b),因为岛屿要满足在雷达的覆盖范围内,所以 (x-a)^2+b^2=r^2,解得

xmin=a-sqrt(r*r-b*b);//即为区间的左端点 xmax=a+sqrt(r*r-b*b);//即为区间的右端点

接下来区间选点即可

------------------------------tmp

1                                                                       a[i]----------------------------b[i]

2                             a[i]--------b[i]

3                                       a[i]-------------------- b[i]

用tmp记录当前雷达坐标,将区间按左端点升序排序后,从左到右扫描,会出现 以上3种情况

1 当前tmp<a[i],雷达无法覆盖到下一个区间,所以增加一个新的雷达,同时更新雷达的坐标为该区间的右端点(贪心,在越右边,越有可能覆盖到下一个区间),即为tmp=b[i]

2 当前b[i]<tmp,雷达无法覆盖该区间,但是该区间被包含在tmp所在区间内,所以不需要增加雷达,更新tmp的值即可 tmp=b[i]

3  该区间被雷达覆盖,不做处理。

Radar Installation

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 55518   Accepted: 12502

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
#include<stdio.h>
#include<string.h>
#include<math.h>
double a[1005],b[1005];
void bubblesort(double a[],double b[],int n)
{
	int i,j;
	double t;
	for(i=1;i<=n;i++)
	{
		for(j=i+1;j<=n;j++)
		{
			if(a[i]>a[j])
			{
				t=a[i];
				a[i]=a[j];
				a[j]=t;

				t=b[i];
				b[i]=b[j];
				b[j]=t;

			}
		}
	}
}
int main()
{
	int n,i,sum,flag,tag=0;
	double x,y,r,tmp;
	flag=1;
	while(scanf("%d %lf",&n,&r)!=EOF&&(n||r))
	{
		tag=0;
		for(i=1;i<=n;i++)
		{
			scanf("%lf %lf",&x,&y);

			if(r>=fabs(y))
			{
			a[i]=x-sqrt(r*r-y*y);
			b[i]=x+sqrt(r*r-y*y);
		    }
		    else
		    tag=1;

		}
		if(tag)//不考虑r<0的情况也能通过
		printf("Case %d: -1\n",flag++);
		else
		{
		  bubblesort(a,b,n);
		  sum=1;
		  tmp=b[1];
		   for(i=2;i<=n;i++)
		    {
			if(a[i]>tmp)
			{
				tmp=b[i];
				sum++;
			}
			else if(b[i]<tmp)
			tmp=b[i];
		    }
		printf("Case %d: %d\n",flag++,sum);
     	}
	}
}

  

时间: 2024-08-07 21:03:39

POJ 1328 Radar Installation 【贪心 区间选点】的相关文章

[ACM] POJ 1328 Radar Installation (贪心,区间选点问题)

Radar Installation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 51131   Accepted: 11481 Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point loca

POJ 1328 Radar Installation 贪心题解

本题是贪心法题解,不过需要自己观察出规律,这就不容易了,很容易出错. 一般网上做法是找区间的方法. 这里给出一个独特的方法: 1 按照x轴大小排序 2 从最左边的点循环,首先找到最小x轴的圆 3 以这个圆判断可以包括右边的多少个圆,直到不可以包括下一个点,那么继续第2步,画一个新圆. 看代码吧,应该很清晰直观的了. 效率是O(n),虽然有嵌套循环,但是下标没有重复,一遍循环就可以了,故此是O(n). #include <stdio.h> #include <cmath> #incl

Poj 1328 Radar Installation 贪心

题目链接:http://poj.org/problem?id=1328 Radar Installation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 52768   Accepted: 11867 Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the othe

poj 1328 Radar Installation(贪心+快排)

Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, s

POJ 1328 Radar Installation 贪心算法

Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, s

POJ 1328 Radar Installation 贪心 难度:1

http://poj.org/problem?id=1328 思路: 1.肯定y大于d的情况下答案为-1,其他时候必定有非负整数解 2.x,y同时考虑是较为麻烦的,想办法消掉y,用d^2-y^2获得圆心允许范围,问题转化为在许多圆心允许范围内取尽可能少的点,也即在许多线段上取尽可能少的点,使得所有线段上都有点被取到 3.从左往右考虑,完全在左边的线段肯定要取点,如果这个点在当前线段上已经取了,明显就可以忽略当前线段,明显在线段上的最优点是右端点 1 #include <iostream> 2

POJ 1328 Radar Installation#贪心(坐标几何题)

(- ̄▽ ̄)-* #include<iostream> #include<cstdio> #include<algorithm> #include<cmath> using namespace std; struct node { double l,r; //找到以岛为圆心,以d为半径的圆与坐标x轴的左交点l.右交点r //雷达只有设在l~r之间,岛才在雷达覆盖范围内 }a[1005]; int cmp(node a,node b) { return a.l

POJ 1328 Radar Installation 雷达安装 贪心问题求解

题目链接: POJ 1328 Radar Installation Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coas

poj1328Radar Installation(贪心—区间选点)

题目链接: 啊哈哈,点我点我 题目: Radar Installation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 52037   Accepted: 11682 Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small isl

[2016-02-04][POJ][1328][Radar Installation]

[2016-02-04][POJ][1328][Radar Installation] Radar Installation Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u Submit Status Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in