hdu 2027 统计元音 (java)

问题:

注意for循环中参数,不要搞混了。

注意空行和换行的区别,题目是讲的不空行,但还是要进行换行。

统计元音

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 45831    Accepted Submission(s): 18695

Problem Description

统计每个元音字母在字符串中出现的次数。

Input

输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串。

Output

对于每个测试实例输出5行,格式如下:

a:num1

e:num2

i:num3

o:num4

u:num5

多个测试实例之间由一个空行隔开。

请特别注意:最后一块输出后面没有空行:)

Sample Input

2
aeiou
my name is ignatius

Sample Output

a:1
e:1
i:1
o:1
u:1

a:2
e:1
i:3
o:0
u:1

代码:

import java.util.*;

public class Main{
	public static void main(String args[]){
		Scanner cin=new Scanner(System.in);
		int n=cin.nextInt();
		String s;
		cin.nextLine();
		for(int i=0;i<n;i++){
			int n1=0,n2=0,n3=0,n4=0,n5=0;
			s=cin.nextLine();
			char[] a=s.toCharArray();
			for(int j=0;j<s.length();j++){
				if(a[j]=='a')
					n1=n1+1;
				else if(a[j]=='e')
					n2=n2+1;
				else if(a[j]=='i')
					n3++;
				else if(a[j]=='o')
					n4++;
				else if(a[j]=='u')
					n5++;
			}
			if(i==n-1)
				System.out.println("a:"+n1+"\r\n"+"e:"+n2+"\r\n"+"i:"+n3+"\r\n"+"o:"+n4+"\r\n"+"u:"+n5);
			else
				System.out.println("a:"+n1+"\r\n"+"e:"+n2+"\r\n"+"i:"+n3+"\r\n"+"o:"+n4+"\r\n"+"u:"+n5+"\r\n");
		}
	}
}
时间: 2024-10-10 00:14:22

hdu 2027 统计元音 (java)的相关文章

hdu 2027 统计元音

统计元音 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 58391    Accepted Submission(s): 23254 Problem Description 统计每个元音字母在字符串中出现的次数. Input 输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串. Output 对于每个测

HDOJ 2027 统计元音

统计元音 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 37878    Accepted Submission(s): 15559 Problem Description 统计每个元音字母在字符串中出现的次数. Input 输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串. Output 对于每个测

统计元音

http://acm.hdu.edu.cn/showproblem.php?pid=2027 1 #include <stdio.h> 2 #include <string.h> 3 #include <stdlib.h> 4 int main() 5 { 6 int n; 7 char a[102]; 8 scanf("%d",&n); 9 getchar(); 10 while(n--) 11 { 12 gets(a); 13 int l

c语言之统计元音

统计元音 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 45249    Accepted Submission(s): 18458 Problem Description 统计每个元音字母在字符串中出现的次数. Input 输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串. Output 对于每个测

hdu 4353 统计点在三角形内的个数

Finding Mine Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1120    Accepted Submission(s): 298 Problem Description In bitland, there is an area with M gold mines. As a businessman, Bob wants t

hdu 1251 统计难题 (map水过)

# include <stdio.h> # include <algorithm> # include <string.h> # include <map> # include <iostream> using namespace std; int main() { char a; string x; map<string,int>q; while(true) { scanf("%c",&a); if(a=

HDU 1251 统计难题 Trie题解

基本上是标准的寻找前缀的问题,只需要insert和search函数就可以了. 我这里主要是修改一下n的记录方法,这里的n代表的不是叶子节点的标志,而是有多少单词经过了这条路径的标志. 然后是查找需要查找的前缀单词,如果没有找到,就返回0,表示没有单词以这个前缀单词为前缀,如果找到,直接返回n就是答案了.因为有n个单词经过了这条路径. 查找效率是常数. 使用静态分配空间的办法. #include <stdio.h> #include <string.h> const int MAX_

1166: 零起点学算法73——统计元音

1166: 零起点学算法73--统计元音 Time Limit: 1 Sec  Memory Limit: 64 MB   64bit IO Format: %lldSubmitted: 1082  Accepted: 402[Submit][Status][Web Board] Description 统计每个元音字母在字符串中出现的次数. Input 输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串,只由小写字母组成. Output 对于每个测试实例输出5行

HDU 4927 Series 1 java大数

java mle前会wa 或者 t 这种事我会乱说? import java.math.*; import java.util.*; import java.io.*; public class Main { BigInteger[] a = new BigInteger[3007]; public void work() { int T; T = cin.nextInt(); while (T-- > 0) { int n; n = cin.nextInt(); for (int i = 0;