1034 Head of a Gang (边不重复 dfs+map)

One way that the police finds the head of a gang is to check people‘s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

  

此题非常综合,值得研究,包括全局变量的设置(G[][],vis[]是dfs通用的),change和map的搭配,注意观察题目是节点不能重复遍历还是边不能重复遍历

#include<iostream>
#include<string>
#include<map>
using namespace std;

map<string,int> si;
map<int,string> is;
map<string,int> Gang;//head->人数
const int maxn=2020;
int G[maxn][maxn]={0},weight[maxn]={0};
int n,m,numPerson=0;
bool vis[maxn]={0};

void dfs(int nowV,int &head,int &numMember,int &totalValue){
    vis[nowV]=1;
    numMember++;
    if(weight[nowV]>weight[head])
        head=nowV;
    for(int i=0;i<numPerson;i++){
        if(G[nowV][i]>0){//这道题边不能重复,不同于常规的节点遍历不重复
            totalValue+=G[nowV][i];
            G[nowV][i]=G[i][nowV]=0;
            if(vis[i]==0){//递归访问
                dfs(i,head,numMember,totalValue);
            }
        }

    }
}

void dfsTravel(){
    for(int i=0;i<numPerson;i++){
        if(vis[i]==0){
            int head=i,num=0,tot=0;
            dfs(i,head,num,tot);
            if(num>2&&tot>m)
                Gang[is[head]]=num;
        }
    }
}

int change(string str){//第一次可能存在需要赋值
    if(si.find(str)!=si.end()) return si[str];
    else{
        si[str]=numPerson;
        is[numPerson]=str;
        return numPerson++;
    }
}

int main(){
    int c;
    cin>>n>>m;
    string a,b;
    for(int i=1;i<=n;i++){
        cin>>a>>b>>c;
        int id1=change(a);
        int id2=change(b);
        weight[id1]+=c;
        weight[id2]+=c;
        G[id1][id2]+=c;
        G[id2][id1]+=c;
    }
    dfsTravel();
    cout<<Gang.size()<<endl;
    map<string,int>::iterator it;//map自动按键从小到大排序
    for(it=Gang.begin();it!=Gang.end();it++){
        cout<<it->first<<" "<<it->second<<endl;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/exciting/p/10447933.html

时间: 2024-10-15 17:54:08

1034 Head of a Gang (边不重复 dfs+map)的相关文章

PAT 甲级 1034 Head of a Gang (30 分)(bfs,map,强连通)

1034 Head of a Gang (30 分) One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of

PAT 1034 Head of a Gang[难]

1034 Head of a Gang (30)(30 分) One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time lengt

1034 Head of a Gang (30 分)

1034 Head of a Gang (30 分) One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between Aand B, we say that A and B is related. The weight of a relation is defined to be the total time length of

java中key值可以重复的map:IdentityHashMap

在Java中,有一种key值可以重复的map,就是IdentityHashMap.在IdentityHashMap中,判断两个键值k1和 k2相等的条件是 k1 == k2 .在正常的Map 实现(如 HashMap)中,当且仅当满足下列条件时才认为两个键 k1 和 k2 相等:(k1==null ? k2==null : e1.equals(e2)). IdentityHashMap类利用哈希表实现 Map 接口,比较键(和值)时使用引用相等性代替对象相等性.该类不是 通用 Map 实现!此类

【语言】java中key值可以重复的map:IdentityHashMap

http://www.rigongyizu.com/java-identityhashmap/ 在java中, 有一种key值可以重复的map,就是IdentityHashMap.在IdentityHashMap中,判断两个键值k1和 k2相等的条件是 k1 == k2 .在正常的Map 实现(如 HashMap)中,当且仅当满足下列条件时才认为两个键 k1 和 k2 相等:(k1==null ? k2==null : e1.equals(e2)). IdentityHashMap类利用哈希表实

1034. Head of a Gang (30)

注意这里n是电话数,电话数不超过1000代表人数不超过两千,...好坑.... 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and

1034 Head of a Gang (30)(30 分)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made b

PAT Advanced 1034 Head of a Gang (30) [图的遍历,BFS,DFS,并查集]

题目 One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls mad

1034. Head of a Gang (30) -string离散化 -map应用 -并查集

题目例如以下: One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone call