PAT A1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N?1??, N?2??, ..., N?K?? }. A continuous subsequence is defined to be { N?i??, N?i+1??, ..., N?j?? } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
const int maxn = 10010;
int s[maxn] = { 0 };
int res[maxn] = { 0 };
int main(){
    int n;
    scanf("%d", &n);
    for (int i = 0; i<n; i++){
        scanf("%d", &s[i]);
    }
    res[0] = s[0];
    for (int i = 1; i<n; i++){
        res[i] = max(s[i], res[i - 1] + s[i]);
    }
    /*for (int i = 1; i < n; i++){
        if (res[i - 1] + s[i] < 0)res[i] = s[i];
        else res[i] = res[i - 1] + s[i];
    }*/
    int maxi = 0;
    for (int i = 1; i<n; i++){
        if (res[i]>res[maxi]){
            maxi = i;
        }
    }
    if (maxi == 0 && s[0]<0)printf("0 %d %d", s[0], s[n - 1]);
    else{
        printf("%d ", res[maxi]);
        int mini = maxi;
        int sum = 0;
        do{
            sum += s[mini--];

        } while (sum != res[maxi]);
        mini++;
        printf("%d %d", s[mini], s[maxi]);
    }
    system("pause");
}

注意点:又是最大子列和问题,不仅要最大子列和答案,还要输出子列的首尾数字。知道可以用动态规划做,做了半天答案一直错误,发现是动态规划想错了,不是一小于0就把值赋给自己,而是要取(自己)和(自己加上前面的最大子列和)的最大值。后面找索引时要用do...while,否则最大子列和只有自身一个数的时候会出错。

原文地址:https://www.cnblogs.com/tccbj/p/10371210.html

时间: 2024-08-28 21:01:41

PAT A1007 Maximum Subsequence Sum (25 分)的相关文章

[PTA] PAT(A) 1007 Maximum Subsequence Sum (25 分)

目录 Problem Description Input Output Sample Sample Input Sample Output Solution Analysis Code Problem portal: 1007 Maximum Subsequence Sum (25 分) Description Given a sequence of $K$ integers { $N_{1}?$, $N_{2}?$, $...$, $N_{K}$ }. A continuous subsequ

1007 Maximum Subsequence Sum (25分) 求最大连续区间和

1007 Maximum Subsequence Sum (25分) Given a sequence of K integers { N?1??, N?2??, ..., N?K?? }. A continuous subsequence is defined to be { N?i??, N?i+1??, ..., N?j?? } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has th

PAT - 测试 01-复杂度2 Maximum Subsequence Sum (25分)

1??, N2N_2N?2??, ..., NKN_KN?K?? }. A continuous subsequence is defined to be { NiN_iN?i??, Ni+1N_{i+1}N?i+1??, ..., NjN_jN?j?? } where 1≤i≤j≤K1 \le i \le j \le K1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum

5-1 Maximum Subsequence Sum (25分)

Given a sequence of KK integers { N_1N?1??, N_2N?2??, ..., N_KN?K?? }. A continuous subsequence is defined to be { N_iN?i??, N_{i+1}N?i+1??, ..., N_jN?j?? } where 1 \le i \le j \le K1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which

A1007. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For examp

pta 1007 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N?1??, N?2??, ..., N?K?? }. A continuous subsequence is defined to be { N?i??, N?i+1??, ..., N?j?? } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For exampl

01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of KKK integers { N1N_1N?1??, N2N_2N?2??, ..., NKN_KN?K?? }. A continuous subsequence is defined to be { NiN_iN?i??, Ni+1N_{i+1}N?i+1??, ..., NjN_jN?j?? } where 1≤i≤j≤K1 \le i \le j \le K1≤i≤j≤K. The Maximum Subsequence is the contin

数据结构课后练习题(练习一)1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N?1??, N?2??, ..., N?K?? }. A continuous subsequence is defined to be { N?i??, N?i+1??, ..., N?j?? } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For exampl

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N?1??, N?2??, ..., N?K?? }. A continuous subsequence is defined to be { N?i??, N?i+1??, ..., N?j?? } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For exampl