SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads【字符串环的最小】

Glass Beads
Time Limit: 3000MS Memory Limit: 10000K
Total Submissions: 5254 Accepted: 2943

Description

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace.

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads.

The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion.

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.

Output

For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e.?such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Sample Input

4
helloworld
amandamanda
dontcallmebfu
aaabaaa

Sample Output

10
11
6
5

Source

Central Europe 1998

Regionals 1998 >> Europe - Central

问题链接SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads
问题简述:(略)
问题分析
????给定一个字符串构成一个环,问从什么位置开始的字符串其字典顺序最小?
????这个问题的解法有两种,一是用2个同样的字符串连接起来,然后从中取出同长度的子串进行比较找出字典顺序最小的(起始位置);二是直接按环进行比较,找出字典顺序最小的(起始位置)。后一种解法似乎值得推荐,模除即可实现环。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads */

#include <iostream>

using namespace std;

int sr(string& s)
{
    int i, j, k, len = s.length();
    for(i = 0, j = 1; j < len;) {
        for(k = 0; k < len && s[(i + k) % len] == s[(j + k) % len]; k++);
        if(k >= len)
            break;
        if(s[(i + k) % len] < s[(j + k) % len])
            j += k + 1;
        else {
            int l = i + k;
            i = j;
            j = max(l, j) + 1;
        }
    }
    return i + 1;
}

int main()
{
    ios::sync_with_stdio(false);
    int n;
    cin >> n;
    while(n--) {
        string s;
        cin >> s;
        cout << sr(s) << endl;
    }

    return 0;
}

AC的C++语言程序如下:

/* SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads */

#include <iostream>

using namespace std;

int sr(string& s)
{
    int i, j, k, len = s.length();
    s += s;
    for(i = 0, j = 1; j < len;) {
        for(k = 0; k < len && s[i + k] == s[j + k]; k++);
        if(k >= len)
            break;
        if(s[i + k] < s[j + k])
            j += k + 1;
        else {
            int l = i + k;
            i = j;
            j = max(l, j) + 1;
        }
    }
    return i + 1;
}

int main()
{
    ios::sync_with_stdio(false);
    int n;
    cin >> n;
    while(n--) {
        string s;
        cin >> s;
        cout << sr(s) << endl;
    }

    return 0;
}

原文地址:https://www.cnblogs.com/tigerisland45/p/10354364.html

时间: 2024-10-11 12:47:31

SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads【字符串环的最小】的相关文章

【POJ1509】Glass Beads 【后缀自动机】

题意 给出一个字符串,求它的最小表示法. 分析 这个题当然可以用最小表示法做啦!但是我是为了学后缀自动机鸭! 我们把这个字符串长度乘二,然后建SAM,然后在SAM上每次跑最小的那个字母,找出长度为n的时候就停下.如果停下的那个状态时u,那么ans=st[u].len-n+1 1 #include <cstdio> 2 #include <cstring> 3 #include <algorithm> 4 #include <iostream> 5 #incl

UVALive 5545 Glass Beads

Glass Beads Time Limit: 3000ms Memory Limit: 131072KB This problem will be judged on UVALive. Original ID: 554564-bit integer IO format: %lld      Java class name: Main Once upon a time there was a famous actress. As you may expect, she played mostly

[最小表示] poj 1509 Glass Beads

题目链接: http://poj.org/problem?id=1509 Glass Beads Time Limit: 3000MS   Memory Limit: 10000K Total Submissions: 2311   Accepted: 1343 Description Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of

Glass Beads

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working fo

PKU 1509 Glass Beads (最小表示法)

题意:有一个环形字符串,让你找一个位置切一刀使得字符串字母序最小,输出这个位置. 思路:可以看成两个字符串比较,一个是从下标0开始(0~n-1),一个从下标1开始(1~n-1,0). 然后两个指针i=0,j=1.从s[i]和s[j]开始比较第k个字符是否相同,当k==len时,返回i,j中的最小值.当s[i+k]和s[j+k]不相同时,若s[i+k]>s[j+k]则可见从s[i+1]到s[i+k]都不会是最小字典序的起始位置,所以i=i+k+1.当s[i+k]<s[j+k]时同理.若移动后i=

zoj 2006 Glass Beads

Glass Beadshttp://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1006 Time Limit: 2 Seconds      Memory Limit: 65536 KB Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the peopl

杂项(最小表示法):HZOI 2015 Glass Beads

[题目描述] 给定长度为n(n<=300000)的循环同构的字符串,定义最小表示为该字符串的字典序最小的同构表示,请输出这个表示. [输入格式] 第一行是串的长度,第二行是字符串. [输出格式] 串的最小表示. [样例输入] 10 helloworld [样例输出] dhelloworl [题目来源] HZOI2015 改编自poj1509 算法很显然,需要注意的是:s[len+1]要赋值成一个较大值. 1 #include <iostream> 2 #include <cstri

POJ1509 Glass Beads 【后缀自动机】

题目大意 找一个环串的起点,使得从其开始遍历字典序最小 题解 建立后缀自动机,从根开始走length步,走到的点就是这个最小串的结尾,其step即表示它在串中的位置 step - n + 1即为开始位置 #include<iostream> #include<cmath> #include<cstdio> #include<cstring> #include<algorithm> #define LL long long int #define

poj 1509 Glass Beads

题意:给你一个长度为n的字符串环,以位置i开始的顺时针长度为n的环构成的字符串有n个,问其中最小字典序的开始位置,有多种解时,输出起始位置最小的. 分析: 首先可以直接拼接两个长度为n的字符串,设原串为S[0],S[1]...S[n-1]则拼接后就是S'=S[0],S[1],...S[n-1],S[0],S[1],...S[n-1]. 那么问题中的n个长度为n的字符串中的任意一个,一定存在S'的某个后缀字符串的前缀与其相等. 我们现在要找最小字典序,则可以直接先求S'的后缀数组SA,然后: 1.