POJ 2406 Power Strings(kmp)


Language:
Default

Power Strings

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 33335   Accepted: 13852

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

求一个串的最小周期

对于一个串,如果abcdabc 那么next[len]=3,那么len-next【len】就大于len/2,那么len%(len-next[len])!=0;而对于一个周期串ababab next[len]=4,此时len-next[len]应该等于

最小串的长度,所以是不是有最小周期就可以用len%(len-next[len])是否为0来判断,(个人理解,如有错,请想告)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
using namespace std;
#define N 100005

char a[N];
int len,next[N];

void getfail(char *a)
{
	 int i,j;
	 len=strlen(a);
	 i=0;j=-1;
	 next[0]=-1;
	 while(i<len)
	 {
	 	if(j==-1||a[i]==a[j])
		{
			 i++;
			 j++;
			 next[i]=j;
		}
		else
			j=next[j];
	 }
}

int main()
{
	int i,j;
	while(scanf("%s",a))
	{
		if(a[0]=='.') break;
		getfail(a);
		int ans=len%(len-next[len]);
		if(ans==0)
			printf("%d\n",len/(len-next[len]));
		else
			printf("1\n");
	}
	return 0;
}
时间: 2024-07-28 14:13:10

POJ 2406 Power Strings(kmp)的相关文章

POJ - 2406 - Power Strings (KMP)

Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 34601   Accepted: 14319 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "

poj 2406 Power Strings(KMP求循环次数)

题目链接:http://poj.org/problem?id=2406 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, e

poj 2406 Power Strings(kmp循环节)

题目链接:http://poj.org/problem?id=2406 题目大意:如果n%(n-next[n])==0,则存在重复连续子串,长度为n-next[n]. 例如:      a    b    a    b    a    b next:-1   0    0    1    2    3    4 next[n]==4,代表着,前缀abab与后缀abab相等的最长长度,这说明,ab这两个字母为一个循环节,长度=n-next[n]; 1 #include <iostream> 2

poj 2406 Power Strings(kmp求一个串的重复子串)

题意:重复子串次数 思路:kmp #include<iostream> #include<stdio.h> #include<string.h> using namespace std; #define MaxSize 1000005 int next[MaxSize]; void GetNext(char t[]){//求next数组 int j,k,len; j=0; k=-1; next[0]=-1; len=strlen(t); while(j<len){

POJ - 2406 - Power Strings (字符串求周期--next函数的妙用)

题目传送:POJ - 2406 思路:就是利用kmp中next数组的特性来求最大周期的 AC代码: #include <cstdio> #include <cstring> #include <algorithm> using namespace std; const int maxn = 1000005; char s[maxn]; int next[maxn]; int main() { while(scanf("%s", s) != EOF)

poj 2406 Power Strings 【KMP的应用】

Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 33595   Accepted: 13956 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "

poj 2406 Power Strings【KMP】

点击打开题目 Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 33548   Accepted: 13935 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b =

Power Strings(KMP)

Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 45008   Accepted: 18794 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "

poj 2406 Power Strings 【kmp】

Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 37564   Accepted: 15532 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "