UVa - The 3n + 1 problem 解读

这个问题并计算质数了一下相间隔似的。思想上一致。

注意问题:

1 i 可能 大于或等于j -- 这里上传。小心阅读题意,我没有说这个地方不能保证。需要特殊处理

2 计算过程中可能溢出,的整数大于最大值,需要使用long long

关于效率和时间问题:

1 能够使用数组保存中间结果,这样执行快了。内存消耗大了,

2 能够不使用中间数组。 这样执行肯定比較慢了。可是内存消耗小,一样能够AC的。

全部没有个标准吧。看情况而定。假设须要速度就添加数组,假设省内存就不使用数组吧。

这样的题目一般都使用数组吧。

我这里使用数组。

參考博客:http://tausiq.wordpress.com/2008/12/09/uva-100-the-3n-1-problem/

题目例如以下:

Background

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

The Problem

Consider the following algorithm:


		1. 		 input n


2. 		 print n

3. 		 if n = 1 then STOP

4. 		 		 if n is odd then  

5. 		 		 else  

6. 		 GOTO 2



Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers
n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given
n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between
i and j.

The Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including
i and j.

You can assume that no operation overflows a 32-bit integer.

The Output

For each pair of input integers i and j you should output
i
, j, and the maximum cycle length for integers between and including
i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers
i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

注意好上述问题之后就比較好AC了。

我以下程序是写了个类,分开多个函数,能够看的逻辑十分清晰的。当然/2和*2能够改动成>>1和<<1操作。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <stdio.h>

using namespace std;

static int table[1000000] = {0};//={-1}不正常工作。仅仅能清零

class ThreeNOne
{
public:
	const static int MAX_N = 1000000;
	ThreeNOne()
	{
		table[1] = 1;
		for (int i = 2; i < 1000000; i*=2)
		{
			table[i] = table[i/2] + 1;
		}
		initTbl(table);
	}

	int checkTbl(int tbl[], long long i)//i一定要为longlong,int会溢出
	{
		if (i < MAX_N && 0 != tbl[i]) return tbl[i];
		if (i % 2)
		{
			if (i < MAX_N) tbl[i] = checkTbl(tbl, i * 3 + 1) + 1;
			else return checkTbl(tbl, i * 3 + 1) + 1;
		}
		else
		{
			if (i < MAX_N) tbl[i] = checkTbl(tbl, i / 2) + 1;
			else return checkTbl(tbl, i / 2) + 1;
		}
		return tbl[i];
	}

	void initTbl(int tbl[])
	{
		for (int i = 3; i < 1000000; i++)
		{
			checkTbl(tbl, i);
		}
	}

	void The3n1problem()
	{
		int i = 0, j = 0;
		while (cin>>i>>j)
		{
			pair<int, int> t = minmax(i, j);//区间给定不一定是i<=j的,细致审题
			int ans = 0;
			for (long long d = t.first; d <= t.second; d++)
			{
				ans = max(ans, table[d]);
				//错误:ans += table[d];细致读题,不是和。而是maximum
			}
			cout<<i<<‘ ‘<<j<<‘ ‘<<ans<<endl;
		}
	}
};
int main()
{
	ThreeNOne tno;
	tno.The3n1problem();
	return 0;
}

版权声明:笔者心脏靖。景空间地址:http://blog.csdn.net/kenden23/。可能不会在未经作者同意转载。

时间: 2024-08-01 14:01:00

UVa - The 3n + 1 problem 解读的相关文章

UVA 100 The 3n + 1 problem(超级大水题)

The 3n + 1 problem Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Description Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you

POJ1207 The 3n + 1 problem

这题不是很难,模拟一下即可,但有一些细节需要注意 输入的数不一定升序,且要按原顺序输出,还有就是读完数据的问题 The 3n + 1 problem Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 53006   Accepted: 16841 Description Problems in Computer Science are often classified as belonging to a certain cl

The 3n + 1 problem(杭电1032)(暴力求解)

The 3n + 1 problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23163    Accepted Submission(s): 8653 Problem Description Problems in Computer Science are often classified as belonging to a

HDU 1032 The 3n + 1 problem【递归】

/* 中文题目 3n+1问题 中文翻译-大意 当一个数n是奇数的时候变成3*n+1,为偶数的时候变成n/2 解题思路:区间内每个数逐个求解 难点详解:如何逐个计算每个数的次数,选用while循环,还有就是将此时的 i 值赋给data,用于while循环的条件.最后再将这一个数运算次数累加在一起 关键点:理解题意 解题人:lingnichong 解题时间:2014-06-03 09:40:39 解题体会:没有告诉你那个大那个小,要先比较一下数,是个陷阱 */ The 3n + 1 problem

HDU 1032 The 3n + 1 problem (这个题必须写博客)

The 3n + 1 problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 22148    Accepted Submission(s): 8276 Problem Description Problems in Computer Science are often classified as belonging to a c

100 - The 3n + 1 problem

题目来源:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=3&page=show_problem&problem=36  The 3n + 1 problem  Background Problems in Computer Science are often classified as belonging to a certain class of problem

hdu 1032 The 3n + 1 problem (打表)

The 3n + 1 problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 26353    Accepted Submission(s): 9784 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1032 Problem Description Problems in Comp

[2016-02-19][UVA][524][Prime Ring Problem]

UVA - 524 Prime Ring Problem Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu Submit Status Description A ring is composed of n (even number) circles as shown in diagram. Put natural numbers  into each circle separately, and the

UVA 10837 - A Research Problem(欧拉函数)

UVA 10837 - A Research Problem 题目链接 题意:给定phi(n),求最小满足的最小的n 思路:phi(n)=pk11(p1?1)?pk22(p2?1)?pk33(p3?1)....(p为质数),因此对于给定phi(n),先把满足条件phi(n)%(p?1)=0的素数全找出来,在这些素数基础上进行暴力搜索,枚举哪些素数用与不用,求出最小值.这样做看似时间复杂度很高,但是实际上,由于每次多选一个素数之后对于值是呈指数上升的,所以实际组合出来的情况并不会太多,因此是可行的