POJ1679 The Unique MST 【次小生成树】

The Unique MST

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20421   Accepted: 7183

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V‘, E‘), with the following properties:

1. V‘ = V.

2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E‘) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E‘.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a
triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!‘.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

POJ Monthly--2004.06.27 [email protected]

这题做得好开心,一次AC~

题意:给定一个联通图,判断最小生成树是否唯一。

题解:求出最小生成树后再求次小生成树,若次小生成树的长度与最小生成树相等就说明不唯一,否则唯一。

这是我的第一道次小生成树题,在这里总结下这个算法:

利用一个矩阵max【】【】表示最小生成树中任意两点路径上的最长边权值(关键!!),在求最小生成树时将已经选上的边标记为已用,求完后,遍历剩下未用的边,这条边若添加到最小树中必定构成回路,所以此时需要去掉原来树中那条回路中的最大值,也就是max矩阵存储的值,所以问题转换成找到一条未用的边,使得它跟对应于max矩阵里的边差值最小,遍历之后,次小生成树的值即为原最小生成树的值加上这个最小的差值。

#include <stdio.h>
#include <string.h>
#include <limits.h>
#define maxn 102
#define maxm (maxn * maxn) >> 1

int head[maxn], max[maxn][maxn];
struct Node{
	int u, v, cost, next;
	bool vis;
} E[maxm];
bool vis[maxn];

int mini(int a, int b){
	return a < b ? a : b;
}

int prim(int n, int m)
{
	int u, i, tmp, j, len = 0, count = 0;
	memset(max, 0x7f, sizeof(max));
	memset(vis, 0, sizeof(vis));
	vis[1] = 1;
	while(count < n - 1){
		for(i = 1, tmp = INT_MAX; i <= n; ++i){
			if(!vis[i]) continue;
			for(j = head[i]; j != -1; j = E[j].next){
				if(vis[E[j].v]) continue;
				if(E[j].cost < tmp){
					tmp = E[j].cost; u = j;
				}
			}
		}
		++count; len += tmp;
		for(i = 1; i <= n; ++i){
			if(!vis[i]) continue;
			max[i][E[u].v] = max[E[u].v][i] = E[u].cost;
		}
		vis[E[u].v] = 1; E[u].vis = 1;
	}
	return len;
}

int getSecLen(int n, int m)
{
	int min = INT_MAX, u, v, w;
	for(int i = 0; i < m; ++i){
		if(E[i].vis) continue;
		u = E[i].u; v = E[i].v;
		w = E[i].cost;
		min = mini(min, w - max[u][v]);
		if(min == 0) return 0;
	}
	return min;
}

int main()
{
	int t, n, m, i, minLen, secLen;
	scanf("%d", &t);
	while(t--){
		scanf("%d%d", &n, &m);
		memset(head, -1, sizeof(head));
		for(i = 0; i < m; ++i){
			scanf("%d%d%d", &E[i].u, &E[i].v, &E[i].cost);
			E[i].vis = 0; E[i].next = head[E[i].u];
			head[E[i].u] = i;
		}
		minLen = prim(n, m);
		secLen = getSecLen(n, m);
		if(secLen == 0) printf("Not Unique!\n");
		else printf("%d\n", minLen);
	}
	return 0;
}

POJ1679 The Unique MST 【次小生成树】

时间: 2024-12-08 17:35:38

POJ1679 The Unique MST 【次小生成树】的相关文章

[POJ1679]The Unique MST 次小生成树

题目链接:http://poj.org/problem?id=1679 给你一个图的连通情况,询问你此图的最小生成树是否唯一. 假如最小生成树唯一,即生成树连通所有节点的权值和唯一.假如不唯一,那么存在另一条最小生成树使得权值等于之前最小生成树的权值. 换个思路考虑,也就是次小生成树的权值与最小生成树的权值相同,那么问题就变成了求次小生成树的权值. 我选择的是先求出最小生成树,将树上用到的边都保存下来.接着分别将每一条用到的边摘下来,再求一次最小生成树.假如不包含当前删掉的边生成的生成树的所选边

poj 1679 The Unique MST (次小生成树)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 20293   Accepted: 7124 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

POJ_1679_The Unique MST(次小生成树模板)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 23942   Accepted: 8492 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

hdu 1679 The Unique MST 次小生成树 简单题

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 21737   Accepted: 7692 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

poj 1679 The Unique MST (次小生成树(sec_mst)【kruskal】)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 35999   Accepted: 13145 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undir

POJ - 1679 The Unique MST(次小生成树)

版权声明:本文为博主原创文章,未经博主允许不得转载.

poj1679 The Unique MST

题目大意:给定一个联无向网,判断它的最小生成树是否唯一. The Unique MST Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 20421 Accepted: 7183 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Con

POJ1679 The Unique MST【Kruskal】【次小生成树】

The Unique MST Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 21304 Accepted: 7537 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undirected

poj1679——The Unique MST(次小生成树,Kruskal)

Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the followin