HDU 1007 Quoit Design

Quoit Design

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 130 Accepted Submission(s): 72
 

Problem Description

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.


Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.


Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.


Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0


Sample Output

0.71
0.00
0.75

题目要求求一个最近点对。

参考了一下别人的方法。

神分治 + 神剪支 + 神排序 就过了。

学习了一种新的排序方法 。 有所收获~~

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
using namespace std;
const int N =  100010;
const double INF = 1e10;
struct node{ double x, y ; }e[N];
int n ;
inline bool cmpx(const node &a , const node &b ){ return a.x <b.x ; }
inline bool cmpy(const int a , const int b ){ return e[a].y < e[b].y ; }
inline double dis( const node a , const node b ){ return sqrt ( ( a.x - b.x ) * ( a.x - b.x ) + ( a.y - b.y ) *( a.y - b.y ) ); }

int a[N];

double solve( int l , int r )
{
    if( l + 1 == r ) return dis( e[l] , e[r] );
    if( l + 2 == r ) return min(  dis( e[l],e[r] ) , min( dis( e[l] ,e[l+1] ) , dis( e[l+1] , e[r]) )  );

    int mid = ( l + r ) >> 1;
    double ans = min( solve( l , mid ) , solve( mid + 1 , r) ) ;
    int cnt = 0 ;
    for( int i = l ; i <= r ; ++i ){
        if( e[i].x >= e[mid].x - ans && e[i].x <= e[mid].x + ans ){
            a[cnt++] = i ;
        }
    }
    sort ( a , a + cnt , cmpy );
    for( int i = 0 ; i < cnt ; ++ i ){
        for( int j = i + 1  ; j < cnt ; ++j ){
            if( e[ a[i] ].y + ans <= e[ a[j] ] .y  )break ;
            ans = min( ans , dis( e[ a[i] ] ,e[ a[j] ] ) );
        }
    }
    return ans ;
}
int main()
{
    ios::sync_with_stdio(false);

    while( cin >> n && n ){

        for( int i = 0 ; i < n ; ++i ){
            cin >> e[i].x >> e[i].y ;
        }
        sort( e, e + n , cmpx );

        printf("%.2lf\n", ( solve( 0 ,n-1 ) / 2.0 ) );
    }
}
时间: 2024-10-14 00:09:26

HDU 1007 Quoit Design的相关文章

HDU 1007 Quoit Design (分治)

Quoit Design Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded. In the field of Cyberground, the position of each toy is fixed, and the ri

hdu 1007 Quoit Design 分治求最近点对

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 29344    Accepted Submission(s): 7688 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

分治 [HDU 1007] Quoit Design

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 33577    Accepted Submission(s): 8800 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

HDU 1007 Quoit Design(二分+浮点数精度控制)

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 47104    Accepted Submission(s): 12318 Problem Description Have you ever played quoit in a playground? Quoit is a game in which fla

HDU 1007 Quoit Design【计算几何/分治/最近点对】

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 58566    Accepted Submission(s): 15511 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

HDU 1007 [Quoit Design] 分治

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1007 题目大意:N个点,求最近一对点的距离的一半. 关键思想:最傻瓜式的枚举所有点对的距离找最短 O(n^2),会TLE. 分治可以优化成O(nlogn).二分区间,考虑三种情形:点对的两点都在左区间.两点都在右区间.两点一左一右 前两种情况,可以递归地解出来,分别为d1,d2.第三种,可以依据min(d1,d2)收缩成一条带状区域(勾股定理显然). 然后对带中所有点进行处理,此时又可依据min(d

hdu 1007 Quoit Design (经典分治 求最近点对)

Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.In the field of Cyberground, the position of each toy is fixed, and the ring is carefull

HDU 1007 Quoit Design (最近点对 分治法)

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded. In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it ca

ZOJ 2107 HDU 1007 Quoit Design(最近点对)

最近点对的裸题 利用分治去搞搞即可 代码: #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> using namespace std; const int N = 100005; struct Point { double x, y; void read() { scanf("%lf%lf", &x, &y); } }; b