POJ 1411 Calling Extraterrestrial Intelligence Again

Calling Extraterrestrial Intelligence Again

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10716   Accepted: 4210

Description

A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974. The message consisted of 1679 bits and was meant to be translated to a rectangular picture with
23 x 73 pixels. Since both 23 and 73 are prime numbers, 23 x 73 is the unique possible size of the translated rectangular picture each edge of which is longer than 1 pixel. Of course, there was no guarantee that the receivers would try to translate the message
to a rectangular picture. Even if they would, they might put the pixels into the rectangle incorrectly. The senders of the Arecibo message were optimistic.

We are planning a similar project. Your task in the project is to find the most suitable width and height of the translated rectangular picture. The term "most suitable" is defined as follows. An integer m greater than 4 is given. A positive fraction a/b less
than or equal to 1 is also given. The area of the picture should not be greater than m. Both of the width and the height of the translated picture should be prime numbers. The ratio of the width to the height should not be less than a/b nor greater than 1.
You should maximize the area of the picture under these constraints.

In other words, you will receive an integer m and a fraction a/b. It holds that m > 4 and 0 < a/b <= 1. You should find the pair of prime numbers p, q such that pq <= m and a/b <= p/q <= 1, and furthermore, the product pq takes the maximum value among such
pairs of two prime numbers. You should report p and q as the "most suitable" width and height of the translated picture.

Input

The input is a sequence of at most 2000 triplets of positive integers, delimited by a space character in between. Each line contains a single triplet. The sequence is followed by a triplet of zeros, 0 0 0, which indicates the end of the input and should not
be treated as data to be processed.

The integers of each input triplet are the integer m, the numerator a, and the denominator b described above, in this order. You may assume 4 < m <= 100000 and 1 <= a <= b <= 1000.

Output

The output is a sequence of pairs of positive integers. The i-th output pair corresponds to the i-th input triplet. The integers of each output pair are the width p and the height q described above, in this order.

Each output line contains a single pair. A space character is put between the integers as a delimiter. No other characters should appear in the output.

Sample Input

5 1 2
99999 999 999
1680 5 16
1970 1 1
2002 4 11
0 0 0

Sample Output

2 2
313 313
23 73
43 43
37 53

算法分析:

p,q的范围其实可在2—50000(why?)

然而,这是最小的范围吗?

考虑大于10000的某个质数,不妨设为Q,另一个质数为P,则:

如果P<10,P/Q<0.001

如果P>10,P*Q>100000

而考虑到a,b的取值范围(1<=a<=b<=1000)

可知min(a/b)=0.001

同时,要求: p*q<=m<=100000

所以无论如何质数都不能超过10000

对于素数的查找利用筛法完成!!!

#include<stdio.h>
#include<stdlib.h>
int prm[1300];
int x[10005];
int main()
{

	int m, a, b, i,j,p,q,max,tmp;
	for(i=2;i<=10005;i++)
	{
		if(!*(x+i))
		{
			for(j=(i<<1);j<=10005;j+=i)
			{
				*(x+j)=1;
			}
		}
	}
	while(scanf("%d%d%d", &m, &a, &b) && (a!=0 || b!=0 || m!=0))
	{
		int num=0;
		prm[0]=2;

		for(i=3,j=1;i<=m;i++)
		{

			if(i==10000)break;
			if(!*(x+i))
			{prm[j++]=i;num++;}
		}
		//从大到小搜索,有利于剪枝
		max=0;
		for(i=num-1; i>=0; i--)
		{
			if(prm[i]>=m) //剪枝,若因子q>=m
				continue;
			for(j=i;j<=num;j++)
			{//剪枝,若乘积大于m,或比值小于a/b,停止p的搜索
				if(prm[i]*prm[j]>m || prm[i]*1.0/prm[j]<a*1.0/b)
					break;
				tmp=prm[i]*prm[j];
				if(tmp>max) { max=tmp; p=prm[i]; q=prm[j];
				}
			}
		}
		printf("%d %d\n",p,q);
	}
	return 0;
}

POJ 1411 Calling Extraterrestrial Intelligence Again

时间: 2024-08-08 13:53:54

POJ 1411 Calling Extraterrestrial Intelligence Again的相关文章

poj 1141 Calling Extraterrestrial Intelligence Again(超时)

Calling Extraterrestrial Intelligence Again Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11211   Accepted: 4356 Description A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto

【HDOJ】1239 Calling Extraterrestrial Intelligence Again

这题wa了很多词,题目本身很简单,把a/b搞反了,半天才检查出来. 1 #include <stdio.h> 2 #include <string.h> 3 #include <math.h> 4 5 char isPrime[100001]; 6 7 int main() { 8 int i, j, q, p, maxi, maxj, max; 9 double m, a, b, n, tmp1, tmp2; 10 11 memset(isPrime, 1, size

HDU - 1239 - Calling Extraterrestrial Intelligence Again (素数相关~)

Calling Extraterrestrial Intelligence Again Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4637    Accepted Submission(s): 2433 Problem Description A message from humans to extraterrestrial in

Calling Extraterrestrial Intelligence Again

Description A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974. The message consisted of 1679 bits and was meant to be translated to a rect

【noi 2.7_413】Calling Extraterrestrial Intelligence Again(算法效率)

题意:给3个数M,A,B,求两个质数P,Q.使其满足P*Q<=M且A/B<=P/Q<=1,并使P*Q最大.输入若干行以0,0,0结尾. 解法:先线性筛出素数表,再枚举出P,二分出对应的最大的Q,得出最佳答案. 注意——二分时通过pri[]的下标尽量大来实现,比递归快了很多,具体请见代码. 1 #include<cstdio> 2 #include<cstdlib> 3 #include<cstring> 4 #include<iostream&g

hdu 1239 Calling Extraterrestrial Intelligence Again(素数,枚举)

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1239 [题目大意] 输入三个数,m,a,b 让你求出一对素数 p ,q ,且满足 p x q <=m  &&   a/b <=p/q <= 1; 数据范围 4< m <= 100000   , 1 <= a <= b <= 1000. [思路] 先用素数筛选法,将1--100000的素数筛选出来, 打了一下表 发现有9000+个素数: 直接暴力枚举

穷举(四):POJ上的两道穷举例题POJ 1411和POJ 1753

下面给出两道POJ上的问题,看如何用穷举法解决. [例9]Calling Extraterrestrial Intelligence Again(POJ 1411) Description A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16

杭电1239--Calling Extraterrestrial Intelligence Again

Calling Extraterrestrial Intelligence Again Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4964    Accepted Submission(s): 2608 Problem Description A message from humans to extraterrestrial int

杭电ACM分类

杭电ACM分类: 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDIATE DECODABILITY