POJ 3176 Cow Bowling 保龄球 数塔问题 DP

题目链接:POJ 3176 Cow Bowling


Cow Bowling

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14044   Accepted: 9310

Description

The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest
score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5

The highest score is achievable by traversing the cows as shown above.

Source

USACO 2005 December Bronze

题意:

从数塔的第一层走到最底层,但只能沿对角线走,求路径上的数的和的最大值。

分析:

从最底层向上考虑,路径上的和的大小取决于直接取决于下面两个数的大小。因而采用自顶向上方法,逐步向上走,走到最顶层,每次都选择最大的和,这样最后的结果就保存在了最顶层。

状态转移方程:dp[i][j] = max(dp[i+1][j], dp[i+1][j+1])+A[i][j];

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int MAX_N = 400;
int dp[MAX_N][MAX_N];
int N, A[MAX_N][MAX_N];
void solve() {
    memset(dp, 0, sizeof(dp));
    for(int i = 1; i <= N; i++) dp[N][i] = A[N][i];
    for(int i = N-1; i >= 1; i--)
        for(int j = 1; j <= i; j++)
            dp[i][j] = A[i][j]+max(dp[i+1][j], dp[i+1][j+1]);
    printf("%d\n", dp[1][1]);
}
int main() {
    while(~scanf("%d", &N)) {
        for(int i = 1; i <= N; i++)
            for(int j = 1; j <= i; j++)
                scanf("%d", &A[i][j]);
        solve();
    }
    return 0;
}
时间: 2024-12-18 22:48:35

POJ 3176 Cow Bowling 保龄球 数塔问题 DP的相关文章

poj 3176 Cow Bowling(dp)

递推式dp[i][j]=max( dp[i-1][j] , dp[i-1][j-1] )+a[i][j]; ①第一次做数塔,不会输入.数塔的输入 1 for(int i=1;i <= n;i++) 2 { 3 for(int j=1;j <= i;j++) 4 { 5 scanf("%d",&a[i][j]); 6 } 7 } 1 #include <iostream> 2 #include <cstring> 3 #include <

poj 3176 Cow Bowling

题目链接:http://poj.org/problem?id=3176 思路: 基本的DP题目:将每个节点视为一个状态,记为B[i][j], 状态转移方程为 B[i][j] = A[i][j] + Max( B[i+1][j], B[i+1][j+1] ); 代码: #include <stdio.h> const int MAX_N = 350 + 10; int A[MAX_N][MAX_N], B[MAX_N][MAX_N]; int Max( int a, int b ) { retu

poj 3176 Cow Bowling(dp基础)

Description The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5 Then the other cows traverse

poj 3176 Cow Bowling 简单DP

题目链接:http://poj.org/problem?id=3176 #include <cstdio> #include <cstdlib> #include <ctime> #include <iostream> #include <cmath> #include <cstring> #include <algorithm> #include <stack> #include <set> #i

poj 1163 The Triangle &amp;poj 3167 Cow Bowling (dp)

链接:poj 1163 题意:输入一个n层的三角形,第i层有i个数,求从第1层到第n层的所有路线中,权值之和最大的路线. 规定:第i层的某个数只能连线走到第i+1层中与它位置相邻的两个数中的一个. 状态方程:f[i][j]=max(f[i-1][j-1],f[i-1][j])+a[i][j]; 1163代码: #include<stdio.h> #include<string.h> int a[105][105],f[105][105]; int max(int a,int b)

HDU 2084 数塔 --- 入门DP

HDU 2084 数塔 从下往上递推,状态转移方程 dp[i][j] = max( dp[i+1][j], dp[i+1][j+1]) + a[i][j]; /* HDU 2084 数塔 --- 入门DP */ #include <cstdio> const int N = 105; int dp[N][N]; int MAX(int a, int b){ return a > b ? a : b; } int main() { #ifdef _LOCAL freopen("D

POJ3176_Cow Bowling【数塔DP】

Cow Bowling Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 14253 Accepted: 9461 Description The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowl

hdu 2084 &amp; POJ 1163 数塔 (dp)

数塔 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 24626    Accepted Submission(s): 14814 Problem Description 在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的: 有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少

HDU 2084 数塔(简单DP入门)

数塔 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 41852    Accepted Submission(s): 24820 Problem Description 在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?