VLAN+VTP+STP+HSRP+ACL+NAT+OSPF综合


如图所示,使用GN3搭建网络环境,交换机间均为Trunk链路。


2、配置要求:


2.1


在SW1、SW2、SW3上添加VLAN 10、VLAN 20,IP地址段分别为192.168.10.0/24和192.168.20.0。


2.2


配置SW1为VLAN 10的根网桥,SW2为VLAN 20的根网桥,实现链路的负载分担。


2.3


在SW1、SW2、R1和R2上配置OSPF路由协议,实现网络互通,Router-id使用管理IP和Loopback地址。配置Area 1为完全末梢区域,Area 2为NSSA区域,将R2的直连网段10.10.10.1重分发到OSPF区域。


2.4


为R1设置密码benet,要求只有SW3可以登录。


2.5


验证SW3可以ping通R2的Loopback0地址,验证SW3可以远程登录到R1。


2.6


在SW1和SW2上配置HSRP,SW1是VLAN 10的活跃路由器VLAN20的备份路由,SW2是VLAN 10的备份路由VLAN20的活跃路由,配置占先权和端口跟踪。


2.7


R2路由器是连接互联网的设备,现希望各区域主机访问Internet,则需要在R1上进行NAT配置,以此实现共享上网

SW1配置

interface FastEthernet0/0

switchport mode trunk

!

interface FastEthernet0/1

no switchport

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/2

switchport mode trunk

!

interface FastEthernet0/3

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

standby 10 ip 192.168.10.10

standby 10 priority 150

standby 10 preempt

standby 10 track FastEthernet0/1 100

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

standby preempt

standby 20 ip 192.168.20.20

!

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

area 1 stub no-summary

redistribute connected subnets

network 192.168.1.0 0.0.0.255 area 0

network 192.168.10.0 0.0.0.255 area 1

network 192.168.20.0 0.0.0.255 area 1

!

no ip http server

no ip http secure-server

!

!

!

SW2配置

interface FastEthernet0/0

switchport mode trunk

!

interface FastEthernet0/1

no switchport

ip address 192.168.2.1 255.255.255.0

!

interface FastEthernet0/2

switchport mode trunk

!

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.10.2 255.255.255.0

standby preempt

standby 10 ip 192.168.10.10

!

interface Vlan20

ip address 192.168.20.2 255.255.255.0

standby 20 ip 192.168.20.20

standby 20 priority 150

standby 20 preempt

standby 20 track FastEthernet0/1 100

!

router ospf 1

router-id 2.2.2.2

log-adjacency-changes

area 1 stub no-summary

network 192.168.2.0 0.0.0.255 area 0

network 192.168.10.0 0.0.0.255 area 1

network 192.168.20.0 0.0.0.255 area 1

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

SW3配置

interface FastEthernet0/0

switchport mode trunk

!

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.10.3 255.255.255.0

!

interface Vlan20

ip address 192.168.20.3 255.255.255.0

!

router ospf 1

router-id 3.3.3.3

log-adjacency-changes

area 1 stub

network 192.168.10.0 0.0.0.255 area 1

network 192.168.20.0 0.0.0.255 area 1

!

no ip http server

no ip http secure-server

!

!

!

R1配置

interface FastEthernet0/0

ip address 192.168.3.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 192.168.2.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

shutdown

duplex auto

speed auto

!

router ospf 1

router-id 4.4.4.4

log-adjacency-changes

area 2 nssa no-summary

network 192.168.1.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 2

!

ip classless

no ip http server

!

access-list 1 permit 192.168.10.3

access-list 1 permit 192.168.20.3

!

dial-peer cor custom

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

access-class 1 in

password cisco

login

!

end

R2配置

interface Loopback0

ip address 10.10.10.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.3.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

router ospf 1

router-id 5.5.5.5

log-adjacency-changes

area 2 nssa no-summary

redistribute connected metric 10 subnets

redistribute static metric 10 subnets

network 192.168.3.0 0.0.0.255 area 2

default-information originate

!

ip nat pool nat 10.10.10.1 10.10.10.1 netmask 255.255.255.0

ip nat inside source list 1 pool nat overload

ip classless

no ip http server

!

access-list 1 permit any

!

dial-peer cor custom

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

!

end

时间: 2024-12-19 22:41:03

VLAN+VTP+STP+HSRP+ACL+NAT+OSPF综合的相关文章

VTP,STP,HSRP,ACL,DHCP,综合实验

实验 拓扑图: 步骤: 一,为PC机配置IP地址 服务器: C2: C1: 二,SW1和SW2做VTP服务模式,SW3和SW4做VTP的客户模式 SW1: SW2: SW3: SW4: 三,根据实验要求VLAN10的流量走SW1,VLAN20的流量走SW2,所以把SW1配置为VLAN10的根网桥,把SW2配置为VLAN20的根网桥,根据命令"tracert"跟踪路由查看 SW1: SW2: 跟踪VLAN10的流量: 跟踪VLAN20的流量: 以上显示VLAN10的流量走的是SW1的vl

cisco dhcp vlan vtp stp vrrp ospf

ciso dhcp vlan stp vtp vrrp ospf 一.拓扑 二.接口配置 IOU1(config)# hostname dhcp dhcp(config)# int e0/0 dhcp(config-if)# ip add 1.1.1.1 255.255.255.0 dhcp(config-if)# no shut dhcp(config)# int e0/1 dhcp(config-if)# ip add 2.2.2.1 255.255.255.0 dhcp(config-if

思科模拟器实现HSRP以及NAT的端口复用综合运用

一.搭建如下拓扑图二.配置内网1.先将在swichi2创建vlan10.vlan20并将连接PC机的接口设为access连接交换机的接口设为trunk,注意:三层交换机设置trunk口的时候,先要定义封装协议dot1q ,命令如下:swichi2:Switch(config)#vlan 10 //创建vlan10Switch(config-vlan)#vlan 20 //创建vlan20Switch(config-vlan)#exitSwitch(config)#interface fastEt

OSPF、VLAN、RIP、单臂路由综合实验,实现全网互通

OSPF.VLAN.RIP.单臂路由综合实验,实现全网互通 ? 前言:根据之前所学的内容,现在要把所学的内容结合在一起,放在一个实验拓扑图中,使得全网能够通讯.更主要的是巩固了这些知识,加深印象. 实验拓扑图如下: 一:实验介绍 首先需要把各个路由器的接口地址配置完成,从左边依次开始,R1.SW和下面的主机这一部分需要配置静态路由,SW和SW2上需要划分vlan10 和vlan20, R1.R3.R4需要配置ospf协议,R4.SW3需要配置RIP协议.下面我们就来看看具体步骤. 1.SW的配置

CCNP第四天 OSPF综合实验(1)

ospf综合实验(1) 本实验主要考察ospf中的接口上的多种工作方式 实验如图所示: 所用拓扑为CCNP标准版,如图: ------------------------------------------------------------------------------------------------------------------------------------- 1. 全网可达 由于CCNP中帧中继是默认全部开启,而且是全连通的,所以在物理接口和多点子接口上建议关闭逆向a

CCNA WAN ACL&NAT

ACL要么应用于入站数据流要么应用于出站数据流. ACL编号范围: 1 ~ 99 和1300 ~ 1999: 标准IP ACL 100 ~ 199和2000 ~ 2699: 扩展IP ACL 600 ~ 699: AppleTalk 800 ~ 899: IPX 标准ACL: 只指定源地址,不指定目标地址 扩展ACL: 查看源IP地址,也查看目标IP地址.协议和端口号. 配置标准ACL access-list 2 deny 192.168.0.1 access-list 2 permit 192

LAB OSPF 综合实验

OSPF 综合实验 1. 实验目的1) 理解和掌握 OSPF stub 区域的特点和配置2) 理解和掌握 OSPF totally stub 区域的特点和配置3) 理解和掌握 OSPF NSSA 区域的特点和配置4) 理解和掌握 OSPF totally NSSA 区域的特点和配置5) 掌握被动接口的作用6) 掌握 OSPF LSA7 的作用7) 掌握 OSPF 邻居间的验证2. 实验拓扑3. 实验需求1) 参考拓扑,完成各路由器的基本配置,除图示地址标识外,设备间的地址自己规划.2) 完成各路

CCNA综合实验,vlan,vlan间路由,vtp,HSRP,PVST,DHCP。

本实验综合了,vlan间路由,DHCP,VTP,PVST,HSRP.本实验目的就是把这几种协议融合一起实现主机互通,相信实际运用这种例子还是很多见的.希望大家看看,有错误的请指正.也是辛苦了好长时间才弄到这上面的. 第一步:先把每个交换机上各个接口起TRUNK模式(除了接PC的接口) SW1 Switch> Switch> Switch>en Switch#conf t Enter configuration commands, one per line.  End with CNTL/

【实验】综合实验(VLAN间通信,ACL技术,DNS/WEB服务器架设,RIP路由)

实验名称:综合实验 实验目的: 1实现全网互通2Client1可以访问www.ntd1711.com并保存网页文件3PC1与PC2之间的任何类型的流量都无法互通涉及技术:VLAN间通信/RIP/DNS/WEB/3层交换机/ACL 拓扑图: 相关设备: 二层交换机:SW1/SW2/SW3三层交换机:MSW1/MSW2(MSW1为VLAN10/20的网关)(MSW2为VLAN30/40的网关)服务器:DNS服务器/WEB服务器终端设备:主机1-5/客户端1配置思路:一-全网互通(VLAN间畅通)#2