uva 116

Unidirectional TSP

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling
Salesperson Problem (TSP) -- finding whether all the cities in a salesperson‘s route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate
amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an  matrix of integers, you are to write a program
that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1
in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps‘‘ so that it represents a horizontal cylinder. Legal steps are illustrated below.

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different  matrices are shown below
(the only difference is the numbers in the bottom row).

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by  integers
where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second
row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path‘s weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence
of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19

Submit Status

//#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<map>
#include<set>
#include<time.h>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define eps 1e-8
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
typedef pair<int , int> pii;
#define M 12
#define N 110

LL a[M][N];
LL d[M][N];
int m, n;

int main()
{
    while(~scanf("%d%d", &m, &n))
    {
        for(int i = 0; i < m; i++)
        for(int j = 0; j < n; j++)
        scanf("%lld", &a[i][j]);
        memset(d, 0x3f, sizeof d);

        LL ans = INF;
        int pos;
        for(int j = n - 1; j >= 0; j--)
        for(int i = 0; i < m; i++)
        {
            if(j == n - 1) d[i][j] = a[i][j];
            else  d[i][j] = min(min(d[(i-1+m)%m][j+1], d[i][j+1]), d[(i+1)%m][j+1]) + a[i][j];

            if(!j)
            {
                if(ans > d[i][j])
                {
                    ans = d[i][j];
                    pos = i;
                }
            }
        }

        LL cur = ans;
        n == 1 ? printf("%d\n", pos + 1) : printf("%d ", pos + 1);
        for(int j = 1; j < n; j++)
        {
            cur -= a[pos][j-1];
            int go[3] = {(pos - 1 + m) % m, pos, (pos + 1) % m};
            sort(go, go + 3);
            for(int i = 0; i < 3; i++)
            {
                if(d[go[i]][j] == cur)
                {
                    pos = go[i];
                    j == n - 1 ? printf("%d\n", pos + 1) : printf("%d ", pos + 1);
                    break;
                }
            }
        }
        printf("%lld\n", ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-03 09:04:38

uva 116的相关文章

uva 116 - Unidirectional TSP (动态规划)

第一次做动规题目,以下均为个人理解以及个人方法,状态转移方程以及状态的定义也是根据个人理解,请过路大神指教. 状态:每一列的每一个数[ i ][ j ]都是一个状态: 然后定义状态[ i ][ j ]的指标函数d[ i ][ j ]为从[ i ][ j ]向右出发的可以得到的最小的整数和: 状态转移方程:d[ i ][ j ]=min(d[ i+1 ][ j+1 ][ i-1 ][ j+1 ][ i ][ j+1 ])+a[ i ][ j ]; 其中a[ i ][ j ]为当前位置的数值: 然后

uva 116 Unidirectional TSP【号码塔+打印路径】

主题: uva 116 Unidirectional TSP 意甲冠军:给定一个矩阵,当前格儿童值三个方向回格最小值和当前的和,就第一列的最小值并打印路径(同样则去字典序最小的). 分析:刚開始想错了,从前往后走,这种话没有办法控制字典序最小,用dfs标记了一下超时了. 事实上从后往前走就好了. 以后一定先想清楚顺序.然后dp的时候选择字典序最小的.用father数据记录就可以. AC代码: #include<iostream> #include<cstdio> #include&

uva 116 Unidirectional TSP (DP)

uva 116 Unidirectional TSP Background Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Sa

uva 116 Unidirectional TSP【数塔+打印路径】

题目: uva 116 Unidirectional TSP 题意:给出一个矩阵,当前的格子值为后面三个方向的格子最小值和当前的和,就第一列的最小值并打印路径(相同则去字典序最小的). 分析:刚开始想错了,从前往后走,这样的话没有办法控制字典序最小,用dfs标记了一下超时了. 其实从后往前走就好了.以后一定先想清楚顺序,然后dp的时候选择字典序最小的,用father数据记录即可. AC代码: #include<iostream> #include<cstdio> #include&

UVA - 116 - Unidirectional TSP (简单DP + 打印路径)

题目传送:UVA - 116 思路:可以定义状态为dp[i][j] 为从第i行第j列开始往后走到第n列(总共n列)的最小值(赋初始值为无穷),且状态方程很好推出来:dp[i][j] = a[i][j] + max(dp[i-1][j+1], dp[i][j+1], dp[i+1][j+1]);    最后最优解  ans = max(dp[i][1])(1<=i<=m); 不过这题难点不在这里,而是可能有多组最小值,输出字典序最小的那组: 这里要注意好递推的方向,只能从右往左递推列数,而如果从

UVA 116 Unidirectional TSP(DP最短路字典序)

Description  Unidirectional TSP  Background Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Travel

uva 116 Unidirectional TSP 单向TSP 问题,经典dP(路径输出注意规划方向)

Unidirectional TSP Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu Submit Status Practice UVA 116 Appoint description: Description Download as PDF Background Problems that require minimum paths through some domain appear in many differ

多阶段决策问题(UVa 116)

在回溯法中,每个决策对应于给一个节点产生新的子树,而解的生成过程对应一颗解答树,节点的层数就是下一个待填充位置$cur$. 在多阶段决策的最优化问题,大多可以用dp解决,状态转移则类似于回溯法中的解答树. UVa 116 $d(i,j)$表示从第此处出发到达最后一列的最小和,要求字典序最小,就同时要记录行号的最小值. 代码: 1 // 2 // main.cpp 3 // UVa 116 4 // 5 // Created by Yanbin GONG on 12/3/2018. 6 // Co

Uva 116,单向TSP

题目链接:https://uva.onlinejudge.org/external/1/116.pdf 和矩形嵌套,巴比伦塔差不多. 题意: 给出矩阵,这个矩阵是环形的,就是说第一行的上一行是最后一行,最后一行的下一行是第一行,要求从最左边一列走到最右边一列,路径上的和最小.多组解输出字典序最小的解. 分析: DAG多段图,dp(i,j)从第i行,第j列出发的最优解,然后走一遍每一行的第一列. 这里的字典序最小,每次决策时的三个选择,每一行,重新排个序,这样就保证了字典序最小. 姜来是老的辣,写

UVa 116 Unidirectional TSP(DP)

题意  一个n*m的环形矩阵(第一行和最后一行是相邻的)  从第一列任意位置出发  只能往右上,右,右下3个方向走  求走到第m列经过的的最小数字和 基础DP  横着的数塔问题 #include <bits/stdc++.h> #define l(x) d[x][j+1] using namespace std; const int N = 105; int n, m, g[N][N], d[N][N], fol[N][N]; int main() { int n, m, u, b, t, k