hdu2652——Warching TV

Warching TV

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 185    Accepted Submission(s): 67

Problem Description

Lemon likes warching TV very much. When winter holiday comes, it is a good time, isn’t it. There are lots of TV program listed on the paper. Every TV program has its start time ,end time, and the happiness value that will add Lemon’s
happiness and it depends on Lemon’s taste.

Input

There are many test cases. Please process to end of file. Each test case starts with one integer N (1 <= N <= 100000) which indicates the size of the list of the TV program. Then N lines follow, each line contains three integers s,
e and v. s, e indicate that the TV program is during [s, e](1 <= s <= e <= 1000000). v indicates that after warching the TV program will add Lemon v happyiness(1 <= v <= 1000). Once Lemon choose a TV program, he must finish warching the TV program.

Output

Print the maximum happiness value that Lemon will get.

Sample Input

2
1 2 1
3 4 2
2
1 2 1
2 4 2

Sample Output

3
2

Author

lemon

Source

决战龙虎门

Recommend

yifenfei   |   We have carefully selected several similar problems for you:  2658 2655 2656 2670 2650

dp[i]表示处理到第i个节目的时候的最大值

dp[i] = max(dp[i - 1], dp[j] + v[i]);

分别对应不看第i个节目, 看第i个节目时最大的收获,由于每一步都是子问题的最优解,所以决策的时候可以二分查找答案(子问题具有单调性)

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 100010;

struct node
{
	int l, r, w;
}inter[N];
int dp[N];

int cmp(node a, node b)
{
	if (a.r != b.r)
	{
		return a.r < b.r;
	}
	return a.l < b.l;
}

int main()
{
	int n;
	while(~scanf("%d", &n))
	{
		memset (dp, 0, sizeof(dp));
		for (int i = 0; i < n; ++i)
		{
			scanf("%d%d%d", &inter[i].l, &inter[i].r, &inter[i].w);
		}
		sort (inter, inter + n, cmp);
		dp[0] = inter[0].w;
		for (int i = 1; i < n; ++i)
		{
			dp[i] = inter[i].w;
			int l = 0, r = i - 1, mid, ans = -1;
			while (l <= r)
			{
				mid = (l + r) >> 1;
				if (inter[mid].r < inter[i].l)
				{
					ans = mid;
					l = mid + 1;
				}
				else
				{
					r = mid - 1;
				}
			}
			if (ans != -1)
			{
				dp[i] = max(dp[i], dp[ans] + inter[i].w);
			}
			dp[i] = max(dp[i], dp[i - 1]);
		}
		printf("%d\n", dp[n - 1]);
	}
	return 0;
}
时间: 2024-10-05 05:16:09

hdu2652——Warching TV的相关文章

阿凡达的说法安德森发斯蒂芬

http://bangumi.tv//blog/77457 http://bangumi.tv//blog/77516 http://bangumi.tv//blog/77650 http://bangumi.tv//blog/77697 http://bangumi.tv//blog/77802 http://bangumi.tv//blog/77842 http://bangumi.tv//blog/77914 http://bangumi.tv//blog/77980 http://ban

QUHD TV量子点电视显示行业的下一个风口?

从学生视听时代的卡带机到CD再到VCD和DVD,从显示时代的CRT到液晶再到如今的4K的超高清.科技的迭代改变着生活方式同样也颠覆着整个行业的创新和生存方式.就电视行业而言,从热炒的3D开始,科技不断为消费者提供更为难以想象的体验方式,那么,量子点科技的热潮能否成为电视行业的真正风口? 众行业专家力赞量子点 国际顶尖纳米材料科学家.国家千人计划入选者彭笑刚认为,量子点是人类至今发现的最好发光材料,其保障发光颜色可以颠覆从蓝光到红光的整个可见区,而且色纯度高.连续可调.并且量子点已经开始应用于生物

android tv焦点特效实现浅析

Android TV上的焦点凸显特效相信大家都看到过,那么我们就来实现它吧,首先上张效果图. 先说一下实现原理,主要通过重写RelativeLayout实现item,之后在其中加入scalanimation动画效果.刚开始处理时,还是发现了一些问题,比如item放大后会被其他item遮挡,如何添加选中边框等等,以及动画的实现等等.下面放上实现细节. 首先是item的代码: <view xmlns:android="http://schemas.android.com/apk/res/and

第一个Android TV Launcher开源项目

Android TV Launcher开源项目 这个项目是机顶盒桌面,用来播放视频.显示图片.应用管理和其他针对机顶盒产品的设置.目前git和CSDN code上面都没有类似的开源项目,正好本人最近在开发类似产品,网上类似研究还非常少,完全自己实现还是比较困难.所以就把目前的项目开源出来,也有利于其他人少走弯路. git项目地址 CSDN code项目地址 项目框架结构 UI.adapter.实体类.图片cache.网络层. 这个层级关系还是和大部分项目是类似的. 功能模块的详细实现方式 这个部

许仙章鱼TV

http://v.youku.com/v_show/id_XMTY3NTYwNTE4MA==.html?from=s1.8-1-1.2&spm=a2h0k.8191407.0.0 20160804象棋特级大师许银川章鱼TV直播 争都空间优势,压制,破坏对方意图.走棋注意效率.不要让黑房有任何骚扰机会. 交换步数后的差别.看不出棋来不急于反击! 有更好的棋就不用去做无谓的冒险!首先把自己最大的弱点解决然后想办法进攻!棋的均衡感! http://www.soku.com/search_video/q

POJ 1966 Cable TV Network(顶点连通度的求解)

Cable TV Network Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 4678   Accepted: 2163 Description The interconnection of the relays in a cable TV network is bi-directional. The network is connected if there is at least one interconnecti

苹果将通过新Apple TV打造电视游戏平台 欲发力家庭游戏(转)

据<纽约时报>报道,9月10日凌晨1时举行的苹果发布会上将会公布新版Apple TV设备,还会推出TV版App Store.新设备以游戏作为主要卖点,图形性能将大幅提升. 苹果2015年秋季发布会即将在北京时间9月10日凌晨1时举行,除了一年一更新的iPhone之外,今年还传出了苹果将会更新Apple TV产品线的消息:得到久违升级的Apple TV将不再只是一个观看视频的机顶盒,还将在电视游戏上发力. 据<纽约时报>报道,接近新Apple TV项目的线人纷纷表示,用iPhone和

POJ 1966 Cable TV Network

Cable TV Network Time Limit: 1000ms Memory Limit: 30000KB This problem will be judged on PKU. Original ID: 196664-bit integer IO format: %lld      Java class name: Main The interconnection of the relays in a cable TV network is bi-directional. The ne

ZOJ 2182 Cable TV Network(无向图点割-最大流)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2182 题意:给出一个无向图,问最少删掉多少个顶点之后图变得不连通? 思路:将原图每个点拆点(i,i+n),连边<i,i+n,1>,对原图的边(u,v),连边<u+n,v,INF>,<v+n,u,INF>.然后对于每对顶点(i,j)跑最大流(i+n,j).所有最大流的最小值即为答案. struct node { int v,cap,nex