A Knight's Journey

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

大意:一个骑士从原点出发,只能走马字型路线, 要求遍历所有路径的字典序排序(就是先A再B再C),用DFS思想遍历每一种状态,如果最后步数等于图的大小那么就直接输出,难在字典序排序(虽然还不知道为什么这样写dir这个数组- -||),用visit记录已经经过的点,最后如果DFS失败那么visit要重新变成0

#include<cstdio>
#include<cstring>
using namespace std;
const int inf = 27;
int visit[inf][inf];
int dir[8][2] = {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
int flag ,p, q,ans;
struct edge{
    char s;
    int num;
}a[inf*inf];
void dfs(int x,int y,int step)
{
    if(flag == 0 ) return  ;
    if(visit[x][y]) return ;
    visit[x][y] = 1;
    if(step == ans){
            flag = 0;
            for(int i = 1; i <= ans;i++)
                printf("%c%d",a[i].s,a[i].num);
                printf("\n");
                return ;

    }
    for(int i = 0; i < 8 ; i++){
        int x1 = x + dir[i][0];
        int y1 = y +dir[i][1];
        if( x1 < 1||y1 < 1||x1 >p||y1 > q||visit[x1][y1] == 1)
            continue;
        a[step+1].s = ‘A‘ + y1 - 1;
        a[step+1].num =  x1;
        dfs(x1,y1,step+1);
        visit[x1][y1] = 0;
    }
}

int main()
{
int T,count = 1;
scanf("%d",&T);
while(T--){
    memset(visit,0,sizeof(visit));
     flag = 1;
     a[1].s = ‘A‘,a[1].num = 1;
    scanf("%d%d",&p,&q);
    ans = p*q;
    printf("Scenario #%d:\n",count++);
    dfs(1,1,1);
    if(flag == 1)
    printf("impossible\n");
    if(T!=0)
    printf("\n");
}
return 0;
}

A Knight's Journey

时间: 2024-08-08 17:49:57

A Knight's Journey的相关文章

A Knight&#39;s Journey(DFS)深搜

A Knight's Journey Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 33634 Accepted: 11450 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around

POJ2488A Knight&#39;s Journey(dfs+数学)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 32422   Accepted: 11040 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

POJ 2488 A Knight&#39;s Journey

A Knight's Journey Time Limit: 1000ms Memory Limit: 65536KB This problem will be judged on PKU. Original ID: 248864-bit integer IO format: %lld      Java class name: Main Background  The knight is getting bored of seeing the same black and white squa

I - A Knight&#39;s Journey

I - A Knight's Journey Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Description BackgroundThe knight is getting bored of seeing the same black and white squares again and again and has decided to make a j

poj_2488 A Knight&#39;s Journey

比较典型的深搜,注意1,最后的输出格式,我imposiable后面忘记endl了,结果PE了两次,有点可惜: 2.最后要以字典序输出 1 #include<iostream> 2 #include<string.h> 3 using namespace std; 4 5 #define MAX 8 6 7 int p,q; 8 int board[MAX][MAX]; 9 int steps[MAX*MAX]; 10 11 int dir[8][2] = {{-1,-2},{1,-

POJ2488-A Knight&#39;s Journey(DFS+回溯)

题目链接:http://poj.org/problem?id=2488 A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 36695   Accepted: 12462 Description Background The knight is getting bored of seeing the same black and white squares again and again

dfs/poj 2488 A Knight&#39;s Journey

1 #include<cstdio> 2 using namespace std; 3 const int b[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}}; 4 int a[30][30],p,q; 5 struct 6 { 7 int x,y; 8 }step[910]; 9 10 bool dfs(int x,int y,int now) 11 { 12 if (now==p*q) return true;

poj A Knight&#39;s Journey(DFS)

题目链接:http://acm.hrbust.edu.cn/vj/index.php?c=problem-problem&id=190592 题意:给出p*q的棋盘,从(A,1)开始,走“日”字,问能否走完棋盘上所有的点,如果能,按字典序输出路径: 思路:DFS,并保存路径即可,注意处理走的方向顺序int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}}; #include <stdio.h> #in

poj2488--A Knight&#39;s Journey(dfs,骑士问题)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 31147   Accepted: 10655 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

POJ 2488 A Knight&#39;s Journey (DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 30656   Accepted: 10498 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar