poj1144 割点割边问题 dfs暴力

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

Hint

You need to determine the end of one line.In order to make it‘s easy to determine,there are no extra blank before the end of each line.

割点:去除这个点之后连通分量增加

割边:去除这条边之后连通分量增加

DFS判断割点的方法:

①s是根节点且有两个或更多的子节点

②非根节点u,当且仅当u存在一个子节点v,v及其后代都没有回退边连回u的祖先

#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
const int N=109;
int low[N],num[N],dfn; //num[u]记录DFS每个点的访问顺序 low[u]记录v和v的后代能连回到祖先的num
bool iscut[N];
vector <int> G[N];
void dfs(int u, int fa){       //u的父结点是fa
	low[u] = num[u] = ++ dfn;     //初始值
	int child = 0;                  //孩子数目
	for (int i = 0;i < G[u].size(); i++)	{   //处理u的所有子结点
		int v = G[u][i];
		if (!num[v]) {              //v没访问过
		    child++;
			dfs(v, u);
			low[u] = min(low[v], low[u]);    //用后代的返回值更新low值
			if (low[v] >= num[u] && u !=1)
                iscut[u] = true;              //标记割点            //if(low[v]>num[u]&&u!=1) iscut[u]=true  判断割边
		}
		else if(num[v] < num[u] && v != fa)
 		       //处理回退边,注意这里v != fa,fa是u的父结点,
       //fa也是u的邻居,但是前面已经访问过,不需要处理它
            low[u] = min(low[u], num[v]);
	}
	if (u == 1 && child >= 2)     //根结点,有两个以上不相连的子树
        iscut[1] = true;
}
int main(){
    int ans,n;
	while (scanf("%d",&n)!=-1){
		if (n==0)break;
		memset(low,0,sizeof(low));
		memset(num,0,sizeof(num));
		dfn=0;
		for (int i=0;i<=n;i++) G[i].clear();
		int a,b;
		while (scanf("%d",&a)&&a)
			while (getchar()!=‘\n‘){
				scanf("%d",&b);
				G[a].push_back(b);
				G[b].push_back(a);
			}
		memset(iscut,false,sizeof(iscut));
		ans = 0;
		dfs(1,1);
		for (int i=1;i<=n;i++) ans+=iscut[i];
		printf("%d\n",ans);
	}
}

  

原文地址:https://www.cnblogs.com/lyj1/p/11392798.html

时间: 2024-10-11 22:07:39

poj1144 割点割边问题 dfs暴力的相关文章

求割点 割边 Tarjan

附上一般讲得不错的博客 https://blog.csdn.net/lw277232240/article/details/73251092 https://www.cnblogs.com/collectionne/p/6847240.html https://blog.csdn.net/zhn_666/article/details/77971619 然后附上模板题:              https://vjudge.net/problem/HihoCoder-1183 裸题,直接要你输

Tarjan&amp;割点&amp;割边&amp;点双&amp;边双&amp;缩点

文末有福利. Tarjan是通过搜索树和压栈完成的,维护两个东西:dfn[i](时间戳).low[i](通过搜索树外的边i(返祖边),节点能到达的最小节点的时间戳). 跑完Tarjan,缩点,可以得到DAG图(有向无环图),可以再建图或统计入度出度. 在有向图中,可以找强连通分量SCC(极大强联通子图)(任意两点可以互达): 多维护一个vis[i]表示在不在栈中. 1 void tarjan_(int u) 2 { 3 stack[++tp]=u; 4 dfn[u]=low[u]=++num;

hdu 5024 Wang Xifeng&#39;s Little Plot (dfs+暴力)

Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 194    Accepted Submission(s): 131 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>)

Codeforces 6D Lizards and Basements 2 dfs+暴力

题目链接:点击打开链接 #include<stdio.h> #include<iostream> #include<string.h> #include<set> #include<vector> #include<map> #include<math.h> #include<queue> #include<string> #include<stdlib.h> #include<a

ACM: Gym 100935G Board Game - DFS暴力搜索

Board Game Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Gym 100935G Description standard input/outputStatements Feras bought to his nephew Saleem a new game to help him learning calculating. The game consists of a boar

NOIP 2002提高组 选数 dfs/暴力

1008 选数 2002年NOIP全国联赛普及组 时间限制: 1 s 空间限制: 128000 KB 题目等级 : 黄金 Gold 题目描述 Description 已知 n 个整数 x1,x2,…,xn,以及一个整数 k(k<n).从 n 个整数中任选 k 个整数相加,可分别得到一系列的和.例如当 n=4,k=3,4 个整数分别为 3,7,12,19 时,可得全部的组合与它们的和为: 3+7+12=22 3+7+19=29 7+12+19=38 3+12+19=34. 现在,要求你计算出和为素

ACM: FZU 2107 Hua Rong Dao - DFS - 暴力

FZU 2107 Hua Rong Dao Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Practice Description Cao Cao was hunted down by thousands of enemy soldiers when he escaped from Hua Rong Dao. Assuming Hua Rong Dao is a narrow aisle

hdu1015 dfs暴力搜索所有情况模板

脑子有点坑,不知道为什么,可能以前遇到阴影了,现在看到dfs暴力搜有种莫名的害怕,总结一下模板吧 这题还是没意思的,直接暴力搜,不过我写的很烂,可能就是这个原因吧,看了别人的模板,觉得不错. 学了个单词”lexicography“ 字典序,又吃了没文化的亏,wa一次 #include <iostream> #include <cstdio> #include <cstdlib> #include <cstring> #include <cmath>

Codeforces Round #286 (Div. 2)B. Mr. Kitayuta&#39;s Colorful Graph(dfs,暴力)

数据规模小,所以就暴力枚举每一种颜色的边就行了. #include<iostream> #include<cstdio> #include<cstdlib> #include<cstring> #include<string> #include<cmath> #include<map> #include<set> #include<vector> #include<algorithm>