Ping pong

Description

N(3N20000) ping
pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other
ping pong players and hold the game in the referee‘s house. For some reason, the contestants can‘t choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee‘s house, and because they are lazy, they
want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call
two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1T20) ,
indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N , the number of players. Then N distinct
integers a1a2...aN follow, indicating the skill rank of each player, in the order of west to east ( 1ai100000 , i =
1...N ).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3

Sample Output

1


思路:  采用前缀和,后缀和得到结果

再求前缀和,后缀和的时候后用树状数组算法得出来。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
int max(int a,int b) {return a>b?a:b;}
inline int lowbit(int x)
{
  return x&(-x);//2^k
}
struct Fen
{
  int n;
  vector<int> c;

  void resize(int n) {this->n=n;c.resize(n);}
  void clear() {fill(c.begin(),c.end(),0);}
  int sum(int x) //求前 N项的和
  {
    int r=0;
	while(x>0)
	{
	 r+=c[x];
	 x-=lowbit(x);
	}
	return r;
  }
  void add(int x,int d)//求前 N项sum的和
  {
    while(x<=n)
	{
	  c[x]+=d;x+=lowbit(x);
	}
  }
};

int n,a[20005],c[20005],d[20005];
Fen f;

int main()
{
  int t,i;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
    memset(a,0,sizeof(a));
    memset(c,0,sizeof(c));
    memset(d,0,sizeof(d));
    int maxs=0;
	for(i=1;i<=n;i++)
	{
	  scanf("%d",&a[i]);
	  maxs=max(maxs,a[i]);
	}
	f.resize(maxs+1);
	f.clear();

	for(i=1;i<=n;i++)//前缀和
	{
	  f.add(a[i],1);//求前 N项sum的和
	  c[i]=f.sum(a[i]-1);//求前 N项的和
	}
	f.clear();
	for(i=n;i>=1;i--)//后缀和
	{
	  f.add(a[i],1);
	  d[i]=f.sum(a[i]-1);
	}
	long long ans=0;
	for(i=2;i<n;i++)
		ans+=(long long)c[i]*(n-i-d[i])+(long long)d[i]*(i-1-c[i]);
	printf("%lld\n",ans);
  }
  return 0;
}
时间: 2024-09-28 20:28:15

Ping pong的相关文章

POJ 3928 &amp; HDU 2492 Ping pong(树状数组求逆序数)

题目链接: PKU:http://poj.org/problem?id=3928 HDU:http://acm.hdu.edu.cn/showproblem.php?pid=2492 Description N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To im

uva 1428 - Ping pong(树状数组)

题目链接:uva 1428 - Ping pong 题目大意:一条大街上住着n个乒乓球爱好者,经常组织比赛.每个人都有一个不同的能力值,每场比赛需要3个人,裁判要住在两个选手之间,并且能力值也要在选手之间,问说最多能举行多少场比赛. 解题思路:预处理出bi和ci分别表示说在1~i中能力值比第i个人小的人和i+1~n中能力值比第i个人小的.处理过程用树状数组维护即可. #include <cstdio> #include <cstring> #include <algorith

Motion sensing game (Ping Pong Game)

Project Demonstration Here is the source code of the project based on OpenCV anc C++. Before you run this code on Linux, you should install the OpenCV library  first. #include<opencv/highgui.h> #include<opencv2/opencv.hpp> #include<string&g

poj3928 Ping pong 树状数组

http://poj.org/problem?id=3928 Ping pong Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 2087   Accepted: 798 Description N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player

【HDOJ】2492 Ping pong

线段树+离散化. 1 #include <cstdio> 2 #include <cstring> 3 #include <cstdlib> 4 5 #define MAXN 20005 6 #define lson l, mid, rt<<1 7 #define rson mid+1, r, rt<<1|1 8 9 int buf[MAXN], bk[MAXN]; 10 int sum[MAXN<<2], n; 11 12 int

UVAlive - 4329 —— Ping pong 【树状数组】

http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=13895 #include <iostream> #include <cstdio> #include <cstring> #include <string> using namespace std; const int MAXA = 100000 + 5; int n; int c[MAXA]; int sum(int i) { int

HDU 2492 Ping pong (树状数组)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2492 Ping pong Problem Description N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank

UVA - 1428 Ping pong

N (3 ≤ N ≤ 20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must

erlang分布式入门(一)-ping pong

erlang分布式入门(一)-ping pong 测试环境和http://willvvv.iteye.com/blog/1523918 一样,192.168.0.182(centos-182)和192.168.0.183(centos-183), 1.按照上面链接(步骤1-4)设置通过ssh hostname 免输入密码直接登录. 2.设置erlang的magiccookie,由于都是以root账号操作,分别在两台机子上执行以下命令 cd /root vi .erlang.cookie 输入 S