Switch Game
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14821 Accepted Submission(s):
9051
Problem Description
There are many lamps in a line. All of them are off at
first. A series of operations are carried out on these lamps. On the i-th
operation, the lamps whose numbers are the multiple of i change the condition (
on to off and off to on ).
Input
Each test case contains only a number n ( 0< n<=
10^5) in a line.
Output
Output the condition of the n-th lamp after infinity
operations ( 0 - off, 1 - on ).
Sample Input
1
5
Sample Output
1
0
Hint
hint
Consider the second test case:
The initial condition : 0 0 0 0 0 …
After the first operation : 1 1 1 1 1 …
After the second operation : 1 0 1 0 1 …
After the third operation : 1 0 0 0 1 …
After the fourth operation : 1 0 0 1 1 …
After the fifth operation : 1 0 0 1 0 …
The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
import java.util.*;
class Main{
public static void main(String args[])
{Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{int n=cin.nextInt();
if(n==1)
System.out.println("1");
else{
int sum=1;
for(int i=2;i*i<=n;i++)
{if(n%i==0&&i!=n/i)
sum+=2;
else if(n%i==0&&n/i==i)
sum+=1;
}
int f=1;
for(int i=1;i<=sum;i++)
{if(f==1)
f=f-1;
else if(f==0)
f=f+1;
}
System.out.println(f);
}
}
}
}
这个题目有规律的,多写几个你就会发现规律的。