分支-13. 计算天数(15)

本题要求编写程序计算某年某月某日是该年中的第几天。

输入格式:

输入在一行中按照格式“yyyy/mm/dd”(即“年/月/日”)给出日期。注意:闰年的判别条件是该年年份能被4整除但不能被100整除、或者能被400整除。闰年的2月有29天。

输出格式:

在一行输出日期是该年中的第几天。

输入样例1:

2009/03/02

输出样例1:

61

输入样例2:

2000/03/02

输出样例2:

62

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		String str = cin.nextLine();
		String[] strs = str.split("/");
		int year = Integer.parseInt(strs[0]);
		int month = Integer.parseInt(strs[1]);
		int day = Integer.parseInt(strs[2]);
		int[] months = { 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 };
		if ((year % 4 == 0 && year % 100 != 0) || year % 400 == 0) {
			months[1] = 29;
		}
		int result = 0;
		for (int i = 0; i < month - 1; i++) {
			result += months[i];
		}
		result += day;
		System.out.print(result);
	}
}

分支-13. 计算天数(15)

时间: 2024-11-03 21:09:32

分支-13. 计算天数(15)的相关文章

*分支-13. 计算天数

1 /* 2 * Main.c 3 * B13-分支-13. 计算天数 4 * Created on: 2014年6月12日 5 * Author: Boomkeeper 6 * 7 ******测试又是木有完全通过啊********* 8 */ 9 10 #include <stdio.h> 11 #include <stdlib.h> 12 13 #define JANUARY 31 14 #define FEBRUARY 28 15 #define MARCH 31 16 #

分支-11. 计算工资(15)

1 /* 2 *c语言实现 3 *B11-分支-11. 计算工资(15) 4 *Created on: 2014年6月3日 5 *Author: Boomkeeper 6 *未全部通过 7 * 8 */ 9 10 #include <stdio.h> 11 #include <stdlib.h> 12 13 float salary=0; 14 15 void newStaff(int *worktime) 16 { 17 if(*worktime<=40) 18 { 19

练习7-9 计算天数 (15分)

本题要求编写程序计算某年某月某日是该年中的第几天. 输入格式: 输入在一行中按照格式“yyyy/mm/dd”(即“年/月/日”)给出日期.注意:闰年的判别条件是该年年份能被4整除但不能被100整除.或者能被400整除.闰年的2月有29天. 输出格式: 在一行输出日期是该年中的第几天. 输入样例1: 2009/03/02 输出样例1: 61 输入样例2: 2000/03/02 输出样例2: 62 #include<stdio.h> int main() { int nian,yue,ri; in

分支-12. 计算火车运行时间(15)

#include<iostream>#include<iomanip>using namespace std;int main(){    int s,e;    cin>>s>>e;    cout<<setfill('0');    if(e%100>=s%100)        cout<<setw(2)<<e/100-s/100<<":"<<setw(2)<&

PHP日期操作类代码-农历-阳历转换、闰年、计算天数等

这是一个实用的PHP日期时间操作类,里面包括了公历-农历转换.转换成中文日期格式.计算农历相隔天数.根据阴历年获取生肖.获取阴历月份的天数.获取农历每年的天数.获取闰月.计算阴历日期与正月初一相隔的天数.计算2个公历(阳历)日期之间的天数.根据距离正月初一的天数计算阴历日期.获取天干地支纪年等,PHP日期操作类:Lunar.class.php代码如下: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27

*分支-11. 计算工资

1 /* 2 *Main.c 3 *B11-分支-11. 计算工资(15) 4 *Created on: 2014年6月3日 5 *Author: Boomkeeper 6 * 7 ******测试未通过********* 8 */ 9 10 #include <stdio.h> 11 #include <stdlib.h> 12 13 float salary=0; 14 15 void newStaff(int *worktime) 16 { 17 //printf("

*分支-12. 计算火车运行时间

1 /* 2 * Main.c 3 * B12-分支-12. 计算火车运行时间 4 * Created on: 2014年6月4日 5 * Author: Boomkeeper 6 * 7 ********测试未通过******* 8 */ 9 #include <stdio.h> 10 #include <stdlib.h> 11 12 int startTime,arrTime; 13 int *p_startTime=&startTime; 14 int *p_arr

分支-10. 计算个人所得税

1 /* 2 * Main.c 3 * B10-分支-10. 计算个人所得税(10) 4 * Created on: 2014年5月29日 5 * Author: Boomkeeper 6 * 7 * 测试通过 8 */ 9 10 11 #include <stdio.h> 12 #include <stdlib.h> 13 14 int main() 15 { 16 float salary=0; 17 float *ps=&salary; 18 19 scanf(&qu

计算天数

1 #include<stdio.h> 2 #include<stdlib.h> 3 int main() 4 { 5 int j; 6 int year, month, day; 7 int sum = 0; //计算天数 8 int flag; //判断平年或者闰年 9 int a[][13] = { 10 {0,31,28,31,30,31,30,31,31,30,31,30,31}, 11 {0,31,29,31,30,31,30,31,31,30,31,30,31} 12