POJ3624Charm Bracelet(01背包)

Charm Bracelet

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23359   Accepted: 10532

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the
N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight
Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor
Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than
M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:
Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

还是01背包

#include<iostream>
#include<cstdio>
#include<cmath>
#include<queue>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{

    int n,i,j,v;
    while(scanf("%d%d",&n,&v)!=EOF){
        int dp[13000]={0},c[3500],w[3500];
        for(i=0;i<n;i++)
            scanf("%d%d",c+i,w+i);
        for(i=0;i<n;i++)
        {
            for(j=v;j>=c[i];j--)
            {
                if(dp[j]<dp[j-c[i]]+w[i])
                {
                    dp[j]=dp[j-c[i]]+w[i];
                }
            }
        }
        printf("%d\n",dp[v]);
    }
    return 0;
}

POJ3624Charm Bracelet(01背包)

时间: 2024-08-03 11:14:46

POJ3624Charm Bracelet(01背包)的相关文章

POJ 3624 Charm Bracelet(01背包裸题)

Charm Bracelet Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 38909   Accepted: 16862 Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible fro

POJ 3624 Charm Bracelet (01背包)

Charm Bracelet Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 26078   Accepted: 11726 Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible fro

POJ - 3624 Charm Bracelet (01背包基础)

题意: 即是给你一个容量M的包,有N件物品,每件物品有分别对应的 价值value 以及 重量weight .然后在不超过该背包容量的情况下能得到的最大价值为多少? 思路: 由于这是最基础的问题,所以就记录当对 01背包状态转移方程式的 理解. 对于动态规划来说,首先要知道我们要确定哪些状态量.然后再基于这些状态量进行状态转移得到我们最后希望得到的答案. 比如对于序列求最值来说我们习惯记录最后位取的是谁(即末位j),那么同理我们也可以记录我们当前选的是哪一种 物品.同时容量在状态中是必不可少的,所

[USACO07DEC]手链Charm Bracelet——01背包

题目描述 Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400),

poj3642 Charm Bracelet(0-1背包)

题目意思: 给出N,M,N表示有N个物品,M表示背包的容量,接着给出每个物品的体积和价值,求背包能够装在的最大价值. http://poj.org/problem?id=3624 题目分析: o-1背包问题,转化方程.dp[j]:表示容量为j的时候,背包的最大价值 dp[j]=max(dp[j],dp[j-w[i]]+d[i]); AC代码: #include<iostream> #include<cstring> using namespace std; int dp[20000

poj3624 Charm Bracelet(0-1背包 滚动数组)

题目链接:https://vjudge.net/problem/POJ-3624 题意:有N个物品,分别有不同的重量Wi和价值Di,Bessie只能带走重量不超过M的物品,要是总价值最大,并输出总价值. 一开始使用正常的dp然后显示超内存,按下面代码也超内存(dp数组太大了)但这种方法可以学习一下 #include <iostream> #include <cstring> using namespace std; int n,m; //int w[3403],d[12881];

[再做01背包] POJ 3624 Charm Bracelet

接触动态规划的第一题是数塔问题,第二题就是01背包问题了. 当时看的懵懵懂懂,回过头来再看这道题还是非常简单的了. 用 dp[i][j] 表示取前i种物品,使它们总体积不超过j的最优取法取得的价值总和状态转移方程:dp[i][j] = max(dp[i-1][j],dp[i-1][j-cost[i]]+weight[i]) 1 //#define LOCAL 2 #include <iostream> 3 #include <cstdio> 4 #include <cstri

Charm Bracelet(01背包)

Problem Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi 

POJ Charm Bracelet 挑饰品 (常规01背包)

问题:去珠宝店抢饰品,给出饰品种数n,能带走的重量m,以及每种饰品的重量w与价值v.求能带走的最大量. 思路:常规01背包. 1 #include <iostream> 2 using namespace std; 3 const int N=100000; 4 int w[N], v[N],dp[N]; 5 6 void cal(int n, int m) 7 { 8 for(int i=0; i<n; i++) 9 for(int j=m; j>=w[i]; j--) 10 d