hdu 5012 Dice

Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 440    Accepted Submission(s): 259

Problem Description

There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom face, left face, right face,
front face and back face of dice A. Similarly, consider b1.b2,b3,b4,b5,b6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller
than 1 and no more than 6 while ai ≠ aj and bi ≠ bj for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, ai ≠ bi). Ddy wants to make the two dices look the same from all directions(which means for all i, ai = bi) only by the following
four rotation operations.(Please read the picture for more information)

Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.

Input

There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a1,a2,a3,a4,a5,a6, representing the numbers on dice A.

The second line consists of six integers b1,b2,b3,b4,b5,b6, representing the numbers on dice B.

Output

For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.

Sample Input

1 2 3 4 5 6
1 2 3 4 5 6
1 2 3 4 5 6
1 2 5 6 4 3
1 2 3 4 5 6
1 4 2 5 3 6

Sample Output

0
3
-1

Source

2014 ACM/ICPC Asia Regional Xi‘an Online

题目及代码:

直接光搜就可以了,最多搜索到5次就可以了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

struct node
{
    int s[6];
    int step;
}l,r,t,tmp;

queue<node>Q;

bool judge(node t)
{
    for(int i=0;i<6;i++)
    if(t.s[i]!=r.s[i]) return false;
    return true;
}

void left(node &t)
{
    int tmp=t.s[3];
    t.s[3]=t.s[1];
    t.s[1]=t.s[2];
    t.s[2]=t.s[0];
    t.s[0]=tmp;
}

void right(node &t)
{
    int tmp=t.s[0];
    t.s[0]=t.s[2];
    t.s[2]=t.s[1];
    t.s[1]=t.s[3];
    t.s[3]=tmp;
}

void front(node &t)
{
    int tmp=t.s[5];
    t.s[5]=t.s[1];
    t.s[1]=t.s[4];
    t.s[4]=t.s[0];
    t.s[0]=tmp;
}

void back(node &t)
{
    int tmp=t.s[0];
    t.s[0]=t.s[4];
    t.s[4]=t.s[1];
    t.s[1]=t.s[5];
    t.s[5]=tmp;
}

int bfs()
{
    while(!Q.empty())
    {
        Q.pop();
    }
    Q.push(l);
    while(!Q.empty())
    {
        t=Q.front();
        Q.pop();
        if(t.step>=5) break;
        if(judge(t)) return t.step;

        t.step++;
        tmp=t;
        right(tmp);
        Q.push(tmp);

        tmp=t;
        left(tmp);
        Q.push(tmp);

        tmp=t;
        front(tmp);
        Q.push(tmp);

        tmp=t;
        back(tmp);
        Q.push(tmp);
    }
    return -1;
}
int main()
{
    while(scanf("%d",&l.s[0])!=EOF)
    {
        l.step=0;
        for(int i=1;i<6;i++)
        {
            scanf("%d",&l.s[i]);
        }
        for(int i=0;i<6;i++)
        {
            scanf("%d",&r.s[i]);
        }
        int n=bfs();
        printf("%d\n",n);
    }

    return 0;
}
时间: 2024-07-28 20:02:55

hdu 5012 Dice的相关文章

HDU 5012 Dice (bfs + 记忆化搜索)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5012 Problem Description There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom face, left f

HDU 5012 Dice (BFS)

其实是很水的一道bfs,用字符串表示每个状态,map判重就ok了. 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5012 #include<iostream> #include<cstdio> #include<cstring> #include<cmath> #include<cctype> #include<algorithm> #include<string> #in

ACM学习历程—HDU 5012 Dice(ACM西安网赛)(bfs)

Problem Description There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A.

HDU - 5012 Dice(BFS)

Problem Description There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A.

HDU 5012 Dice DFS

简单DFS 1 //#pragma comment(linker, "/STACK:16777216") //for c++ Compiler 2 #include <stdio.h> 3 #include <iostream> 4 #include <cstring> 5 #include <cmath> 6 #include <stack> 7 #include <queue> 8 #include <v

HDU 4652 Dice (概率DP)

Dice Problem Description You have a dice with m faces, each face contains a distinct number. We assume when we tossing the dice, each face will occur randomly and uniformly. Now you have T query to answer, each query has one of the following form: 0

HDU 4599 Dice

Dice Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others) Total Submission(s): 211    Accepted Submission(s): 127 Problem Description Given a normal dice (with 1, 2, 3, 4, 5, 6 on each face), we define: F(N) to be the e

Spring-1-F Dice(HDU 5012)解题报告及测试数据

Dice Time Limit:1000MS     Memory Limit:65536KB Description There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, r

HDU 5012 骰子旋转(DFS)

http://acm.hdu.edu.cn/showproblem.php?pid=5012 保存骰子的状态,然后用dfs或者bfs搜索 还是再讲一下dfs 我们的目标是找一个与b相同,且转次数最少的状态 dfs就是树状图,要明确每个状态下的分支,以及边界条件 有4种变换,所以每个状态下面有四种分支,又因为骰子转4次以上的状态没有意义,所以边界条件可以是4 每个状态起始时与b判断,如果相同,则更新结果 #include <iostream> #include <string> #i