UESTC_王之迷宫 2015 UESTC Training for Search Algorithm & String<Problem A>

A - 王之迷宫

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)

Submit Status

王被困在了一个3维的迷宫中,他很想逃离这个迷宫回去当学霸,你能帮助他么? 由于王很仁慈,他悄悄地告诉你,本题读入迷宫的每一行时,要用scanf("%s"...) ......

Input

多组测试数据,对于每组测试数据,有三个整数 L,R,C(0<l,r,c≤30)。

L代表迷宫的高度,R和C分别代表每一层的行和列。

接下来是L个R×C的矩阵,矩阵包含4种字符(S,E,.,#),S代表王的初始位置,E代表出口,#代表障碍。.代表能通过的地方。

每一层之后有一个空行。

当L=R=C=0时,输入中断。

Output

如果可以逃离迷宫,按下列格式输出最短时间:

Escaped in x minute(s). (x表示逃离迷宫的最短时间, 走一步花费一昏钟)

否则,输出:

Trapped!

Sample input and output

Sample Input Sample Output
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Escaped in 11 minute(s).
Trapped!

解题报告:

简单bfs,直接跑就完了

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
char g[40][40][40];
bool vis[40][40][40];
int l,r,c;
int dir[6][3] = {-1,0,0,1,0,0,0,-1,0,0,1,0,0,0,-1,0,0,1};
typedef struct status
{
  int x,y,z,step;
  status(const int &x,const int &y,const int &z,const int &step)
   {
         this->x  = x , this->y = y, this->z = z ,this->step = step;
   }
};

queue<status>q;
int tarx,tary,tarz;

bool judge(int x,int y,int z)
{
   if (g[z][x][y] == ‘#‘ || x >= r || x < 0 || y >= c || y < 0 || z >= l || z < 0)
    return false;
   return true;
}

int bfs()
{
   while(!q.empty())
    {
        status ns = q.front();q.pop();
        if (ns.x == tarx && ns.y == tary && ns.z == tarz)
         return ns.step;
        int x = ns.x , y = ns.y , z = ns.z , step = ns.step;
        for(int i = 0 ; i < 6 ; ++ i)
         {
             int newx = x + dir[i][0];
             int newy = y + dir[i][1];
             int newz = z + dir[i][2];
             if(!judge(newx,newy,newz) || vis[newx][newy][newz])
              continue;
             vis[newx][newy][newz] = true;
             q.push(status(newx,newy,newz,step+1));
         }
    }
   return -1;
}

int main(int argc,char *argv[])
{
  while(scanf("%d%d%d",&l,&r,&c)  && l )
   {
         for(int i = 0 ; i < l ; ++ i)
          for(int j = 0 ; j < r ; ++ j)
           scanf("%s",g[i][j]);
         int stx,sty,stz;
         for(int i = 0 ; i < l ; ++ i)
          for(int j = 0 ; j < r ; ++ j)
           for(int k = 0 ; k < c ; ++ k)
            {
                if (g[i][j][k] == ‘S‘)
                 stx = j,sty = k,stz = i;
                if (g[i][j][k] == ‘E‘)
                 tarx = j,tary = k , tarz = i;
         }
      while(!q.empty())
       q.pop();
      memset(vis,false,sizeof(vis));
      vis[stx][sty][stz] = true;
      q.push(status(stx,sty,stz,0));
      int ans = bfs();
      if (ans != -1)
       printf("Escaped in %d minute(s).\n",ans);
      else
       printf("Trapped!\n");
   }
  return 0;
}
时间: 2024-11-10 02:43:58

UESTC_王之迷宫 2015 UESTC Training for Search Algorithm & String<Problem A>的相关文章

UESTC_吴队长征婚 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem E&gt;

E - 吴队长征婚 Time Limit: 10000/4000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status 吴队长征婚这件事因为请客而没有传出去(虽然他忘了请一个队吃饭),于是吴队长高兴地玩起了木棒.吴队长拿了一些长度相同的木(guang)棒(gun),随机的把它们截成了N段,每一段最长50.现在他想把这些木棒还原成原来的状态,但是他忘记了原来的木棒有多少根,也忘记了每一根有多长.请帮助

UESTC_全都是秋实大哥 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem J&gt;

J - 全都是秋实大哥 Time Limit: 5000/2000MS (Java/Others)     Memory Limit: 32000/32000KB (Java/Others) Submit Status 秋实大哥是一个多愁善感的人,偶尔也会唱唱两句伤情的歌.每次唱完后,秋实大哥都能解决一道问题!这次也不例外. 秋实大哥告诉了你 一些关于这个问题的信息 如果一个字符串S是由若干个子串a连续拼接而成的,则称a是S的循环节,即A=a+a+...+a.比如 aba 是 abaabaaba

UESTC_秋实大哥の恋爱物语 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem K&gt;

K - 秋实大哥の恋爱物语 Time Limit: 5000/2000MS (Java/Others)     Memory Limit: 32000/32000KB (Java/Others) Submit Status 传说有这么一个故事! 在一个月白风清的晚上,秋实大哥约一位他心仪的妹子一起逛校园,浪漫的秋实大哥决定在当晚对妹子表白.“XXXXX...”,秋实大哥温情地说完了准备已久的话.而妹子决定用一种浪漫的方式接受秋实大哥(其实妹子早已对秋实大哥动心,这一刻她早已迫不及待了,但还是决定

UESTC_韩爷的梦 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem N&gt;

N - 韩爷的梦 Time Limit: 200/100MS (Java/Others)     Memory Limit: 1300/1300KB (Java/Others) Submit Status 一天,韩爷去百度面试,面试官给了他这么一个问题. 给你2万个字符串,每个字符串长度都是100,然后把2万个字符串丢入一个 set< string >g 中,问最终set里含有多少个元素? g 是一个用来存储字符串.具有去重功能的容器,即相同字符串在 g 中只能保留一个. 两个字符串相等,当且

UESTC_基爷的中位数 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem D&gt;

D - 基爷的中位数 Time Limit: 5000/3000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status 给你N个数,X1,X2,...,XN, 基爷让我们计算任意两个数差的绝对值 ∣Xi−Xj∣ (1≤i<j≤N) . 这样,我们可以得到 C2N 个数. 现在,基爷希望聪明的你能用一个简单的程序求出这 C2N 个数的中位数! Input 输入有多组数据. 每组数据,第一行一个整数 N

UESTC_基爷与加法等式 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem C&gt;

C - 基爷与加法等式 Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status 一天,上小学的妹妹跑过来问基爷一道字母加法等式,基爷不假思索的便给出了一组可行解. 聪明的你发现,一个字母等式可能有多种不同解,于是你想编个程序计算一下 Input 输入包含多组数据. 每组数据第一行一个整数n,表示有n个字符串 3 ≤ n ≤ 10 接下来n行,每行有1个最多只

UESTC_邱老师降临小行星 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem B&gt;

B - 邱老师降临小行星 Time Limit: 10000/5000MS (Java/Others)     Memory Limit: 65536/65535KB (Java/Others) Submit Status 人赢邱老师和任何男生比,都是不虚的.有一天,邱老师带妹子(们)来到了一个N行M列平面的小行星.对于每一个着陆地点,邱老师总喜欢带着妹子这样走:假设着陆地点为(r0, c0),那么他们下一步只能选择相邻格点,向四周走,即(r0–1, c0), (r0 + 1, c0), (r0

UESTC_Palindromic String 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem M&gt;

M - Palindromic String Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 128000/128000KB (Java/Others) Submit Status 秋实大哥喜欢探索新鲜事物,最近他发明了一种新型回文串,叫K重回文串!今天他想用它来考考小朋友们. 秋实大哥给出了与K重回文串有关的信息 任何字符串都属于0重回文串,包括空字符串. 一个长度为N的字符串S,S是K(k≥1)重回文串,当且仅当S是回文串,且其

UESTC_Infected Land 2015 UESTC Training for Search Algorithm &amp; String&lt;Problem G&gt;

G - Infected Land Time Limit: 6000/3000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status The earth is under an attack of a deadly virus. Luckily, prompt actions of the Ministry of Health against this emergency successfully