12-1054. 求平均值

              1054. 求平均值 (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

01:
#include <cstring>
#include <iostream>
#include <cstdio>
using namespace std;

int main(){
	int n;
	string s;
	double sum = 0;
	int count = 0;
	cin >> n;
	for(int k = 0; k < n; k++){
		cin >> s;
		double b = 0, c = 0;   //b记录整数部分,c记录小数部分
		if(s[0] == ‘-‘){       //为负数的情况
			int i = 1;
			while(s[i] >= ‘0‘ && s[i] <= ‘9‘){
				b = b * 10 + s[i] - ‘0‘;
				i++;
			}

			if(s[i] == ‘.‘){
				int j = i + 1;
				double l = 0.1;
				while(s[j] >= ‘0‘ && s[j] <= ‘9‘){
					c += l * (s[j] - ‘0‘);
					j++;
					l *= 0.1;
				}
				if(j - i - 1 > 2 || j + 1 < s.length()){
					cout << "ERROR: " << s << " is not a legal number" << endl;
					continue;
				}
			}
			if(b + c < -1000 || b + c> 1000){
				cout << "ERROR: " << s << " is not a legal number" << endl;
				continue;
			}
			count++;
			sum += -b - c;
		}
		else if(s[0] >= ‘0‘ && s[0] <= ‘9‘){  //非负数
			int i = 0;
			while(s[i] >= ‘0‘ && s[i] <= ‘9‘){
				b = b * 10 + s[i] - ‘0‘;
				i++;
			}

			if(s[i] == ‘.‘){
				int j = i + 1;
				double l = 0.1;
				while(s[j] >= ‘0‘ && s[j] <= ‘9‘){
					c += l * (s[j] - ‘0‘);
					j++;
					l *= 0.1;
				}
				if(j - i - 1 > 2 || j < s.length()){
					cout << "ERROR: " << s << " is not a legal number" << endl;
					continue;
				}
			}
			if(b + c < -1000 || b + c> 1000){
				cout << "ERROR: " << s << " is not a legal number" << endl;
				continue;
			}

			count++;
			sum += b + c;
		}
		else{
			cout << "ERROR: " << s << " is not a legal number" << endl;
		}
	}
	if(count == 0){
		printf("The average of 0 numbers is Undefined");
	}
	else if(count == 1)
		printf("The average of 1 number is %.2lf", sum);
	else
		printf("The average of %d numbers is %.2lf", count, sum / count);
	return 0;
}

02:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

int main(){
	char a[50], b[50];				//尽量大点,不能提前预知非法数据的长短
	int n, count = 0, flag = 0;
	double sum, temp;
	cin >> n;
	for(int i = 0; i < n; i++){
		flag = 0;
		cin >> a;
		sscanf(a, "%lf", &temp);    //a必须是char类型,不能是string
		sprintf(b, "%.2lf", temp);
		for(int j = 0; j < strlen(a); j++){
			if(a[j] != b[j])
				flag = 1;
		}
		if(flag == 1 || temp > 1000 || temp < -1000){
			cout << "ERROR: " << a << " is not a legal number" << endl;
			continue;
		}
		sum += temp;
		count++;
	}
	if(count == 0){
		printf("The average of 0 numbers is Undefined");
	}
	else if(count == 1)
		printf("The average of 1 number is %.2lf", sum);
	else
		printf("The average of %d numbers is %.2lf", count, sum / count);
	return 0;
}
时间: 2024-10-05 20:57:32

12-1054. 求平均值的相关文章

1054. 求平均值 (20)-PAT乙级真题

今天刚刚到学校,2017年学习正式开始了,今天看到了浙大的<数据结构>这学期又要开课了,决定一定要跟着学习一遍:在大学生mooc网上学习:http://www.icourse163.org/course/zju-93001#/info :然后就是跟着<算法之美>也要同步看完. 然后就在PAT上随便做一道题,这是第一次通过AC,发现了两个比较好的博客主页:http://www.liuchuo.net/  和  https://www.joyhwong.com/   都总结了刷题的过程

1054. 求平均值 (20)(转载)

1054. 求平均值 (20) 本题的基本要求非常简单:给定N个实数,计算它们的平均值.但复杂的是有些输入数据可能是非法的.一个"合法"的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位.当你计算平均值的时候,不能把那些非法的数据算在内. 输入格式: 输入第一行给出正整数N(<=100).随后一行给出N个实数,数字间以一个空格分隔. 输出格式: 对每个非法输入,在一行中输出"ERROR: X is not a legal number",

PAT-乙级-1054. 求平均值 (20)

1054. 求平均值 (20) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue 本题的基本要求非常简单:给定N个实数,计算它们的平均值.但复杂的是有些输入数据可能是非法的.一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位.当你计算平均值的时候,不能把那些非法的数据算在内. 输入格式: 输入第一行给出正整数N(<=100).随后一行给出N个正整数,数字间以一个空格分隔. 输出格

PTA乙级 (*1054 求平均值 (20分))

1054 求平均值 (20分) https://pintia.cn/problem-sets/994805260223102976/problems/994805272659214336 #include <cstdio> #include <cstring> #include <string> #include <iostream> #include <cmath> #include <algorithm> #include <

PAT 1054. 求平均值 (20)

本题的基本要求非常简单:给定N个实数,计算它们的平均值.但复杂的是有些输入数据可能是非法的.一个"合法"的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位.当你计算平均值的时候,不能把那些非法的数据算在内. 输入格式: 输入第一行给出正整数N(<=100).随后一行给出N个实数,数字间以一个空格分隔. 输出格式: 对每个非法输入,在一行中输出"ERROR: X is not a legal number",其中X是输入.最后在一行中输出结

1054. 求平均值 (20)

本题的基本要求非常简单:给定N个实数,计算它们的平均值.但复杂的是有些输入数据可能是非法的.一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位.当你计算平均值的时候,不能把那些非法的数据算在内. 输入格式: 输入第一行给出正整数N(<=100).随后一行给出N个实数,数字间以一个空格分隔. 输出格式: 对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入.最后在一行中输出结果:“The average of

PAT 1054 求平均值

https://pintia.cn/problem-sets/994805260223102976/problems/994805272659214336 本题的基本要求非常简单:给定N个实数,计算它们的平均值.但复杂的是有些输入数据可能是非法的.一个"合法"的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位.当你计算平均值的时候,不能把那些非法的数据算在内. 输入格式: 输入第一行给出正整数N(<=100).随后一行给出N个实数,数字间以一个空格分隔. 输

1054 求平均值 (string+.c_str() )

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值.但复杂的是有些输入数据可能是非法的.一个"合法"的输入是 [?] 区间内的实数,并且最多精确到小数点后 2 位.当你计算平均值的时候,不能把那些非法的数据算在内. 输入格式: 输入第一行给出正整数 N(≤).随后一行给出 N 个实数,数字间以一个空格分隔. 输出格式: 对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入.最后在一行中输出结果:The average of

1054 求平均值 (20 分)

sscanf() – 从一个字符串中读进与指定格式相符的数据sprintf() – 字符串格式化命令,主要功能是把格式化的数据写入某个字符串中. 真好 #include<iostream> #include<cstdio> #include<string.h> using namespace std; int main(){ int n,cnt=0; double tmp,sum=0.0; char a[50],b[50]; cin>>n; for(int