一些项目——elevator problem

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

代码

#include<iostream>
using namespace std;
int main()
{
    int N,*a,min;
    while(cin>>N)
    {
        if(N==0)
            return 0;
        a=new int[N];
        min=0;
        for(int i=0; i<N; i++)
        {
            cin>>a[i];
        }
        for(int i=0; i<N; i++)
        {
            if(i==0)
                min=6*a[i]+5;
            else if(a[i]>a[i-1])
                min=min+(a[i]-a[i-1])*6+5;
            else
                min=min+(a[i-1]-a[i])*4+5;
        }
        delete []a;
        a=NULL;
        cout<<min<<endl;
    }
    return 0;
}
时间: 2024-10-08 02:22:03

一些项目——elevator problem的相关文章

MyEclipse加载项目时 出现&quot;building workspace has encountered a problem&quot;错误

当MyEclipse加载项目时 出现"building workspace has encountered a problem"错误,这是重新编译时出错, ① 根据MyEclipse菜单栏的Project->propertise(当有项目运行或是加载时Propertise为灰色,不可用)->Builders->不要选中JavaScript Validator(把前面的勾去掉). ② 或是重新换一个命名空间(workspace). 2.当MyEclipse在运行程序时弹

eclipse 导入项目出现Unbound classpath variable: &#39;TOMCAT_HOME&#39; in project XXX Problem

翻译:未绑定的类路径变量:项目XXX中的“TOMCAT_HOME” 解决: 配置TOMCAT环境变量,新建TOMCAT_HOME环境变量,path为tomcat目录路径. 打开eclipse,选择Window-> Preferences-> Java-> Bulid Path-> Classpath Variables -> New Name:TOMCAT_HOME   Path:tomcat目录路径. eclipse 导入项目出现Unbound classpath vari

初始化vue项目,报错This is probably not a problem with npm,there is likely additional logging output above

https://blog.csdn.net/ink_if/article/details/79015811 参考别人的博客 初始化项目,vue init webpack-simple demo 然后npm install 再然后npm run dev 就报错了,最后找出是版本更新原因, 解决方案: npm install之后,运行 npm i -D [email protected] 原文地址:https://www.cnblogs.com/qianjin888/p/10086950.html

别的项目导入myeclipese出现struts problem report JDBC Exception:can not open connection解决办法

解决办法:数据库里缺少数据库,在对应的数据库里新建所需数据库即可

Maven 项目打包需要注意到的那点事儿

1. 关于 Maven 打 war 包 <使用 Eclipse 的 Maven 2 插件开发一个 JEE 项目>详细介绍了如何在 Eclipse 使用 Maven 新建一个 JEE 项目并对其进行断点跟踪调试,但是没有介绍如何对 JEE 项目打 war 包.其实很简单,你只需要把 pom.xml 中的 <packaging>jar</packaging> 换成 <packaging>war</packaging> 就可以使用 mvn packag

cocos2dx 3.2+ 项目创建与问题总汇

本文为Cocos2d-x 3.x 全平台(Android,iOS)新手开发配置教程攻略,希望对大家有所帮助.由于这篇文章是面对新手的. 所以有些地方会啰嗦一些,请勿见怪. 假设教程中有错误.欢迎指正. 假设在配置开发平台时还遇到问题,欢迎大家讨论. 本文所使用的环境是PC(Win7),HTC G18,MacBook Air 以及 Mini iPad. 一.通用准备工作 1.安装Cocos2d-x 3.1 在Cocos2d官网上下载Cocos2d-x 3.2+引擎,下载后解压缩. 2.安装Ecli

curl: (60) SSL certificate problem: unable to get local issuer certificate 错误

今天同事做微信管理的项目,请求接口返回如下错误SSL certificate problem: unable to get local issuer certificate. 此问题的出现是由于没有配置信任的服务器HTTPS验证.默认,cURL被设为不信任任何CAs,就是说,它不信任任何服务器验证.因此,这就是浏览器无法通过HTTPs访问你服务器的原因. 解决此报错有2种处理方法 1.如果你的内容不敏感,一个快捷的方法是使用curl_exec()之前跳过ssl检查项. curl_setopt($

We have a problem with promises

原文地址:http://fex.baidu.com/blog/2015/07/we-have-a-problem-with-promises/ 用Javascript的小伙伴们,是时候承认了,关于 promises 我们一直存在着问题.并非说 promises 本身有问题,Promises/A+ 是极好的. 就我过去数年观察大量 PouchDB API 以及其他 promise-heavy API 的使用者们与这些 API 的搏斗中我发现,最大的问题是: 大部分使用 promises 的小伙伴们

hdu 1008 elevator

#include<iostream> #include<stdio.h> #include<math.h> #include<algorithm> using namespace std; int main() { int n; while(~scanf("%d",&n)&&n!=0) { int a,b; a=0; int ans=0; for(int i=0;i<n;i++) { scanf("