2016 省热身赛 Find the Spy

Find the Spy

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Whoooa! There is a spy in Marjar University. All we know is that the spy has a special ID card. Please find him out!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains a integer N (3 <= N <= 100), which describes that there are N students need to be checked.

The second line contains N integers indicating the ID card number of N students. All ID card numbers are 32-bit integers.

Output

For each test case, output the ID card number which is different from others.

Sample Input

3
10
1 1 1 1 1 1 1 1 6 1
3
9 9 8
5
90016 90016 90016 2009 90016

Sample Output

6
8
2009水体一枚
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;

const int maxn=105;
int a[maxn];

int main()
{
     int t;
     scanf("%d",&t);
     while(t--)
     {
         memset(a,0,sizeof(a));
         int n;
         scanf("%d",&n);
         int tmp=0;
         scanf("%d",&a[0]);
         tmp=a[0];
         for(int i=1;i<n;i++)
         {
             scanf("%d",&a[i]);
         }
         for(int i=1;i<n;i++)
         {
             if(a[1]!=a[0])
         {
             if(a[2]==a[0])printf("%d\n",a[1]);
             else printf("%d\n",a[0]);
             break;
         }
             if(a[i]!=tmp&&i>1)
             {
                 printf("%d\n",a[i]);break;
             }
         }

     }
return 0;
}

				
时间: 2024-11-08 22:06:03

2016 省热身赛 Find the Spy的相关文章

2016 省热身赛 Cylinder Candy

Cylinder Candy Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Description Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylinder with radius r mm and height h mm

2016 省热身赛做题总结

ACM 总结(第二次) 今天做题目做的不是很理想,一共想了6道题目,A出来两道题目,这也是醉了,,做题目是主要有以下几点要注意: 1.最重要的一点   一定要用scanf, 和printf 因为这个东西,水题A出来是TLE,浪费时间,,, 今天好不容易把第二题做出来,就是因为这个,导致想了好几次算法.. 这个真坑. 以后不管什么样的题目只要做ACM,输入输出都要用c语言的方式,先养成习惯在说..   因为这个很重要,影响心情和时间. 如果你是做ACM的,请注意这一点.... 2.英语是硬伤呀,,

2016 省热身赛 Valid Pattern Lock

Valid Pattern Lock Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Description Pattern lock security is generally used in Android handsets instead of a password. The pattern lock can be set by joining points on a 3 × 3 matr

2016 省热身赛 Earthstone: Easy Version

Earthstone: Easy Version Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Description Earthstone is a famous online card game created by Lizard Entertainment. It is a collectible card game that revolves around turn-based mat

2016 省热身赛 Easy Task

Easy Task Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Description You are given n integers. Your task is very easy. You should find the maximum integer a and the minimum integer b among these nintegers. And then you sho

聊一聊前端模板与渲染那些事儿

欢迎大家收看聊一聊系列,这一套系列文章,可以帮助前端工程师们了解前端的方方面面(不仅仅是代码): https://segmentfault.com/blog/frontenddriver 作为现代应用,ajax的大量使用,使得前端工程师们日常的开发少不了拼装模板,渲染模板.我们今天就来聊聊,拼装与渲染模板的那些事儿. 如果喜欢本文请点击右侧的推荐哦,你的推荐会变为我继续更文的动力 1 页面级的渲染 在刚有web的时候,前端与后端的交互,非常直白,浏览器端发出URL,后端返回一张拼好了的HTML串

使用 Raspberry Pi 上的传感器在 Node.js 中创建一个 IoT Bluemix 应用程序

先决条件 一个IBM Bluemix 帐号,一个 Raspberry Pi 2 或 3,一个 PIR 运动传感器 适用于本文的 Github 存储库 如果您是一位精明的 Bluemix 开发人员,您可能只想看看如何在 node.js 中与 IoT 建立连接,或者只想了解如何从此 github 存储库中拉取我的代码. git clone https://github.com/nicolefinnie/iot-nodejs-tutorial 以下是实现与 IBM IoT 平台连接在一起的 4 个 R

FOJ有奖月赛-2016年4月(校赛热身赛)

A.ABCDEFG 题意:给出一个由abcdefg(大/小)组成的字符串,计算写这些字符串要多少笔. 题解:先打一个前七个大小写字母笔画的表,之后用这个求和即可. 代码: 1 /*A*/ 2 #include<cstdio> 3 #include<cstring> 4 using namespace std; 5 6 int a[7]={1,1,1,2,1,2,1}; 7 int A[7]={3,2,1,2,3,3,1}; 8 9 int main() 10 { 11 int T;

2016年浙江财经大学信工学院程序设计竞赛题解

代码为本人出于爱好 验题时所写,如有错误,敬请指出. 题面$pdf$为本人排版,不到之处,还请海涵.  联系方式$QQ$:$774388357$  浙江财经大学 $14$软件工程 周甄陶 正赛题面:https://pan.baidu.com/s/1jIQASxo 热身赛题面:https://pan.baidu.com/s/1mi4mjMg 热身赛$pdf$密码:IbcS3jJkkOsxiMCYfF6v 弱校现场赛$Rank$:https://pan.baidu.com/s/1kVBFGMV 热身