完全背包[HDU 1114] Piggy-Bank

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12466    Accepted Submission(s): 6312

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it‘s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.

The minimum amount of money in the piggy-bank is 100.

This is impossible.

赤裸裸的完全背包问题、换个说法:

求容量为s的背包能放下的硬币的最小价值,每种硬币无限多,完全背包问题

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define min(a,b) a<b?a:b
#define INF 0x7ffffff
#define N 10010

int n,s;
int dp[N];
int v[N],w[N]; //算了,统一一下,n代表种类,s代表总容量,v代表价值,w代表重量

int main()
{
    int T,i,j;
    scanf("%d",&T);
    while(T--)
    {
        int s1,s2;
        scanf("%d%d%d",&s1,&s2,&n);
        s=s2-s1;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&v[i],&w[i]);
        }
        for(i=1;i<=N;i++)
        {
            dp[i]=INF;
        }
        dp[0]=0;
        for(i=1;i<=n;i++)
        {
            for(j=w[i];j<=s;j++)
            {
                dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
            }
        }
        if(dp[s]!=INF)
            cout<<"The minimum amount of money in the piggy-bank is "<<dp[s]<<‘.‘<<endl;
        else
            cout<<"This is impossible.\n";
    }
    return 0;
}
时间: 2024-11-03 01:24:25

完全背包[HDU 1114] Piggy-Bank的相关文章

HDU 1114 Piggy-Bank(完全背包 DP)

题意  知道空存钱罐的重量和装满钱的存钱罐的重量及每种币值的重量   求存钱罐里至少有多少钱 裸的完全背包  但是是求最小值  所以初始0要变成初始INF  max也要变成min #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int N = 10005, INF = 0x3f3f3f3f; int val[N], wei[N], d[N]; int ma

F - Piggy-Bank HDU 1114 (完全背包的变形+初始化细节)

F - Piggy-Bank Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1114 Description Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for th

HDU 1114 Piggy-Bank(一维背包)

题目地址:HDU 1114 把dp[0]初始化为0,其它的初始化为INF.这样就能保证最后的结果一定是满的,即一定是从0慢慢的加上来的. 代码例如以下: #include <algorithm> #include <iostream> #include <cstring> #include <cstdlib> #include <cstdio> #include <queue> #include <cmath> #incl

hdu 1114 完全背包问题

题意:给定背包体积与物品的体积与价值 求正好放完的最小价值#include<iostream> using namespace std; int min(int a,int b) { if(a<b) return a; return b; } int main() { int t,m1,m2,n,i,j; int v[502],w[502],dp[10005],m; cin>>t; while(t--) { cin>>m1>>m2; m=m2-m1;

[2016-03-27][HDU][1114][Piggy-Bank]

时间:2016-03-27 16:37:56 星期日 题目编号:[2016-03-27][HDU][1114][Piggy-Bank] 遇到的问题:注意f == e的情况,即dp[0] = 0; #include <cstring> #include <cstdio> #include<algorithm> using namespace std; int dp[10000 + 10]; int w[500 + 10],c[500 + 10]; int main(){

hdu 1114 Piggy-Bank

题目: 链接:点击打开链接 题意: 知道存钱罐的质量和装满硬币的存钱罐的质量,然后是不同硬币的价值和质量,求出存钱罐里钱币的最小价值. 算法: 完全背包问题,银币的个数是不限的. 思路: 状态转移方程:j = 0时,价值为0 dp[j] = min(dp[j],dp[j-w[i]]+v[i]);//表示质量为j的钱币,含有的最小的价值 代码: #include<iostream> #include<cstdio> #include<cstring> using name

hdu 1114 Piggy-Bank dp

#include <cstdio> #include <cstring> #include <algorithm> using namespace std; #define inf 10000000 int dp[11000]; int n; int val[550],wei[550]; int main() { int cas,n; scanf("%d",&cas); while(cas--) { int w1,w2,w; int i,j;

初涉分组背包 HDU 1561 The more,The better

给出一个森林,每棵树均为一组物品,首先推出每棵树可以组成的物品种类. 然后是基本的分组背包模板. 即 最外层枚举组数,次外层枚举背包容量,内层枚举物品体积. 对于每棵树有 ans[root][i+j] = ans[root][ i ] + ans[son][ j ]. 题水数据也水,不多说了. #include <iostream> #include <algorithm> #include <cstdlib> #include <cstdio> #incl

C - Piggy-Bank HDU - 1114

C - Piggy-Bank HDU - 1114 Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM memb