PAT 1011

1011. World Cup Betting (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner‘s odd would be the product of the three odds times 65%.

For example, 3 games‘ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

解析:题目很简单,但是sample给的略坑,其实后面的输出应该是37.97,题目有一点误导。

Code:
/*************************************************************************
    > File Name: 1011.cpp
    > Author:
    > Mail:
    > Created Time: 2015年12月12日 星期六 19时30分41秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
using namespace std;

float findmax(float a, float b, float c, char &value){
    if(a > b){
        if(a > c){
            value = ‘W‘;
            return a;
        }
        else{
            value = ‘L‘;
            return c;
        }
    }
    else{
        if(b > c){
            value = ‘T‘;
            return b;
        }
        else{
            value = ‘L‘;
            return c;
        }
    }
}

int main(){

    float w1,t1,l1;
    float w2,t2,l2;
    float w3,t3,l3;
    cin>>w1>>t1>>l1;
    cin>>w2>>t2>>l2;
    cin>>w3>>t3>>l3;

    char choice1,choice2,choice3;
    float a = findmax(w1,t1,l1,choice1);
    float b = findmax(w2,t2,l2,choice2);
    float c = findmax(w3,t3,l3,choice3);

    float result = (a*b*c*0.65-1.0)*2;
    //printf("%f*%f*%f*0.65-1.0 * 2=%f\n",a,b,c,result);
    printf("%c %c %c %.2f",choice1,choice2,choice3,result);
    return 0;
}
 
时间: 2024-10-30 16:15:31

PAT 1011的相关文章

PAT 1011. A+B和C (15)

给定区间[-231, 231]内的3个整数A.B和C,请判断A+B是否大于C. 输入格式: 输入第1行给出正整数T(<=10),是测试用例的个数.随后给出T组测试用例,每组占一行,顺序给出A.B和C.整数间以空格分隔. 输出格式: 对每组测试用例,在一行中输出"Case #X: true"如果A+B>C,否则输出"Case #X: false",其中X是测试用例的编号(从1开始). 输入样例: 4 1 2 3 2 3 4 2147483647 0 214

PAT——1011. A+B和C

给定区间[-231, 231]内的3个整数A.B和C,请判断A+B是否大于C. 输入格式: 输入第1行给出正整数T(<=10),是测试用例的个数.随后给出T组测试用例,每组占一行,顺序给出A.B和C.整数间以空格分隔. 输出格式: 对每组测试用例,在一行中输出"Case #X: true"如果A+B>C,否则输出"Case #X: false",其中X是测试用例的编号(从1开始). 输入样例: 4 1 2 3 2 3 4 2147483647 0 214

PAT 1011 World Cup Betting 查找元素

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their

PAT 乙级真题 1011.个位数统计

PAT 乙级真题 1011.个位数统计 题目描述 给定一个k位整数N = dk-110k-1 + ... + d1101 + d0 (0<=di<=9, i=0,...,k-1, dk-1>0),请编写程序统计每种不同的个位数字出现的次数.例如:给定N = 100311,则有2个0,3个1,和1个3. 输入格式 每个输入包含1个测试用例,即一个不超过1000位的正整数N. 输出格式 对N中每一种不同的个位数字,以D:M的格式在一行中输出该位数字D及其在N中出现的次数M.要求按D的升序输出

PAT乙级 1011. A+B和C (15)

1011. A+B和C (15) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 HOU, Qiming 给定区间[-231, 231]内的3个整数A.B和C,请判断A+B是否大于C. 输入格式: 输入第1行给出正整数T(<=10),是测试用例的个数.随后给出T组测试用例,每组占一行,顺序给出A.B和C.整数间以空格分隔. 输出格式: 对每组测试用例,在一行中输出“Case #X: true”如果A+B>C,否则输出“Case

1011. World Cup Betting (20)——PAT (Advanced Level) Practise

题目信息: 1011. World Cup Betting (20) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing

PAT Basic Level 1011

1 #include <stdio.h> 2 int main () 3 { 4 int amount; 5 scanf("%d",&amount); 6 int cnt = 1; 7 8 while (amount > 0) 9 { 10 long a; 11 long b; 12 long c; 13 scanf("%ld %ld %ld",&a,&b,&c); //此题仔细搞懂INT DOUBLE LONG L

PAT:1011. A+B和C (15) AC

#include<stdio.h> int main() { int n; long long a,b,c; scanf("%d",&n); for(int turn=1 ; turn<=n ; ++turn) { scanf("%lld%lld%lld",&a,&b,&c); if(a+b>c) printf("Case #%d: true\n",turn); else printf(&q

PAT (Advanced Level) 1011. World Cup Betting (20)

简单题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> using namespace std; double a[5][5],Max[5]; double ans=1; int main() { for(int i=1;i<=3;i++) for(int j=1;j<=3;j++) scanf(&qu