HDU--3081--Marriage Match II--最大匹配,匈牙利算法

Marriage Match II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1608    Accepted Submission(s): 566

Problem Description

Presumably, you all have known the question of stable marriage match. A girl will choose a boy; it is similar as the game of playing house we used to play when we are kids. What a happy time as so many friends playing together. And
it is normal that a fight or a quarrel breaks out, but we will still play together after that, because we are kids.

Now, there are 2n kids, n boys numbered from 1 to n, and n girls numbered from 1 to n. you know, ladies first. So, every girl can choose a boy first, with whom she has not quarreled, to make up a family. Besides, the girl X can also choose boy Z to be her boyfriend
when her friend, girl Y has not quarreled with him. Furthermore, the friendship is mutual, which means a and c are friends provided that a and b are friends and b and c are friend.

Once every girl finds their boyfriends they will start a new round of this game—marriage match. At the end of each round, every girl will start to find a new boyfriend, who she has not chosen before. So the game goes on and on.

Now, here is the question for you, how many rounds can these 2n kids totally play this game?

Input

There are several test cases. First is a integer T, means the number of test cases.

Each test case starts with three integer n, m and f in a line (3<=n<=100,0<m<n*n,0<=f<n). n means there are 2*n children, n girls(number from 1 to n) and n boys(number from 1 to n).

Then m lines follow. Each line contains two numbers a and b, means girl a and boy b had never quarreled with each other.

Then f lines follow. Each line contains two numbers c and d, means girl c and girl d are good friends.

Output

For each case, output a number in one line. The maximal number of Marriage Match the children can play.

Sample Input

1
4 5 2
1 1
2 3
3 2
4 2
4 4
1 4
2 3

Sample Output

2

题意:n个女生和n个男生,女生和男生没吵过架就能在一起。。

女生和女生之间仅仅要是好朋友,那么没吵过架的男生就都能在一起,女所有选择好了要在一起的男生就算一次匹配,然后再来。可是女生不能选先前选择过的男生,问最多能玩出几次这种匹配

题解:用匈牙利算法匹配,然后把匹配到的女生和男生的关系变为吵架(这样下次她就不会选择到他了)

注意:女生A和B是朋友。B和C是朋友。那么和A、B、C没吵过架的人都能被A、B、C选择

#include <iostream>
#include <cstring>
using namespace std;
int n,map[111][111],vis[111],d[111],v[111],fa[111];
int Find(int x)	//并查集——查找祖先
{
    return fa[x]==x?x:fa[x]=Find(fa[x]);
}
void Union(int x,int y)	//并查集——合并两点
{
    x=Find(x);
    y=Find(y);
    if(x!=y)fa[x]=y;
}
int find(int x)	//匈牙利算法
{
    int i;
    for(i=1;i<=n;i++)
    if(map[x][i])
    {
        if(!vis[i])
        {
            vis[i]=1;
            if(d[i]==-1||find(d[i]))
            {
                d[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main (void)
{
    int t,m,f,i,j,k,l,s;
    cin>>t;
    while(t--&&cin>>n>>m>>f)
    {
        memset(map,0,sizeof(map));
        for(i=1;i<=n;i++)
        fa[i]=i;
        for(i=0;i<m;i++)
        {
            cin>>j>>k;
            map[j][k]=1;
        }
        for(i=0;i<f;i++)
        {
            cin>>k>>l;
            Union(k,l);	//先用并查集把女生中是好朋友的弄到一堆
        }
        for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        if(Find(i)==Find(j)	//假设i和j是好朋友
        for(k=1;k<=n;k++)
        if(map[i][k]||map[j][k])	//假设k没和i吵过架或者没和j吵过架
        map[i][k]=map[j][k]=1;	//那么k能被i与j选择
        s=0;
        while(1)
        {
            memset(d,-1,sizeof(d));
            for(i=1,k=0;i<=n;i++)
            {
                memset(vis,0,sizeof(vis));
                k+=find(i);	//匈牙利算法记录匹配数
            }
            if(k==n)s++;	//所有都匹配了就记录为一次
            else break;	//不然就结束
            for(i=1;i<=n;i++)	//然后把匹配男女的关系处理为吵架
            map[d[i]][i]=0;
        }
        cout<<s<<endl;
    }
    return 0;
}

版权声明:本文博主原创文章,博客,未经同意不得转载。

时间: 2024-10-11 07:35:13

HDU--3081--Marriage Match II--最大匹配,匈牙利算法的相关文章

HDU 3081 Marriage Match II(二分法+最大流量)

HDU 3081 Marriage Match II pid=3081" target="_blank" style="">题目链接 题意:n个女孩n个男孩,每一个女孩能够和一些男孩配对.然后有些女孩是朋友.满足这个朋友圈里面的人,假设有一个能和某个男孩配对,其它就都能够,然后每轮要求每一个女孩匹配到一个男孩.且每轮匹配到的都不同,问最多能匹配几轮 思路:二分轮数k,然后建图为,源点连向女孩,男孩连向汇点容量都为k,然后女孩和男孩之间连边为.有关系的

HDU 3081 Marriage Match II(二分+最大流)

HDU 3081 Marriage Match II 题目链接 题意:n个女孩n个男孩,每个女孩可以和一些男孩配对,然后有些女孩是朋友,满足这个朋友圈里面的人,如果有一个能和某个男孩配对,其他就都可以,然后每轮要求每个女孩匹配到一个男孩,且每轮匹配到的都不同,问最多能匹配几轮 思路:二分轮数k,然后建图为,源点连向女孩,男孩连向汇点容量都为k,然后女孩和男孩之间连边为,有关系的连边容量1,这样一个匹配对应一条边,且不会重复,每次判断最大流是否等于n * k即可 代码: #include <cst

hdu 3081 Marriage Match II (二分+最大流+并查集)

hdu 3081 Marriage Match II Description Presumably, you all have known the question of stable marriage match. A girl will choose a boy; it is similar as the game of playing house we used to play when we are kids. What a happy time as so many friends p

hdu 3081 Marriage Match II(最大流 + 二分 + 并查集)

Marriage Match II                                                                           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Problem Description Presumably, you all have known the question of stable

HDU 3081 Marriage Match II 二分+最大流

题目来源:HDU 3081 Marriage Match II 题意: 思路: 错误代码 纠结不知道哪错了 先放一放 #include <cstdio> #include <queue> #include <vector> #include <cstring> #include <algorithm> using namespace std; const int maxn = 1010; const int INF = 999999999; st

HDU 3081 Marriage Match II 二分图最大匹配

Marriage Match II Problem Description Presumably, you all have known the question of stable marriage match. A girl will choose a boy; it is similar as the game of playing house we used to play when we are kids. What a happy time as so many friends pl

HDU 3081 Marriage Match II

Marriage Match II Time Limit: 1000ms Memory Limit: 32768KB This problem will be judged on HDU. Original ID: 308164-bit integer IO format: %I64d      Java class name: Main Presumably, you all have known the question of stable marriage match. A girl wi

HDU 3081 Marriage Match II 二分 + 网络流

Marriage Match II 题意:有n个男生,n个女生,现在有 f 条男生女生是朋友的关系, 现在有 m 条女生女生是朋友的关系, 朋友的朋友是朋友,现在进行 k 轮游戏,每轮游戏都要男生和女生配对,每轮配对过的人在接下来中都不能配对,求这个k最大是多少. 题解:二分 + 网络流check . 代码: 1 #include<bits/stdc++.h> 2 using namespace std; 3 #define Fopen freopen("_in.txt",

HDU 3081 Marriage Match II【并查集+二分图最大匹配】

大意:有n个男孩n个女孩,告诉你每个女孩喜欢哪些男孩,又告诉你女孩之间的存在一些朋友关系 一个女孩可以和她喜欢的男孩结婚也可以和她朋友喜欢的男孩结婚, 并且朋友关系可以传递 Once every girl finds their boyfriends they will start a new round of this game―marriage match. At the end of each round, every girl will start to find a new boyfr

HDU 3081 Marriage Match II(网络流+并查集+二分答案)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3081 题目: Problem Description Presumably, you all have known the question of stable marriage match. A girl will choose a boy; it is similar as the game of playing house we used to play when we are kids. W