2^x mod n = 1
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11658 Accepted Submission(s): 3634
Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
Input
One positive integer on each line, the value of n.
Output
If the minimum x exists, print a line with 2^x mod n = 1.
Print 2^? mod n = 1 otherwise.
You should replace x and n with specific numbers.
Sample Input
2 5
Sample Output
2^? mod 2 = 1 2^4 mod 5 = 1
Author
MA, Xiao
Source
思路就是:欧拉定理
就是a和m互质,且a<m,设x为欧拉函数的值,则a^x%m=1恒成立。由于题上的说明是a为二
则只要m是奇数,且m不等于1即可
则有一下代码:
#include<stdio.h>
int main()
{
int n;
while(~scanf("%d",&n))
{
if(n%2&&n>1)
{
int i,s=1;
for(i=1;;i++)//因为判断了奇数一定有解 所以可以用这样的暴力 因为一定能跳出
{
s=s*2%n;
if(s==1)
{
printf("2^%d mod %d = 1\n",i,n);
break;
}
}
}
else
printf("2^? mod %d = 1\n",n);
}
}
杭电 1395