HDU 5137 How Many Maos Does the Guanxi Worth 最短路 dijkstra

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 303    Accepted Submission(s): 93

Problem Description

"Guanxi" is a very important word in Chinese. It kind of means
"relationship" or "contact". Guanxi can be based on friendship, but also
can be built on money. So Chinese often say "I don‘t have one mao (0.1
RMB) guanxi with you." or "The guanxi between them is naked money
guanxi." It is said that the Chinese society is a guanxi society, so you
can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the
middle school entrance examinations in order to relief studying burden
of primary school students. Because there is no clear and strict
standard of entrance, someone may make their children enter good middle
schools through guanxis. Boss Liu wants to send his kid to a middle
school by guanxi this year. So he find out his guanxi net. Boss Liu‘s
guanxi net consists of N people including Boss Liu and the schoolmaster.
In this net, two persons who has a guanxi between them can help each
other. Because Boss Liu is a big money(In Chinese English, A "big money"
means one who has a lot of money) and has little friends, his guanxi
net is a naked money guanxi net -- it means that if there is a guanxi
between A and B and A helps B, A must get paid. Through his guanxi net,
Boss Liu may ask A to help him, then A may ask B for help, and then B
may ask C for help ...... If the request finally reaches the
schoolmaster, Boss Liu‘s kid will be accepted by the middle school. Of
course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu‘s plan. All you
can do is to persuade ONE person in Boss Liu‘s guanxi net to reject any
request. This person can be any one, but can‘t be Boss Liu or the
schoolmaster. If you can‘t make Boss Liu fail, you want Boss Liu to
spend as much money as possible. You should figure out that after you
have done your best, how much at least must Boss Liu spend to get what
he wants. Please note that if you do nothing, Boss Liu will definitely
succeed.

Input

There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N
people in Boss Liu‘s guanxi net. They are numbered from 1 to N. Boss
Liu is No. 1 and the schoolmaster is No. N. M means that there are M
guanxis in Boss Liu‘s guanxi net. (3 <=N <= 30, 3 <= M <=
1000)

Then M lines follow. Each line contains three integers
A, B and C, meaning that there is a guanxi between A and B, and if A
asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It‘s guaranteed that Boss Liu‘s request can reach the schoolmaster if you do not try to undermine his plan.

Output

For each test case, output the minimum money Boss Liu has to spend
after you have done your best. If Boss Liu will fail to send his kid to
the middle school, print "Inf" instead.

Sample Input

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0

Sample Output

50
Inf

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int  inf = 0x3f3f3f3f;
int dis[250],map[250][250];
int vis[250];
int n,m;
int dij(int x,int y)
{
    for(int i=1; i<=n; i++)
        dis[i]=map[x][i];
    memset(vis,0,sizeof(vis));
    vis[x]=1;
    dis[x]=0;   //注意这个、开始没注意到、
    int k=x;
    for(int i=1; i<n; i++)
    {
        int mmax=inf;
        for(int j=1; j<=n; j++)   //每个的最短
        {
            if(!vis[j]&&dis[j]<mmax)
            {
                mmax=dis[j];
                k=j;
            }
        }
        vis[k]=1;
        for(int j=1; j<=n; j++)   //更新
        {
            if(!vis[j]&&dis[j]>dis[k]+map[k][j])
                dis[j]=dis[k]+map[k][j];
        }
    }
    return dis[y];
}
int css[200];
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0 && m==0)
            break;
        int a,b,v,d,f,num;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                map[i][j]=map[j][i]=inf;
        for(int i=0; i<m; i++)
        {
            cin>>a>>b>>v;
            if(map[a][b]>v)
                map[a][b]=map[b][a]=v;
        }
        int ans = 0;
        for(int i=2;i<n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                css[j] = map[i][j];
                map[i][j] = map[j][i] = inf;
            }
            ans = max(ans,dij(1,n));
            for(int j=1;j<=n;j++)
            {
                map[i][j] = map[j][i] = css[j];
            }
        }
        if(ans==inf)
            puts("Inf");
        else
            printf("%d\n",ans);
    }
    return 0;
}
时间: 2024-10-11 03:39:27

HDU 5137 How Many Maos Does the Guanxi Worth 最短路 dijkstra的相关文章

HDU 5137 How Many Maos Does the Guanxi Worth (14广州 Floyd 最短路)

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 468    Accepted Submission(s): 164 Problem Description "Guanxi" is a very important word in Chinese. I

hdu 5137 How Many Maos Does the Guanxi Worth(dijkstra &amp;&amp; floyd)

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 853    Accepted Submission(s): 326 Problem Description "Guanxi" is a very important word in Chinese. I

HDU 5137 How Many Maos Does the Guanxi Worth(暴力+spfa)

题目大意:给你一个关系图,让你再删除一个点之后(除了1,和n).让你求出来从1到n的最短路的最大值,如果不可达输出Inf. 解题思路:题意也说了,就是暴力枚举点,然后跑n-2次spfa求出来一个最大值就可以了. How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 4

[ACM] HDU 5137 How Many Maos Does the Guanxi Worth(去掉一个点使得最短路最大化)

How Many Maos Does the Guanxi Worth Problem Description "Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese

HDU 5137 How Many Maos Does the Guanxi Worth(最短路径)

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 403    Accepted Submission(s): 125 Problem Description "Guanxi" is a very important word in Chinese. I

HDU 5137 How Many Maos Does the Guanxi Worth(floyd记录路径)

题意:给定N个点和M条边,点编号是1到N.现在要从2到N-1中选择一个删除,同时跟选择的点连接的边也就消失,然后使得点1到N的最短路径的长度最大.如果点1和点N不连通,则输出"Inf". 思路:直接暴力,枚举删去的点即可.我做了一步优化,只删原图最短路上的点, 所以用floyd的时候记录路径即可 //Accepted 1164 KB 0 ms #include<cstdio> #include<iostream> #include<cstring>

hdoj 5137 How Many Maos Does the Guanxi Worth【最短路】

题目:hdoj 5137 How Many Maos Does the Guanxi Worth 题意:给出一个无向图n个点m条边,断开其中的除了1和n之外的其中一个点的所有边,让最短路最长. 分析:思路已经题意中给出了.枚举删去那些的所有变,然后求一个最大的最短路.就是写代码的事儿 AC代码: #include<iostream> #include<stdio.h> #include<string.h> using namespace std; const int i

hdoj 5137 How Many Maos Does the Guanxi Worth 【枚举删点 + 最短路】

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 847    Accepted Submission(s): 322 Problem Description "Guanxi" is a very important word in Chinese. I

HDOJ 5137 How Many Maos Does the Guanxi Worth 枚举+Dijkstra

枚举点暴力Dijkstra.... How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 96    Accepted Submission(s): 34 Problem Description "Guanxi" is a very important wo