HDU1213 How Many Tables 【并查集】

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13360    Accepted Submission(s): 6539

Problem Description

Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

用并查集判断有多少棵树。

#include <stdio.h>
#include <string.h>
#define maxn 1002

int pre[maxn];

int unionFind(int a)
{
	int b = a;
	while(pre[a] != -1) a = pre[a];
	int k;
	while(b != a){
		k = pre[b];
		pre[b] = a;
		b = k;
	}
	return a;
}

int main()
{
	int n, m, t, a, b, ans;
	scanf("%d", &t);
	while(t--){
		scanf("%d%d", &n, &m);
		memset(pre, -1, sizeof(pre));
		ans = n;
		while(m--){
			scanf("%d%d", &a, &b);
			a = unionFind(a);
			b = unionFind(b);
			if(a != b){
				--ans; pre[a] = b;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

HDU1213 How Many Tables 【并查集】

时间: 2024-08-28 20:38:50

HDU1213 How Many Tables 【并查集】的相关文章

hdu1213 How Many Tables(并查集)

How Many Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17946    Accepted Submission(s): 8822 Problem Description Today is Ignatius' birthday. He invites a lot of friends. Now it's dinn

HDU1213最简单的并查集问题

题目地址 http://acm.hdu.edu.cn/showproblem.php?pid=1213 1 #include<iostream> 2 using namespace std; 3 #define MAX 100005 4 int fa[MAX]; 5 6 int findHead(int x) 7 { 8 while(x!=fa[x]) 9 x=fa[x]; 10 return x; 11 } 12 13 void Union(int x,int y) 14 { 15 int

HDU 1213 How Many Tables (并查集)

How Many Tables Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1213 Appoint description:  System Crawler  (2015-05-25) Description Today is Ignatius' birthday. He invites a lot of friends. Now

HDU 1213 How Many Tables (并查集,常规)

并查集基本知识看:http://blog.csdn.net/dellaserss/article/details/7724401 题意:假设一张桌子可坐无限多人,小明准备邀请一些朋友来,所有有关系的朋友都可以坐同一张桌,没有关系的则要另开一桌,问需要多少张桌子(小明不坐,不考虑小明与其他人的关系)? 思路:常规的并查集.要求出所有人的老大,有几个老大就要几张桌子.那么有关系的都归为同一个老大.用数组实现,再顺便压缩路径. 1 #include <bits/stdc++.h> 2 #define

HDU 1213 How Many Tables (并查集,连通分支数,两种方式)

How Many Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23012    Accepted Submission(s): 11485 Problem Description Today is Ignatius' birthday. He invites a lot of friends. Now it's din

How Many Tables——并查集模板题

题目链接 题意: n个人参加晚宴;完全不认识的两个人不能被分配在同一餐桌;认识具有传递性:A认识B B认识C,那么A和C也认识. 题解: 将认识两个人合并到同一集合:最后统计有多少个不同的集合即可; 代码: #include<iostream> #include<stdio.h> #include<math.h> using namespace std; typedef long long ll; const int maxn=5e5+5; int f[maxn]; i

HDU1232 畅通工程 并查集

这道题跟HDU 1213 How Many Tables 并查集非常接近,都是赤裸裸的并查集的题. 思路:假设还需要建n-1条路,每并一次就自减1. 参考代码: #include<stdio.h> int fa[1000]; int find(int u) { return fa[u]==u?u:fa[u]=find(fa[u]); } int main() { int i,n,m,u,v,x,y; scanf("%d%d",&n,&m); while (n

HDU1213 How Many Tables 【标准并查集】

How Many Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15359    Accepted Submission(s): 7525 Problem Description Today is Ignatius' birthday. He invites a lot of friends. Now it's dinn

HDU1213:How Many Tables(并查集)

How Many Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 46694    Accepted Submission(s): 23319 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213 Description: Today is Ignatius' birthda