POJ3684 Physics Experiment 【物理】

Physics Experiment

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1031   Accepted: 365   Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters
above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it
will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.

1≤ N ≤ 100.

1≤ H ≤ 10000

1≤ R ≤ 100

1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20

Source

POJ Founder Monthly Contest – 2008.08.31, Simon

/*
** Problem: POJ3684
** Status: Accepted
** Running Time: 0ms
** Author: Changmu
**
** 题意:算是我的第一道物理题吧,题意是N个球叠放在一起,每隔一秒最下边的球
** 就掉落下来,给定最下面球的底的高度,求T秒后每个球的底的离地高度,g=10m/s^2.
**
** 题解:由于碰撞时两个球的速度交换了,实际上可以看做两个球互相穿越了彼此,但
** 又由于球的顺序不会变,所以求得的结果排序后就是答案。
*/

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>

#define maxn 105
const double g = 10.0;

int N, H, R, T;
double Y[maxn];

double cal(int k) {
    if(k < 0) return H;
    double t = (double)sqrt(2.0 * H / g);
    int m = (int)(k / t);
    if(m & 1) {
        double t1 = (m + 1) * t - k;
        return H - g * t1 * t1 / 2;
    } else {
        double t1 = k - m * t;
        return H - g * t1 * t1 / 2;
    }
}

int main() {
    int t, i;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d%d%d", &N, &H, &R, &T);
        for(i = 0; i < N; ++i)
            Y[i] = cal(T - i);
        std::sort(Y, Y + N);
        for(i = 0; i < N; ++i)
            printf("%.2lf%c", Y[i] + 2.0*R*i/100.0, i==N-1?'\n':' ');
    }
    return 0;
}
时间: 2024-08-05 12:33:56

POJ3684 Physics Experiment 【物理】的相关文章

poj 3684 Physics Experiment 弹性碰撞

Physics Experiment Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 1489   Accepted: 509   Special Judge Description Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment,

HDU 5826 physics(物理)

HDU 5826 physics(物理) Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)   Description 题目描述 There are n balls on a smooth horizontal straight track. The track can be considered to be a number line. The balls can be con

Physics Experiment poj 3684 弹性碰撞

Language: Default Physics Experiment Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 1107   Accepted: 380   Special Judge Description Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Befor

Physics Experiment(POJ 3684)

原题如下: Physics Experiment Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 3583   Accepted: 1275   Special Judge Description Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the exper

Greedy:Physics Experiment(弹性碰撞模型)(POJ 3848)

物理实验 题目大意:有一个与地面垂直的管子,管口与地面相距H,管子里面有很多弹性球,从t=0时,第一个球从管口求开始下落,然后每1s就会又有球从球当前位置开始下落,球碰到地面原速返回,球与球之间相碰会发生完全弹性碰撞(各自方向改变,速率变为相碰时另一个球的速率)问最后所有球的位置? 这一题又是一道弹性碰撞模型的题目,和Liner World有点像,但是这一题不要求输出球的名字,而是要你求得各个球的高度 这道题我们只用明白一个道理就很方便了: 首先我们来看一个球的情况: 一个球从H的高度下落,碰到

POJ 3684 Physics Experiment

和蚂蚁问题类似. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<queue> #include<algorithm> using namespace std; int c,n; double h,r,t,T; double ans[105]; double cal(double time) { if(time<=0) re

北大ACM3684——Physics Experiment

这题,题目的意思是,有N个球从高度为H的地方落下,每一秒落下一个球,球与球之间和球与地板直接都是弹性碰撞,求T秒后的每个球的位置,也就是高度. 这题,跟Ants那题类似,也就是球与球碰撞可以当作不转换方向,继续按照原来的方向.也就是R = 0的时候,忽略半径,算出每一个球的位置,每一个球与地板碰撞后,会上升到原来的高度.先算出一次掉落需要t = sqrt(2 * H / g):每个球总共的时间T,总共的完整的来回有k = T / t次. k为奇数,最终高度为H - g * (k * t + t

关于cocos2d-X 3.x版本使用引擎自带的物理引擎Physics

今天本来打算使用BOX2D物理引擎的, 想到前段时间听说cocos2d-X在3.0版本中封装了一个自己的物理引擎Physics, 听名字就很霸气额, 用起来确实是比BOX2D简单很多( 毕竟是基于BOX2D封装的嘛), 好了, 现在我们来看看如何使用Physics这个物理引擎, 第一步: 创建项目............略 第二部: 修改场景的创建方式 将Scene::create();换成Scene::createWithPhysics(); Scene* HelloWorld::create

POJ3684-Physics Experiment 弹性碰撞

Physics Experiment Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 3576   Accepted: 1270   Special Judge Description Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment,