poj 1426 Find The Multiple (bfs 搜索)

Find The Multiple

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18012   Accepted: 7297   Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

Dhaka 2002

開始做这道题的时候半天没有读懂题意,例子数据是吓人的,把一个单词理解错误,multiple在这里是倍数的意思。这个题目就是要求我们求出给定的一个数的一个由0,1组成的倍数,100位也是吓人的。開始看那个例子,全然不好理解啊。看了半天没有理解题意,也想不到要用bfs来做。看了别人的一点提示就清晰啦。就用一个队列来模拟运算的过程,假设能够整除就直接输出,不能整除把他*10,和*10+1入队;

由于都是0,1组成的倍数,所以组成直接*10。或者是*10+1;

以下是用stl写的,第一次用stl写。有点水,用stl在poj上c++过不了,g++才过的;

#include <iostream>
#include <queue>
#include <cstdio>
using namespace std;
void bfs(int n)
{
   queue<__int64>q;//这里后面的数据可能会有大的,所以用个64位的就够了
   q.push(1);
   while(!q.empty())
   {
       __int64 x;
       x=q.front();
       q.pop();
       if(x%n==0)//能够整除就直接输出
       {
           printf("%I64d\n",x);
           return ;
       }
       q.push(x*10);//把x的10的倍数入队。
       q.push(x*10+1);
   }
}
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        bfs(n);
    }
    return 0;
}

自己用数组模拟队列写了一下;貌似效率比stl好了一些;

主要的思想都是一样的;

#include <cstdio>
#include <cstring>
long long q[2000000];
void bfs(int n)
{
    int front=0;
    int rear=0;
    q[front]=1;
    rear++;
    long long temp;
    while(rear>front)
    {
        temp=q[front];
        if(temp%n==0)
        {
            break;
        }
        temp*=10;
        q[rear]=temp;
        rear++;
        q[rear]=temp+1;
        rear++;
        front++;
    }
    printf("%lld\n",temp);
}
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        bfs(n);
    }
    return 0;
}

在网上还看到了大神的代码用了同余取模定理,还是有点没看懂。还有的直接用满二叉树模拟的队列。

http://blog.csdn.net/lyy289065406/article/details/6647917 (用的同余取模定理)

(a*b)%n = (a%n *b%n)%n

(a+b)%n = (a%n +b%n)%n

看到其它大神对这道的思路:

再贴一段pl大牛关于此题的分析思路。以学习:

要m整除n,那么能够用对n的余数来表示当前的状态。

搜到一个余数为0的状态就能够了。

直接bfs出去。

假设当前的余数是r。添在当前答案后面的数为,k

那么新的余数。也就是新的状态为:

( r * 10 + k ) % n 。

这样最多200个状态,判重一下。能够非常快出解。

大牛的代码:

#include<iostream>
using namespace std;
int a[524300],i,n;
int main(){
while(cin>>n){
   if (!n) break;
   i=1; a[1]=1%n;
   while(a[i]){i++; a[i]=(a[i/2]*10+i%2)%n;}
   n=0; while(i){a[n++]=i%2;i>>=1;}
   while(n--) cout<<a[n]; cout<<endl;
}
return 0;
}

这原来也是bfs,直接用一个满二叉树实现(左儿子是0,右儿子是1);

还是要多学习大神们的代码~

时间: 2024-12-22 02:46:29

poj 1426 Find The Multiple (bfs 搜索)的相关文章

poj 1426 Find The Multiple ( BFS+同余模定理)

Find The Multiple Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 18390   Accepted: 7445   Special Judge Description Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains

POJ 1426 Find The Multiple (BFS基础)

题目大意: 就是说,给你一个数字n,求出任意一个比这个n大的数字,并且这个数字是n的倍数,且只能由0和1组成. 解题思路: 刚开始考虑了大数问题,但是仔细想了下,是多虑的,因为就题目的样例来看,给你的这几个答案都很长...实际有比这个答案更小的数字. 双入口的BFS,只要一次向队列中进入两个元素就好了,q.push(x*10), q.push(x*10+1); 代码: 1 # include<cstdio> 2 # include<iostream> 3 # include<

[题解] [BFS] POJ 1426 - Find The Multiple

p { margin-bottom: 0.25cm; line-height: 115% } a:link { } VJudge题目:https://cn.vjudge.net/contest/279018#problem/L 即POJ 1426 - Find The Multiple:http://poj.org/problem?id=1426 题目要求: 给出一个不大于200的整数n,要求找到任意一个n的倍数(十进制),并且这个倍数只由1与0组成,最多100位. 输入输出:输入以0结束. 示

DFS/BFS(同余模) POJ 1426 Find The Multiple

题目传送门 1 /* 2 题意:找出一个0和1组成的数字能整除n 3 DFS:200的范围内不会爆long long,DFS水过~ 4 */ 5 /************************************************ 6 Author :Running_Time 7 Created Time :2015-8-2 14:21:51 8 File Name :POJ_1426.cpp 9 ******************************************

POJ 1426 Find The Multiple(寻找倍数)

p.MsoNormal { margin-bottom: 10.0000pt; font-family: Tahoma; font-size: 11.0000pt } h1 { margin-top: 5.0000pt; margin-bottom: 5.0000pt; text-align: left; font-family: 宋体; font-weight: bold; font-size: 24.0000pt } span.10 { font-family: "Times New Rom

广搜+打表 POJ 1426 Find The Multiple

POJ 1426   Find The Multiple Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 25734   Accepted: 10613   Special Judge Description Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representati

poj 1465 &amp; zoj 1136 Multiple (BFS+余数重判)

Multiple Time Limit: 1000MS   Memory Limit: 32768K Total Submissions: 6177   Accepted: 1346 Description a program that, given a natural number N between 0 and 4999 (inclusively), and M distinct decimal digits X1,X2..XM (at least one), finds the small

poj 1915 Knight Moves (bfs搜索)

Knight Moves Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 21919   Accepted: 10223 Description Background Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast

20200202 POJ - 3126 Prime Path POJ - 1426 Find The Multiple

>>>>>>>>>POJ 1426直达?? >>>>>>>>>POJ 3126直达?? 做了这么几道搜索题,感觉差不多也摸出了门路,模板差不多记下来了,只是面对不同的题目算法不同罢了 简单写一下想法,搞明白搜索的主题到底是什么(之前的mutiple那题,一开始就没想明白到底搜谁,就没想到算法 TBC(晚上再写 ===================================分割线=======