HDU 1575

Tr A

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4604    Accepted Submission(s): 3461

Problem Description

A为一个方阵,则Tr A表示A的迹(就是主对角线上各项的和),现要求Tr(A^k)%9973。

Input

数据的第一行是一个T,表示有T组数据。
每组数据的第一行有n(2 <= n <= 10)和k(2 <= k < 10^9)两个数据。接下来有n行,每行有n个数据,每个数据的范围是[0,9],表示方阵A的内容。

Output

对应每组数据,输出Tr(A^k)%9973。

Sample Input

2
2 2
1 0
0 1
3 99999999
1 2 3
4 5 6
7 8 9

Sample Output

2
2686

一个简单的矩阵快速幂,刚学 拿来练模版(网上随便找了个,可惜没找到结构体的那个)

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<string.h>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<cstdlib>
typedef long long ll;
typedef unsigned long long LL;
using namespace std;
const int INF=0x3f3f3f3f;
const int num=100;
const int mod=9973;
int N;
struct Mat{
    int a[num][num];
    void init(){
        memset(a,0,sizeof(a));
        for(int i=0;i<num;i++)
            a[i][i]=1;
    }
};
//矩阵加法
Mat add(Mat a,Mat b){
    Mat ans;
    for(int i=0;i<N;i++)
    for(int j=0;j<N;j++){
        ans.a[i][j]=a.a[i][j]+b.a[i][j];
        ans.a[i][j]=ans.a[i][j]%mod;
    }
    return ans;
}
//矩阵乘法
Mat mul(Mat a,Mat b){
    Mat ans;
    for(int i=0;i<N;i++){
    for(int j=0;j<N;j++){
        ans.a[i][j]=0;
        for(int k=0;k<N;k++){
            ans.a[i][j]+=a.a[i][k]*b.a[k][j];
        }
        ans.a[i][j]=ans.a[i][j]%mod;
    }
    }
    return ans;
}
//矩阵快速幂
Mat power(Mat a,int n){
    Mat ans;
    ans.init();
    while(n){
        if(n&1){
            ans=mul(ans,a);
        }
        n=n>>1;
        a=mul(a,a);
    }
    return ans;
}
//矩阵的幂和
Mat pow_sum(Mat a,int n){
    int m;
    Mat ans,pre;
    if(n==1){
        return a;
    }
    m=n/2;
    pre=pow_sum(a,m);
    ans=add(pre,mul(pre,power(a,m)));
    if(n&1)
        ans=add(ans,power(a,n));
    return ans;
}
void output(Mat a){
    for(int i=0;i<N;i++){
    for(int j=0;j<N;j++){
        if(j==0)printf("%d",a.a[i][j]);
        else printf(" %d",a.a[i][j]);
    }
    printf("\n");
    }
}
int main(){
    int tt;
    int k,n;
    scanf("%d",&tt);
    while(tt--){
        int t=0;
        scanf("%d%d",&n,&k);
        Mat a;
        N=n;
        for(int i=0;i<N;i++){
        for(int j=0;j<N;j++)
            scanf("%d",&a.a[i][j]);
        }
        Mat ans=power(a,k);
        //output(ans);
        for(int i=0;i<N;i++){
            t=(t+ans.a[i][i])%mod;
        }
        printf("%d\n",t);
    }
    return 0;
}
时间: 2024-10-15 04:31:00

HDU 1575的相关文章

矩阵快速幂——将运算推广到矩阵上HDU 1575

/* 本题的思路比较简单,就是将递推公式写出来,然后表达成为一个矩阵的形式 最后通过计算就可以得到一个符合题目要求的矩阵, 然后就是将矩阵上面所有的对角线元素相加 得到的结果即为所求的目标 */ #include<cstdio>  #include<cstring>  using namespace std;  const int maxn = 15;  #define mod 9973  int res[maxn][maxn];  int n;  void mul(int a[]

HDU 1575 &amp;&amp; 1757 矩阵快速幂&amp;&amp;构造矩阵入门

HDU 1575 Tr A Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2912    Accepted Submission(s): 2167 Problem Description A为一个方阵,则Tr A表示A的迹(就是主对角线上各项的和),现要求Tr(A^k)%9973. Input 数据的第一行是一个T,表示有T组数据.每组

HDU 1575 Tr A(矩阵高速幂)

题目地址:HDU 1575 矩阵高速幂裸题. 初学矩阵高速幂.曾经学过高速幂.今天一看矩阵高速幂,原来其原理是一样的,这就好办多了.都是利用二分的思想不断的乘.仅仅只是把数字变成了矩阵而已. 代码例如以下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #i

题解报告:hdu 1575 Tr A

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1575 Problem Description A为一个方阵,则Tr A表示A的迹(就是主对角线上各项的和),现要求Tr(A^k)%9973. Input 数据的第一行是一个T,表示有T组数据.每组数据的第一行有n(2 <= n <= 10)和k(2 <= k < 10^9)两个数据.接下来有n行,每行有n个数据,每个数据的范围是[0,9],表示方阵A的内容. Output 对应每组数据

HDU 1575 Tr A 【矩阵经典2 矩阵快速幂入门】

任意门:http://acm.hdu.edu.cn/showproblem.php?pid=1575 Tr A Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 7572    Accepted Submission(s): 5539 Problem Description A为一个方阵,则Tr A表示A的迹(就是主对角线上各项的和),现要

HDU 1575 Tr A(矩阵快速幂)

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5537    Accepted Submission(s): 4161 Problem Description A为一个方阵,则Tr A表示A的迹(就是主对角线上各项的和),现要求Tr(A^k)%9973. Input 数据的第一行是一个T,表示有T组数据.每组数据的第一行有n(2 <=

hdu 1575 Tr A(矩阵快速幂乘法优化算法)

Problem Description A为一个方阵,则Tr A表示A的迹(就是主对角线上各项的和),现要求Tr(A^k)%9973. Input 数据的第一行是一个T,表示有T组数据. 每组数据的第一行有n(2 <= n <= 10)和k(2 <= k < 10^9)两个数据.接下来有n行,每行有n个数据,每个数据的范围是[0,9],表示方阵A的内容. Output 对应每组数据,输出Tr(A^k)%9973. Sample Input 2 2 2 1 0 0 1 3 99999

HDU 1575 EASY

#include <iostream> #include <cstdio> #include <cstring> #include <algorithm> using namespace std; int n,M=9973; struct Matrax { int m[15][15]; }; Matrax a,per; void initial(){ int i,j; for(i=0;i<n;i++){ for(j=0;j<n;j++){ sca

hdu 1575 try a 矩阵快速幂

#include<cstring> #include<cstdlib> #include<cstdio> #include<cmath> #include<queue> #include<stack> #include<algorithm> #include<iostream> using namespace std; #define ll long long int const int m=9973; ll

hdu 1575 求一个矩阵的k次幂 再求迹 (矩阵快速幂模板题)

Problem DescriptionA为一个方阵,则Tr A表示A的迹(就是主对角线上各项的和),现要求Tr(A^k)%9973. Input数据的第一行是一个T,表示有T组数据.每组数据的第一行有n(2 <= n <= 10)和k(2 <= k < 10^9)两个数据.接下来有n行,每行有n个数据,每个数据的范围是[0,9],表示方阵A的内容. Output对应每组数据,输出Tr(A^k)%9973. Sample Input22 21 00 13 999999991 2 34