CODE[VS] 1294 全排列

1294 全排列

时间限制: 1 s

空间限制: 128000 KB

题目等级 : 黄金 Gold

题解

查看运行结果

题目描述 Description

给出一个n, 请输出n的所有全排列

输入描述 Input Description

读入仅一个整数n   (1<=n<=10)

输出描述 Output Description

一共n!行,每行n个用空格隔开的数,表示n的一个全排列。并且按全排列的字典序输出。

样例输入 Sample Input

3

样例输出 Sample Output

1 2 3

1 3 2

2 1 3

2 3 1

3 1 2

3 2 1

这个题目个人是用深搜解决的,貌似用STL的话就很简单了

就是先搜索那个数放第一,再递归放后面的数

这题目竟然卡了printf,scanf,我还能说什么

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int visit[11];
int b[11];
int n;
void dfs(int i)
{
    if(i>n)
    {
        for(int j=1;j<=n;j++)
        {
            if(j!=n)
                printf("%d ",b[j]);
            else printf("%d\n",b[j]);
        }
        return;
    }
    else
    {
        for(int j=1;j<=n;j++)
        {
            if(!visit[j])
            {
                b[i] = j;
                visit[j] = 1;
                dfs(i+1);
                visit[j] = 0;
            }
        }
    }
}
int main()
{
    scanf("%d",&n);
    memset(visit,0,sizeof(visit));
    dfs(1);
    return 0;
}
时间: 2024-10-07 21:16:59

CODE[VS] 1294 全排列的相关文章

[Wikioi 1294]全排列---两种不同的解法(复习)

题目描述 Description 给出一个n, 请输出n的所有全排列 输入描述 Input Description 读入仅一个整数n   (1<=n<=10) 输出描述 Output Description 一共n!行,每行n个用空格隔开的数,表示n的一个全排列.并且按全排列的字典序输出. 样例输入 Sample Input 3 样例输出 Sample Output 1 2 3 1 3 2 2 1 3 2 3 1 3 1 2 3 2 1 数据范围及提示 Data Size & Hint

codevs——1294 全排列

1294 全排列 时间限制: 1 s 空间限制: 128000 KB 题目等级 : 黄金 Gold 题解 查看运行结果 题目描述 Description 给出一个n, 请输出n的所有全排列 输入描述 Input Description 读入仅一个整数n   (1<=n<=10) 输出描述 Output Description 一共n!行,每行n个用空格隔开的数,表示n的一个全排列.并且按全排列的字典序输出. 样例输入 Sample Input 3 样例输出 Sample Output 1 2

wikioi 1294 全排列 dfs

1294 全排列 时间限制: 1 s 空间限制: 128000 KB 题目等级 : 黄金 Gold 题目描述 Description 给出一个n, 请输出n的所有全排列 输入描述 Input Description 读入仅一个整数n   (1<=n<=10) 输出描述 Output Description 一共n!行,每行n个用空格隔开的数,表示n的一个全排列.并且按全排列的字典序输出. 样例输入 Sample Input 3 样例输出 Sample Output 1 2 3 1 3 2 2

codevs 1294 全排列 next_permuntation

#include<bits/stdc++.h> using namespace std; #define ll long long #define pi (4*atan(1.0)) #define eps 1e-14 const int N=2e5+10,M=4e6+10,inf=1e9+10,mod=1e9+7; const ll INF=1e18+10; int a[N]; int main() { int n; scanf("%d",&n); for(int

CodeVS 1294 全排列(dfs)

题目: http://codevs.cn/problem/1294/ 代码(用cout 会超时!!!): #include <iostream> #include<cstdio> using namespace std; int n; bool visited[15] = {false}; int res[15] = {0}; void dfs(int m) { if(m > n) { for(int i = 1; i < n; i++) { printf("

POJ1850 Code【全排列】

题目链接: http://poj.org/problem?id=1850 题目大意: 给你一个字符串str,输出str在字典序全排列中的位置(从小到大排列). 解题思路: 参考博文:http://www.cnblogs.com/lyy289065406/archive/2011/07/31/2122760.html 先判断str是不是升序序列,如果是升序序列,则为字典序的第1个,输出1. 不符合第一步的话,则分为两步计算str的字典序位置. 先计算比 str 的长度少的字符串总个数. 再计算长度

题目1120:全排列

题目描述: 给定一个由不同的小写字母组成的字符串,输出这个字符串的所有全排列.我们假设对于小写字母有'a' < 'b' < ... < 'y' < 'z',而且给定的字符串中的字母已经按照从小到大的顺序排列. 输入: 输入只有一行,是一个由不同的小写字母组成的字符串,已知字符串的长度在1到6之间. 输出: 输出这个字符串的所有排列方式,每行一个排列.要求字母序比较小的排列在前面.字母序如下定义:已知S = s1s2...sk , T = t1t2...tk,则S < T 等价

组合数学 + STL --- 利用STL生成全排列

Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4730    Accepted Submission(s): 2840 Problem Description Now our hero finds the door to the BEelzebub feng5166. He op

mysql error code及意义

mysql error code(备忘) 转1005:创建表失败 1006:创建数据库失败 1007:数据库已存在,创建数据库失败 1008:数据库不存在,删除数据库失败 1009:不能删除数据库文件导致删除数据库失败 1010:不能删除数据目录导致删除数据库失败 1011:删除数据库文件失败 1012:不能读取系统表中的记录 1020:记录已被其他用户修改 1021:硬盘剩余空间不足,请加大硬盘可用空间 1022:关键字重复,更改记录失败 1023:关闭时发生错误 1024:读文件错误 102