HDOJ 1317 XYZZY

spfa找正环

XYZZY

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2344    Accepted Submission(s): 589

Problem Description

It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are
winnable.

Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player‘s energy. This process continues
until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.

Input

The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:

the energy value for room i

the number of doorways leaving room i

a list of the rooms that are reachable by the doorways leaving room i

The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output

In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".

Sample Input

5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1

Sample Output

hopeless
hopeless
winnable
winnable

Source

University of Waterloo Local Contest 2003.09.27

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>

using namespace std;

const int maxn=211;

vector<int> g[maxn];
int dist[maxn],inq[maxn],cq[maxn];
int vis[maxn],energy[maxn],n;

void dfs(int u)
{
    vis[u]=true;
    for(int i=0,sz=g[u].size();i<sz;i++)
    {
        int v=g[u][i];
        if(vis[v]) continue;
        dfs(v);
    }
}

bool spfa()
{
    memset(dist,0xcf,sizeof(dist));
    memset(inq,0,sizeof(inq));
    memset(cq,0,sizeof(cq));

    dist[1]=0;
    inq[1]=cq[1]=1;
    queue<int> q;
    q.push(1);

    while(!q.empty())
    {
        int u=q.front(); q.pop();
        for(int i=0,sz=g[u].size();i<sz;i++)
        {
            int v=g[u][i];
            int newvalue=dist[u]+energy[v];
            if(newvalue>-100)
            if(dist[v]<newvalue)
            {
                dist[v]=newvalue;
                if(inq[v]==0)
                {
                    inq[v]=1;
                    cq[v]++;
                    if(cq[v]>=n)
                    {
                        memset(vis,0,sizeof(vis));
                        dfs(v);
                        if(vis[n]) return true;
                        continue;
                    }
                    q.push(v);
                }
            }
        }
        inq[u]=0;
    }
    if(dist[n]>-100) return true;
    return false;
}

int main()
{
    int a,b,c;
    while(scanf("%d",&n)!=EOF&&~n)
    {
        for(int i=1;i<=n;i++)
        {
            g[i].clear();
            scanf("%d",energy+i);
            scanf("%d",&a);
            for(int j=1;j<=a;j++)
            {
                scanf("%d",&b);
                g[i].push_back(b);
            }
        }
        if(spfa()) puts("winnable");
        else puts("hopeless");
    }
    return 0;
}

HDOJ 1317 XYZZY,布布扣,bubuko.com

时间: 2024-11-12 23:28:52

HDOJ 1317 XYZZY的相关文章

HDU 1317 XYZZY

题意是指 从1 到 N 能否保证 到达每个点的时候 能量都为正数. 起点 1 初始100 点能量. 输入是 从 1 ~ N , 分别是 能量,能到m个房间, 分别是 a1,a2,a3,-,am 可以给每个能到达的点 而 产生的边赋权,即能量值. SPFA 求最长路的变形,出现负环不怕,出现正环就需要一点改动. vis[]标记是否需要入队,d[] 表示能量,que[] 表示入队次数. 如果出现正环(que[v]>=n),表明一定能 保证到达每个点的时候都是正能量. 这时候直接 将 d[v] 赋最大

hdu 1317 XYZZY(spfa判环)

http://acm.hdu.edu.cn/showproblem.php?pid=1317 大致题意:有n个房间,每个房间都有对应的能量值(可正可负),现在从1出发要到达n,初始能量为100,问是否能够达到n点,到达n的条件是中间及最后的能量值都要大于0. 思路:若不考虑环,那么求最长路判断是否大于0即可.若存在负环,对求最长路也没影响:但当存在正环时,最长路就不存在了.可用spfa判断,当某点入队超过n次,那么它必定在环中,直接将其dis置为INF,并不再将其近队列.最后若能到达n则可行,否

HDU 1317 XYZZY (SPFA 找正环 + Floyd 判连通)

XYZZY Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3004    Accepted Submission(s): 817 Problem Description It has recently been discovered how to run open-source software on the Y-Crate gami

HDU 1317 XYZZY(floyd+bellman_ford判环)

http://acm.hdu.edu.cn/showproblem.php?pid=1317 题意: 给出一个有向图,每到达一个点,都会加上或减去一些能量,我们要做的就是判断从1出发是否能到达n.初始能量有100,行走的途中能量不能小于等于0. 思路: 首先我们用floyd来判断一下1和n之间是否有通路. 其次就是bellman_ford算法来判正环了. 1 #include <iostream> 2 #include <cstring> 3 #include <algori

hdu 1317 XYZZY 国产SPFA算法AC,,题目输入部分真特么难懂。。内有解析

XYZZY Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3017    Accepted Submission(s): 824 Problem Description It has recently been discovered how to run open-source software on the Y-Crate gami

HDU 1317 XYZZY【Bellman_Ford判断正环】

题意:给出n个房间,初始在房间1有100的能量值,每次进入一个房间,能量值可能增加也可能减小,(是点权,不是边权),问能否到达终点的时候能量值还为正 这题自己写的时候wa--wa-- 后来看了题解,还是wa---wa--- 题解很详细http://blog.csdn.net/freezhanacmore/article/details/9937327 记录下自己犯的错误吧 首先是floyd函数初始化的时候,直接写在了函数里面,这样是不对的,因为输入值在前,调用函数在后,这样就相当于将之前输入的可

HDU - 1317 XYZZY (floyd + 最长路)

题目大意:有一种游戏,游戏里面有N个房间,每个房间有相应的能量值,走入该房间就可以得到相应的能量值 现在你要从房间1出发,走到房间N,如果中途能量耗尽了,就表示输了,反之,则为赢 解题思路:首先得判断一下能不能到达N,这可以用Floyd去判断 如果能直接走到N的话,就算赢,否则判断一下,看是否有正环,且正环中有点能到N #include <cstdio> #include <cstring> #include <algorithm> #include <vecto

【HDOJ图论题集】【转】

1 =============================以下是最小生成树+并查集====================================== 2 [HDU] 3 1213 How Many Tables 基础并查集★ 4 1272 小希的迷宫 基础并查集★ 5 1325&&poj1308 Is It A Tree? 基础并查集★ 6 1856 More is better 基础并查集★ 7 1102 Constructing Roads 基础最小生成树★ 8 1232

题单二:图论500

http://wenku.baidu.com/link?url=gETLFsWcgddEDRZ334EJOS7qCTab94qw5cor8Es0LINVaGMSgc9nIV-utRIDh--2UwRLvsvJ5tXFjbdpzbjygEdpGehim1i5BfzYgYWxJmu ==========  以下是最小生成树+并查集=========================[HDU]1213         How Many Tables        基础并查集★1272         小